[PATCH] gnu: Add gnome-shell-extension-fly-pie

  • Open
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Maxim Cournoyer
  • phodina
Owner
unassigned
Submitted by
phodina
Severity
normal
P
P
phodina wrote on 10 Jan 2023 02:23
(name . Guix Patches)(address . guix-patches@gnu.org)
3twSZ6ug0xQ7R3m0gDjGyUbI3jx5f2yke-CVBb5Y0-YdGVxh-uYVS61q35D2GL5ITQU3R4cFgOD6uvppWXIJEJqedAdjylgE9TR07gvr5X0=@protonmail.com
Hi,

this patch adds Fly Pie Gnome Shell extension which provides alternative way around menus.

However, I have been unable to get the settings working - they never launch. Maybe somebody will
know what's missing :-)

----
Petr
Attachment: file
From e224a0d30f73970d1d43cdc01dec10761940695a Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Tue, 10 Jan 2023 01:59:08 +0100
Subject: [PATCH] gnu: Add gnome-shell-extension-fly-pie.

* gnu/packages/gnome-xyz.scm (gnome-shell-extension-fly-pie): New variable.

Toggle diff (53 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 0f3b6b6f43..c5b5d49e45 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1090,6 +1090,46 @@ (define-public gnome-shell-extension-blur-my-shell
GNOME Shell, including the top panel, dash and overview.")
(license license:gpl3)))
+(define-public gnome-shell-extension-fly-pie
+ (package
+ (name "gnome-shell-extension-fly-pie")
+ (version "17")
+ (home-page "https://github.com/Schneegans/Fly-Pie")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ifkqlg2bp2vz2abakghv3zqkay0gzfljp9y252b6kpnm3fh4wvw"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan '(("."
+ "share/gnome-shell/extensions/flypie@schneegans.github.com"
+ #:include-regexp ("\\.js(on)?$" "\\.css$"
+ "\\.ui$"
+ "\\.png$"
+ "\\.xml$"
+ "\\.compiled$"
+ "\\.gresource$")))
+ #:phases (modify-phases %standard-phases
+ (add-before 'install 'compile-resources
+ (lambda _
+ (invoke "make" "resources/flypie.gresource")))
+ (add-before 'install 'compile-schemas
+ (lambda _
+ (with-directory-excursion "schemas"
+ (invoke "glib-compile-schemas" ".")))))))
+ (native-inputs (list `(,glib "bin") gettext-minimal))
+ (synopsis "Fly-Pie is an innovative marking menu written as a GNOME Shell
+extension")
+ (description
+ "Unite is a GNOME Shell extension which lets you launch applications,
+simulate hotkeys, open URLs using seamless marking menu.")
+ (license license:expat)))
+
(define-public gnome-shell-extension-radio
(package
(name "gnome-shell-extension-radio")
--
2.38.1
L
L
Liliana Marie Prikler wrote on 10 Jan 2023 06:19
(name . monego@posteo.net)(address . monego@posteo.net)
88baf3122ef9b9c1e7f7130f96d094e9716d7aac.camel@gmail.com
Am Dienstag, dem 10.01.2023 um 01:23 +0000 schrieb phodina:
Toggle quote (7 lines)
> Hi,
>
> this patch adds Fly Pie Gnome Shell extension which provides
> alternative way around menus.
>
> However, I have been unable to get the settings working - they never
> launch. Maybe somebody will know what's missing :-)
Haven't looked at it in detail, but I'm pretty sure it's libadwaita.
There are some gjs-based apps, that have been wrapped to get their GI
libraries, but so far none of them are extensions. Perhaps we should
make this one an example?

Cheers
M
M
Maxim Cournoyer wrote on 21 Mar 2023 21:20
control message for bug #60700
(address . control@debbugs.gnu.org)
877cv9n9ef.fsf@gmail.com
tags 60700 + moreinfo
quit
?