[PATCH] gnu: git-annex: Patch 'git-annex webapp' to use hardcoded lsof.

  • Done
  • quality assurance status badge
Details
3 participants
  • Thompson, David
  • Efraim Flashner
  • Simon Tournier
Owner
unassigned
Submitted by
Thompson, David
Severity
normal

Debbugs page

Thompson, David wrote 2 years ago
(address . guix-patches@gnu.org)
CAJ=RwfYjG-=J=FP53jQ2q8VtNa5Pi8pGT6_fPwCFFC9qVkGLVw@mail.gmail.com
Hi all,

I'm back with another 'git-annex webapp' patch. In order for the
git-annex assistant's file watching capabilities to work it needs
access to the lsof utility.

WDYT?

- Dave
From 86914063988c01eb399097e7746a81a4ae51c159 Mon Sep 17 00:00:00 2001
From: David Thompson <dthompson2@worcester.edu>
Date: Mon, 9 Jan 2023 18:06:10 -0500
Subject: [PATCH] gnu: git-annex: Patch 'git-annex webapp' to use hardcoded
lsof.

* gnu/packages/haskell-apps.scm (git-annex)[arguments]: Substitute "lsof" in
'patch-webapp' phase.
[inputs]: Add lsof.
---
gnu/packages/haskell-apps.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 4ac486eeb6..9cb383eeb2 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -50,6 +50,7 @@ (define-module (gnu packages haskell-apps)
#:use-module (gnu packages haskell-crypto)
#:use-module (gnu packages haskell-web)
#:use-module (gnu packages haskell-xyz)
+ #:use-module (gnu packages lsof)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -335,7 +336,11 @@ (define-public git-annex
;; webapp' runs without making the user also install xdg-utils.
(substitute* '("Assistant/WebApp/DashBoard.hs"
"Utility/WebApp.hs")
- (("xdg-open") (which "xdg-open")))))
+ (("xdg-open") (which "xdg-open")))
+ ;; Also replace loose references to lsof.
+ (substitute* "Assistant/Threads/Watcher.hs"
+ (("\"lsof\"")
+ (string-append "\"" (which "lsof") "\"")))))
(add-before 'configure 'factor-setup
(lambda _
;; Factor out necessary build logic from the provided
@@ -480,6 +485,7 @@ (define-public git-annex
ghc-yesod-core
ghc-yesod-form
ghc-yesod-static
+ lsof
rsync
xdg-utils))
(propagated-inputs
--
2.38.1
Simon Tournier wrote 2 years ago
87v8l6s8k3.fsf@gmail.com
Hi,

On lun., 09 janv. 2023 at 18:10, "Thompson, David" <dthompson2@worcester.edu> wrote:

Toggle quote (4 lines)
> * gnu/packages/haskell-apps.scm (git-annex)[arguments]: Substitute "lsof" in
> 'patch-webapp' phase.
> [inputs]: Add lsof.

LGTM.

Cheers,
simon
Efraim Flashner wrote 2 years ago
(name . Thompson, David)(address . dthompson2@worcester.edu)(address . 60698-done@debbugs.gnu.org)
ZH7LYg8IgDbGNfhN@3900XT
Patch was pushed, closing the bug.

--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmR+y2IACgkQQarn3Mo9
g1E5eRAAt3VoHZtFHwv8HhO/eJHgrFBO3s7tNZHmkfehVMz2zMpqIg0H0nVCo58B
khe242N5KBwaozkkueFr4YvEQdDmNZTXoyRJ6ZIfutYpmsVyL81aFhIaLAEK52L1
JUFM6SQTukLxY4u/o3N76kr2HEsXDcfxrLP6G+z/94oy5/zqKvdECA2cL3yvABxH
uw7YqPtN8PqPwvuxqukjOzXp7gVRsRg2c+1dDOlL6Rlj+RvUyjWEDBE0z27WAfTv
XR77fHIYk40lLnceiXOdwyFeTq6UvOqsevnNDabTALQ8eUGmnLGsKz7uHPMshS/P
po+6IF8W56IBDCmSXTZ19nyeDxzZWcgY4Q70cYUQak+bXVogQcVPw/wdO9JbTBkk
ZUrlUTiFaMVWyMFxGsL53JzBZ8ChgQUVoruxaOu4dSgVE66f4ngtz8/SVY4uH2qo
4h3UysdG0pb3G9uvSDgYqWGaYJ/WQN+d6es9mOPl3qFatoCjhd6AjQoPmyyuPBZb
TkKkZ4B7B0vyQZGyzrNbNy3A6ZCm7SY45MhYd6b2KoxRi7X/DnHGocDHNuy5QS42
O+AYWj1glfUxHm1ClK+gqF8INb4gcCZAg1Ha6YBV3yySAUJmzAFs4xoGg8GZD8mU
L0NZL0nDAXgt38gk0ulnoBh1bmFGgo2e4KfP/gtZx8qPqdgWdVo=
=imqZ
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60698@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60698
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help