update guile version for guile-aa-tree and fix install.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Bruno Victal
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
N
N
Nicolas Graves wrote on 8 Jan 2023 15:12
(address . guix-patches@gnu.org)
87h6x1dsif.fsf@ngraves.fr
Hi guix!

Small patch series to update guile-aa-tree guiel version and properly
install only the right scheme file (i.e. removing the test file from
install).

--
Best regards,
Nicolas Graves
N
N
Nicolas Graves wrote on 8 Jan 2023 17:03
[PATCH 1/3] gnu: guile-aa-tree: Restrict install to aa-tree.scm.
(address . 60658@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20230108160317.14909-1-ngraves@ngraves.fr
* gnu/packages/guile-xyz.scm (guile-aa-tree):
[native-inputs]: Remove guile-2.2.
[inputs]: Add guile-2.2.
[arguments]: (scheme-file-regexp): Restrict install to aa-tree.scm
[arguments]: (phases): Add check phase.
---
gnu/packages/guile-xyz.scm | 18 +++++++++++++++++-
1 file changed, 17 insertions(+), 1 deletion(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 2dd5a520d1..68150c89d0 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1261,7 +1261,23 @@ (define-public guile-aa-tree
(base32
"0044c105r3q9vpl17pv3phl1b79kjm1llhkakqgiasixyav01blh"))))
(build-system guile-build-system)
- (native-inputs (list guile-2.2))
+ (inputs (list guile-2.2))
+ (arguments
+ (list
+ #:scheme-file-regexp "^aa-tree\\.scm"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'install-documentation 'check
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let* ((guile #$(this-package-input "guile"))
+ (effective (target-guile-effective-version guile))
+ (go-dir (string-append #$output "/lib/guile/"
+ effective "/site-ccache/")))
+ (invoke (search-input-file inputs "/bin/guile")
+ "--no-auto-compile"
+ "-C" go-dir
+ "-c" (string-append
+ "(load \"" (getcwd) "/test-aa-tree.scm\")"))))))))
;; https://savannah.nongnu.org/projects/guile-aa-tree
(home-page "https://qlfiles.net/guile-aa-tree/")
(synopsis "AA tree data structure for Guile")
--
2.38.1
N
N
Nicolas Graves wrote on 8 Jan 2023 17:03
[PATCH 2/3] gnu: guile-aa-tree: Format origin.
(address . 60658@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20230108160317.14909-2-ngraves@ngraves.fr
* gnu/packages/guile-xyz.scm (guile-aa-tree): Format origin.
---
gnu/packages/guile-xyz.scm | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 68150c89d0..f5969dfe19 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1253,13 +1253,13 @@ (define-public guile-aa-tree
(package
(name "guile-aa-tree")
(version "3.1.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://savannah/guile-aa-tree/guile-aa-tree-"
- version ".tar.gz"))
- (sha256
- (base32
- "0044c105r3q9vpl17pv3phl1b79kjm1llhkakqgiasixyav01blh"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://savannah/guile-aa-tree/guile-aa-tree-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0044c105r3q9vpl17pv3phl1b79kjm1llhkakqgiasixyav01blh"))))
(build-system guile-build-system)
(inputs (list guile-2.2))
(arguments
--
2.38.1
N
N
Nicolas Graves wrote on 8 Jan 2023 17:03
[PATCH 3/3] gnu: guile-aa-tree: Update Guile version to 3.0 .
(address . 60658@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20230108160317.14909-3-ngraves@ngraves.fr
* gnu/packages/guile-xyz.scm (guile-aa-tree): Update Guile version to 3.0.
---
gnu/packages/guile-xyz.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index f5969dfe19..ea05fd932c 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1261,7 +1261,7 @@ (define-public guile-aa-tree
(sha256
(base32 "0044c105r3q9vpl17pv3phl1b79kjm1llhkakqgiasixyav01blh"))))
(build-system guile-build-system)
- (inputs (list guile-2.2))
+ (inputs (list guile-3.0))
(arguments
(list
#:scheme-file-regexp "^aa-tree\\.scm"
--
2.38.1
B
B
Bruno Victal wrote on 11 Jan 2023 18:37
(no subject)
(name . control)(address . control@debbugs.gnu.org)
f77e6554-a24d-1b0a-924d-3eeea473f720@makinata.eu
retitle 60732 [PATCH] gnu: Add package python-scapy
tags 60732 + patch

tags 60658 + patch
tags 60661 + patch
tags 60539 + patch
tags 60540 + patch
tags 60640 + patch

quit
L
L
Ludovic Courtès wrote on 12 Jan 2023 23:21
Re: bug#60658: update guile version for guile-aa-tree and fix install.
(name . Nicolas Graves)(address . ngraves@ngraves.fr)(address . 60658-done@debbugs.gnu.org)
87sfgffl6h.fsf@gnu.org
Hi,

Nicolas Graves <ngraves@ngraves.fr> skribis:

Toggle quote (4 lines)
> Small patch series to update guile-aa-tree guiel version and properly
> install only the right scheme file (i.e. removing the test file from
> install).

Applied, except for the ‘origin’ reindentation since ‘guix style’ would
keep it as it was (which some don’t like it seems, but hey).

Thanks,
Ludo’.
Closed
?