[PATCH staging] gnu: glew: Update to 2.2.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • 宋文武
  • Parnikkapore
Owner
unassigned
Submitted by
Parnikkapore
Severity
normal

Debbugs page

Parnikkapore wrote 2 years ago
(address . guix-patches@gnu.org)
f46d6c545ac9ad8c53c66235c9c28ca77794c61a.1673150797.git.poomklao@yahoo.com
* gnu/packages/gl.scm (glew): Update to 2.2.0.
[source] Migrato to GitHub, which is now the canonical source
[home-page] Use HTTPS
---
gnu/packages/gl.scm | 35 ++++++++++++++++++++---------------
1 file changed, 20 insertions(+), 15 deletions(-)

Toggle diff (65 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 01ab6135a4..136b0bdf2f 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -616,36 +616,41 @@ (define-public mesa-utils
(define-public glew
(package
(name "glew")
- (version "2.1.0")
+ (version "2.2.0")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://sourceforge/glew/glew/" version
- "/glew-" version ".tgz"))
+ (uri (string-append
+ "https://github.com/nigels-com/glew/releases"
+ "/download/glew-"
+ version
+ "/glew-"
+ version
+ ".tgz"))
(sha256
(base32
- "159wk5dc0ykjbxvag5i1m2mhp23zkk6ra04l26y3jc3nwvkr3ph4"))
+ "1qak8f7g1iswgswrgkzc7idk7jmqgwrs58fhg2ai007v7j4q5z6l"))
(modules '((guix build utils)))
- (snippet
- '(begin
- (substitute* "config/Makefile.linux"
- (("= cc") "= gcc")
- (("/lib64") "/lib"))
- #t))))
+ (snippet '(begin
+ (substitute* "config/Makefile.linux"
+ (("= cc")
+ "= gcc")
+ (("/lib64")
+ "/lib")) #t))))
(build-system gnu-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases (delete 'configure))
+ '(#:phases (modify-phases %standard-phases
+ (delete 'configure))
#:make-flags (list (string-append "GLEW_PREFIX="
(assoc-ref %outputs "out"))
(string-append "GLEW_DEST="
(assoc-ref %outputs "out")))
- #:tests? #f)) ;no 'check' target
- (inputs
- (list libxi libxmu libx11 mesa))
+ #:tests? #f)) ;no 'check' target
+ (inputs (list libxi libxmu libx11 mesa))
;; <GL/glew.h> includes <GL/glu.h>.
(propagated-inputs (list glu))
- (home-page "http://glew.sourceforge.net/")
+ (home-page "https://glew.sourceforge.net/")
(synopsis "OpenGL extension loading library for C and C++")
(description
"The OpenGL Extension Wrangler Library (GLEW) is a C/C++ extension

base-commit: db3fdbbdfee9d412053cc9538ad76abee7c2cb89
--
2.34.1
宋文武 wrote 2 years ago
(name . Parnikkapore)(address . poomklao@yahoo.com)(address . 60642-done@debbugs.gnu.org)
87zga1hiys.fsf_-_@envs.net
Parnikkapore <poomklao@yahoo.com> writes:

Toggle quote (2 lines)
> * gnu/packages/gl.scm (glew): Update to 2.2.0.

Hello, on the staging branch glew is 2.2.0 already, close this, thank
you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60642@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60642
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help