[PATCH 0/1] mumi: Depend on guile-email, not guile-email-latest

  • Done
  • quality assurance status badge
Details
3 participants
  • Arun Isaac
  • Ricardo Wurmus
  • Simon Tournier
Owner
unassigned
Submitted by
Arun Isaac
Severity
normal

Debbugs page

Arun Isaac wrote 2 years ago
(name . Arun Isaac)(address . arunisaac@systemreboot.net)
20230106202426.528-1-arunisaac@systemreboot.net
Hi Ricardo,

With the release of guile-email 0.3.0, I think we should remove
guile-email-latest and have mumi depend on guile-email instead. WDYT?

Regards,
Arun

Arun Isaac (1):
gnu: guile-email-latest: Remove package.

gnu/packages/guile-xyz.scm | 20 --------------------
gnu/packages/mail.scm | 4 ++--
2 files changed, 2 insertions(+), 22 deletions(-)

--
2.38.1
Arun Isaac wrote 2 years ago
[PATCH] gnu: guile-email-latest: Remove package.
(address . 60606@debbugs.gnu.org)
20230106202624.819-1-arunisaac@systemreboot.net
* gnu/packages/guile-xyz.scm (guile-email-latest): Delete variable.
* gnu/packages/mail.scm (mumi)[inputs]: Replace guile-email-latest with
guile-email.
---
gnu/packages/guile-xyz.scm | 20 --------------------
gnu/packages/mail.scm | 4 ++--
2 files changed, 2 insertions(+), 22 deletions(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 1ed8290ba6..ca75305fac 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1503,26 +1503,6 @@ (define-public guile-email
format.")
(license license:agpl3+)))
-(define-public guile-email-latest
- (let ((commit "ea60bb902d3677d5c653851c7aa6afbbf710140e")
- (revision "2"))
- (package
- (inherit guile-email)
- (name "guile-email-latest")
- (version (git-version "0.2.2" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.systemreboot.net/guile-email")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1g4rn7ai3nfxmpppc8qbpv8b18wnsld29y5xa58cv9b8pf3pbwnj"))))
- (native-inputs
- (list pkg-config autoconf automake texinfo)))))
-
(define-public guile2.2-email
(package
(inherit guile-email)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index de868e948b..369f4dccd8 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2016, 2017 Troy Sankey <sankeytms@gmail.com>
;;; Copyright © 2016, 2017, 2018 Nikita <nikita@n0.is>
;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
-;;; Copyright © 2016–2022 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2016–2023 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2016, 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
@@ -4072,7 +4072,7 @@ (define-public mumi
`("GUILE_LOAD_COMPILED_PATH" ":" prefix
(,go ,(getenv "GUILE_LOAD_COMPILED_PATH"))))))))))
(inputs
- (list guile-email-latest
+ (list guile-email
guile-fibers
guile-gcrypt
guile-json-4
--
2.38.1
Simon Tournier wrote 2 years ago
871qnzygzw.fsf@gmail.com
Hi Arun,

On ven., 06 janv. 2023 at 20:26, Arun Isaac <arunisaac@systemreboot.net> wrote:
Toggle quote (8 lines)
> * gnu/packages/guile-xyz.scm (guile-email-latest): Delete variable.
> * gnu/packages/mail.scm (mumi)[inputs]: Replace guile-email-latest with
> guile-email.
> ---
> gnu/packages/guile-xyz.scm | 20 --------------------
> gnu/packages/mail.scm | 4 ++--
> 2 files changed, 2 insertions(+), 22 deletions(-)

LGTM.

Cheers,
simon
Ricardo Wurmus wrote 2 years ago
Re: [PATCH 0/1] mumi: Depend on guile-email, not guile-email-latest
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 60606-done@debbugs.gnu.org)
87mt6nlcbs.fsf@elephly.net
Arun Isaac <arunisaac@systemreboot.net> writes:

Toggle quote (3 lines)
> With the release of guile-email 0.3.0, I think we should remove
> guile-email-latest and have mumi depend on guile-email instead. WDYT?

Agreed.

I applied it. Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60606@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60606
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help