Artyom V. Poptsov wrote 2 years ago
(address . guix-patches@gnu.org)
Hello,
this patch adds FXTUI[1], a simple C++ library for terminal based user
interfaces.
From 3453ac53e0d1bfe28e5536a89411584fc2461e29 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Thu, 5 Jan 2023 08:03:15 +0300
Subject: [PATCH] gnu: Add ftxui
* gnu/packages/tui.scm: New module.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add "tui.scm".
---
gnu/local.mk | 1 +
gnu/packages/tui.scm | 62 ++++++++++++++++++++++++++++++++++++++++++++
2 files changed, 63 insertions(+)
create mode 100644 gnu/packages/tui.scm
Toggle diff (82 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index bc0309ee87..c110b54bef 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -605,6 +605,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/tmux.scm \
%D%/packages/toolkits.scm \
%D%/packages/tor.scm \
+ %D%/packages/tui.scm \
%D%/packages/tv.scm \
%D%/packages/uglifyjs.scm \
%D%/packages/uml.scm \
diff --git a/gnu/packages/tui.scm b/gnu/packages/tui.scm
new file mode 100644
index 0000000000..7a3037073b
--- /dev/null
+++ b/gnu/packages/tui.scm
@@ -0,0 +1,62 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages tui)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix utils)
+ #:use-module (guix gexp)
+ #:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module (guix packages)
+ #:use-module (guix build-system cmake)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages base)
+ #:use-module (gnu packages version-control))
+
+(define-public ftxui
+ (package
+ (name "ftxui")
+ (version "3.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ArthurSonzogni/FTXUI")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "10a4yw2h29kixxyhll6cvrwyscsvz9asxry857a9l8nqvbhs946s"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f)) ;Tests require gtest
+ (home-page "https://github.com/ArthurSonzogni/FTXUI")
+ (synopsis "C++ Functional Terminal User Interface")
+ (description
+ "Functional Terminal (X) User interface (FTXUI) is a simple C++ library for
+terminal based user interfaces.
+
+Main features:
+@itemize
+@item Functional style.
+@item Keyboard & mouse navigation.
+@item Support for UTF8 and fullwidth chars.
+@item Support for animations.
+@item Support for drawing.
+@item No dependencies.
+@end itemize")
+ (license license:expat)))
--
2.34.1
I decided to place this package in a separate module called "tui.scm" as
there are other libraries for building text-based user interfaces that
can be added in the future (like [2], for example.)
Also to check if the library installed right I tried to build "tiles"
game[3] that is using FXTUI:
Toggle snippet (9 lines)
git clone https://github.com/tusharpm/tiles.git
cd tiles
guix shell binutils gcc
mkdir build
cd build
cmake ..
make -j$(nproc)
Which worked out flawlessly.
Thanks,
- avp
References:
--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
Home page: https://memory-heap.org/~avp/
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----
iQFNBAEBCgA3FiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmO2Yy4ZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRDpxaLZCJigL3p4B/9F0LDO3jhDmelKJVz6Dthl
q2mrIvJFwSfqjroze2RBdTSuovd5gxlzBxOp7w8L6GuprUxhfcgptKLod1BoDfeY
lab7hj3UQ2S0mySfy55OBB2Ij1jS05E0452Y66DrqVaEI1kgdTS5hUuO9T567It5
PQwqCvgeb2X3V5EoclV0ky7ayLO+N+lDgAPt831lr1pVivZyk+kSgkzkzPZN2tYo
2BRyP/YbOeSFrlv2R04dqtvzxF/1KbWF48Dem6mb7DhWCMaL1DPtnlcSWIox4IaX
gpbPAtWQ8LGAvSyh2icvVuI+d/GaCNiLEHDdqmhOZtlthw6kHeoDUrOBMk8AVmnM
=PKyY
-----END PGP SIGNATURE-----