[PATCH 0/1] Fix mingw cross-compilation of nettle

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal

Debbugs page

Vivien Kraus wrote 2 years ago
(name . Vivien Kraus via Guix-patches via)(address . guix-patches@gnu.org)
cover.1672875360.git.vivien@planete-kraus.eu
Dear guix,

nettle separates its static library output from its main output by moving all
files with a ".a" extension. However, doing that also moves the ".dll.a" files
on mingw. These files are required to link against a DLL. Packages that want
to link against the nettle DLL will require the default output of nettle, and
will not want the static output. So, these files must stay in the default
output.

Best regards,

Vivien

Vivien Kraus (1):
gnu: nettle: Fix mingw cross-compilation.

gnu/packages/nettle.scm | 10 ++++++++--
1 file changed, 8 insertions(+), 2 deletions(-)


base-commit: 658c09333da095edf6e1b3c5e351a7bfa3c87354
--
2.38.1
Vivien Kraus wrote 2 years ago
[PATCH 1/1] gnu: nettle: Fix mingw cross-compilation.
(address . 60563@debbugs.gnu.org)
f328720ab29bada6e9652684842074b47125c7e6.1672875360.git.vivien@planete-kraus.eu
* gnu/packages/nettle.scm (nettle-2) [move-static-libraries]: .dll.a files are
not static libraries.
---
gnu/packages/nettle.scm | 10 ++++++++--
1 file changed, 8 insertions(+), 2 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/nettle.scm b/gnu/packages/nettle.scm
index 27bd9efc60..ea26ba3b2d 100644
--- a/gnu/packages/nettle.scm
+++ b/gnu/packages/nettle.scm
@@ -44,7 +44,7 @@ (define-public nettle-2
(arguments
;; 'sexp-conv' and other programs need to have their RUNPATH point to
;; $libdir, which is not the case by default. Work around it.
- '(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
+ `(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out")
"/lib"))
#:phases (modify-phases %standard-phases
@@ -59,7 +59,13 @@ (define-public nettle-2
(rename-file ar (string-append
slib "/"
(basename ar))))
- (find-files "." "\\.a$")))
+ (find-files
+ "."
+ ,(if (target-mingw?)
+ '(lambda (filename _)
+ (and (string-suffix? ".a" filename)
+ (not (string-suffix? ".dll.a" filename))))
+ "\\.a$"))))
#t))))))
(outputs '("out" "debug" "static"))
(native-inputs (list m4))
--
2.38.1
Ludovic Courtès wrote 2 years ago
Re: bug#60563: [PATCH 0/1] Fix mingw cross-compilation of nettle
(name . Vivien Kraus)(address . vivien@planete-kraus.eu)(address . 60563-done@debbugs.gnu.org)
87lelya3kx.fsf_-_@gnu.org
Hi Vivien,

Vivien Kraus <vivien@planete-kraus.eu> skribis:

Toggle quote (3 lines)
> * gnu/packages/nettle.scm (nettle-2) [move-static-libraries]: .dll.a files are
> not static libraries.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60563@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60563
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help