teams: Add scope for Embedded / Bootstrap

  • Done
  • quality assurance status badge
Details
4 participants
  • Josselin Poiret
  • Bruno Victal
  • Mathieu Othacehe
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal

Debbugs page

Vagrant Cascadian wrote 2 years ago
(address . guix-patches@gnu.org)
875ydmalre.fsf@yucca
There are some packages that are obviously related to embedded
(e.g. u-boot from bootloaders.scm, arm-trusted-firmware from
firmware.scm) and bootstrapping (mes.scm).

Patch attached.

live well,
vagrant
From 6c8076261cf1a93134e3435124d4a7e9dcbbba1c Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Tue, 3 Jan 2023 21:41:34 -0800
Subject: [PATCH 3/4] teams: Add scope for Embedded / Bootstrap team.

* etc/teams.scm.in (embedded-bootstrap): Add bootloaders, firmware and mes to
scope.
---
etc/teams.scm.in | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (18 lines)
diff --git a/etc/teams.scm.in b/etc/teams.scm.in
index b3a1c72c28..921c101aa7 100644
--- a/etc/teams.scm.in
+++ b/etc/teams.scm.in
@@ -244,7 +244,10 @@ asdf-build-system."
(define-team embedded-bootstrap
(team 'embedded-bootstrap
- #:name "Embedded / Bootstrap"))
+ #:name "Embedded / Bootstrap"
+ #:scope (list "gnu/packages/bootloaders.scm"
+ "gnu/packages/firmware.scm"
+ "gnu/packages/mes.scm")))
(define-team rust
(team 'rust
--
2.30.2
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCY7UUVgAKCRDcUY/If5cW
qgT9AQCZTbfQBakPz0umrZA5syKQDgQDnOjlt1wdpUiJuFz8YwD/Tks4jgs5+Nz5
Tj5Hm8Mw9btHv1OlXeTvjC8TTecMNQw=
=3axp
-----END PGP SIGNATURE-----

Mathieu Othacehe wrote 2 years ago
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 60540@debbugs.gnu.org)
87lemduopj.fsf@gnu.org
Hello Vagrant,

Toggle quote (8 lines)
> (define-team embedded-bootstrap
> (team 'embedded-bootstrap
> - #:name "Embedded / Bootstrap"))
> + #:name "Embedded / Bootstrap"
> + #:scope (list "gnu/packages/bootloaders.scm"
> + "gnu/packages/firmware.scm"
> + "gnu/packages/mes.scm")))

Seems fine.

I think we could have two distinct teams here: embedded and
bootstrap. There are quite a few people, like me, following closely the
embedded part, but not so closely the bootstrap part.

WDYT?

Thanks,

Mathieu
Vagrant Cascadian wrote 2 years ago
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 60540@debbugs.gnu.org)
87sfgim0wn.fsf@contorta
On 2023-01-08, Mathieu Othacehe wrote:
Toggle quote (14 lines)
>> (define-team embedded-bootstrap
>> (team 'embedded-bootstrap
>> - #:name "Embedded / Bootstrap"))
>> + #:name "Embedded / Bootstrap"
>> + #:scope (list "gnu/packages/bootloaders.scm"
>> + "gnu/packages/firmware.scm"
>> + "gnu/packages/mes.scm")))
>
> Seems fine.
>
> I think we could have two distinct teams here: embedded and
> bootstrap. There are quite a few people, like me, following closely the
> embedded part, but not so closely the bootstrap part.

Yeah, I think they should be split so started a thread on guix-devel:


But I also wanted to start by keeping this patch simple. Although it
could really use a description too ...

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCY73y6AAKCRDcUY/If5cW
qmw9AP0fZ+NG0FUkeUVch4Mjhln9U1R56LqwrE59NdYiPA2KOQEAmjzrcxd8YHFt
KwN9PfOblxKn0FWGg/HQy6x6ST6/HQA=
=+xqE
-----END PGP SIGNATURE-----

Bruno Victal wrote 2 years ago
(no subject)
(name . control)(address . control@debbugs.gnu.org)
f77e6554-a24d-1b0a-924d-3eeea473f720@makinata.eu
retitle 60732 [PATCH] gnu: Add package python-scapy
tags 60732 + patch

tags 60658 + patch
tags 60661 + patch
tags 60539 + patch
tags 60540 + patch
tags 60640 + patch

quit
Vagrant Cascadian wrote 2 years ago
Re: bug#60540: teams: Add scope for Embedded / Bootstrap
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 60540@debbugs.gnu.org)
87lelzzlmt.fsf@contorta
On 2023-01-08, Mathieu Othacehe wrote:
Toggle quote (14 lines)
>> (define-team embedded-bootstrap
>> (team 'embedded-bootstrap
>> - #:name "Embedded / Bootstrap"))
>> + #:name "Embedded / Bootstrap"
>> + #:scope (list "gnu/packages/bootloaders.scm"
>> + "gnu/packages/firmware.scm"
>> + "gnu/packages/mes.scm")))
>
> Seems fine.
>
> I think we could have two distinct teams here: embedded and
> bootstrap. There are quite a few people, like me, following closely the
> embedded part, but not so closely the bootstrap part.

It makes total sense to me, so...

New patch attached which also splits the teams.

They could still probably significantly benefit from
descriptions... though I haven't heard much of anything weighed in on
that from the discussion on guix-devel.

live well,
vagrant
From 0ae1c6951bcfd3c1a83e8a86adcbc6afae122c01 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Wed, 18 Jan 2023 11:17:36 -0800
Subject: [PATCH] teams: Split Embedded and Bootstrap into separate teams.

* etc/teams.scm.in (embedded-bootstrap): Replace by two separate teams.
(embedded): New variable.
(bootstrap): New variable.
Adjust membership to use new teams.
---
etc/teams.scm.in | 17 ++++++++++++-----
1 file changed, 12 insertions(+), 5 deletions(-)

Toggle diff (44 lines)
diff --git a/etc/teams.scm.in b/etc/teams.scm.in
index 77c0127bb2..8d21f63d9d 100644
--- a/etc/teams.scm.in
+++ b/etc/teams.scm.in
@@ -242,9 +242,16 @@ (define-team go
"guix/scripts/import/go.scm"
"tests/go.scm")))
-(define-team embedded-bootstrap
- (team 'embedded-bootstrap
- #:name "Embedded / Bootstrap"))
+(define-team bootstrap
+ (team 'bootstrap
+ #:name "Bootstrap"
+ #:scope (list "gnu/packages/mes.scm")))
+
+(define-team embedded
+ (team 'embedded
+ #:name "Embedded"
+ #:scope (list "gnu/packages/bootloaders.scm"
+ "gnu/packages/firmware.scm")))
(define-team rust
(team 'rust
@@ -438,7 +445,7 @@ (define-member (person "Jonathan Brielmaier"
(define-member (person "Ludovic Courtès"
"ludo@gnu.org")
- core home embedded-bootstrap mentors)
+ core home embedded bootstrap mentors)
(define-member (person "Andreas Enge"
"andreas@enge.fr")
@@ -458,7 +465,7 @@ (define-member (person "Leo Famulari"
(define-member (person "Efraim Flashner"
"efraim@flashner.co.il")
- embedded-bootstrap julia rust science)
+ embedded bootstrap julia rust science)
(define-member (person "jgart"
"jgart@dismail.de")
--
2.39.0
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCY8hIuwAKCRDcUY/If5cW
qiaOAP9LzxQ78KHGxTQ1faxvVFvOBBjRNWBrbLuNb3efYt8bKAD/R4HuwrzZkUGz
MHfyi9+f71QQUq+wxDF1eZk8+xoXIww=
=Vo4G
-----END PGP SIGNATURE-----

Josselin Poiret wrote 2 years ago
Re: [bug#60540] teams: Add scope for Embedded / Bootstrap
(address . 60540@debbugs.gnu.org)
87ednh2zos.fsf@jpoiret.xyz
Hi everyone,

Vagrant Cascadian <vagrant@debian.org> writes:

Toggle quote (18 lines)
> New patch attached which also splits the teams.
>
> They could still probably significantly benefit from
> descriptions... though I haven't heard much of anything weighed in on
> that from the discussion on guix-devel.
>
> live well,
> vagrant
> From 0ae1c6951bcfd3c1a83e8a86adcbc6afae122c01 Mon Sep 17 00:00:00 2001
> From: Vagrant Cascadian <vagrant@debian.org>
> Date: Wed, 18 Jan 2023 11:17:36 -0800
> Subject: [PATCH] teams: Split Embedded and Bootstrap into separate teams.
>
> * etc/teams.scm.in (embedded-bootstrap): Replace by two separate teams.
> (embedded): New variable.
> (bootstrap): New variable.
> Adjust membership to use new teams.

Any news about this patch?

Best,
--
Josselin Poiret
-----BEGIN PGP SIGNATURE-----

iQHEBAEBCgAuFiEEOSSM2EHGPMM23K8vUF5AuRYXGooFAmRif9MQHGRldkBqcG9p
cmV0Lnh5egAKCRBQXkC5FhcaihWPC/4z2U3fNaF15Gxooa81yNWkuci5g6tuJ3C/
p4Sn9VTG6C9WT62QxJVovrErRFDB44OMFYNtQZFrouu6/P9o1QRx1t0HY72jv001
el33MyMDyq2LBlbf1IjlWSH4q6kjnSIDrCf0DlWyoyvCTHAKuCyI2X+JkNii36PE
wCqSbme0DPWNDPmku0331PLmLQm/Kz8aAn+jloaTvnVZZeDkeAtay+ixFBdQESz+
aS4p709jF1Vp1TsPqwwXfZpBdCXwli0I38PQXJ3XTpnmOtBjjhocLYg89/GsVb9y
Gk8KnUpPgC+fcwZPPn16Y/UR3vORk7+HHXcOGqyY4w35qlCNg7gstKbkNWCubrf0
zQhjq4kEdi7R050nwEiGCJtfMxHspncZ1zYXZ4VNmRuc9Kna7/t+5+HRYNif3vO+
3ifwr4zKC4rOnFNjlxyPovdR3QexRVrXGJr6EBkC/8GvX64sM4hOf/4NQ810PjRc
F7pGzImciY6io+TyGUuNlGltX7eRQXI=
=CMJW
-----END PGP SIGNATURE-----

Vagrant Cascadian wrote 2 years ago
(address . 60540@debbugs.gnu.org)
87wn19l7sf.fsf@wireframe
On 2023-05-15, Josselin Poiret wrote:
Toggle quote (22 lines)
> Vagrant Cascadian <vagrant@debian.org> writes:
>
>> New patch attached which also splits the teams.
>>
>> They could still probably significantly benefit from
>> descriptions... though I haven't heard much of anything weighed in on
>> that from the discussion on guix-devel.
>>
>> live well,
>> vagrant
>> From 0ae1c6951bcfd3c1a83e8a86adcbc6afae122c01 Mon Sep 17 00:00:00 2001
>> From: Vagrant Cascadian <vagrant@debian.org>
>> Date: Wed, 18 Jan 2023 11:17:36 -0800
>> Subject: [PATCH] teams: Split Embedded and Bootstrap into separate teams.
>>
>> * etc/teams.scm.in (embedded-bootstrap): Replace by two separate teams.
>> (embedded): New variable.
>> (bootstrap): New variable.
>> Adjust membership to use new teams.
>
> Any news about this patch?

Maybe it just wasn't controversial enough and I should just push it
already. :)

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZGKGUAAKCRDcUY/If5cW
qiklAQC8EL/mnYDA3JJsxY4MUfBLyto/rGABqKEqAeSlgGoHVQD/azywUXuuNiiV
InvV5Jg7XheE+nNKaATJS9XO5uRBgQs=
=Hqmy
-----END PGP SIGNATURE-----

Vagrant Cascadian wrote 2 years ago
(address . 60540-done@debbugs.gnu.org)
87jzwxgx0h.fsf@wireframe
On 2023-05-15, Vagrant Cascadian wrote:
Toggle quote (26 lines)
> On 2023-05-15, Josselin Poiret wrote:
>> Vagrant Cascadian <vagrant@debian.org> writes:
>>
>>> New patch attached which also splits the teams.
>>>
>>> They could still probably significantly benefit from
>>> descriptions... though I haven't heard much of anything weighed in on
>>> that from the discussion on guix-devel.
>>>
>>> live well,
>>> vagrant
>>> From 0ae1c6951bcfd3c1a83e8a86adcbc6afae122c01 Mon Sep 17 00:00:00 2001
>>> From: Vagrant Cascadian <vagrant@debian.org>
>>> Date: Wed, 18 Jan 2023 11:17:36 -0800
>>> Subject: [PATCH] teams: Split Embedded and Bootstrap into separate teams.
>>>
>>> * etc/teams.scm.in (embedded-bootstrap): Replace by two separate teams.
>>> (embedded): New variable.
>>> (bootstrap): New variable.
>>> Adjust membership to use new teams.
>>
>> Any news about this patch?
>
> Maybe it just wasn't controversial enough and I should just push it
> already. :)

Pushed as: 7cf606a5a0515b9a124fb58a06e3daa24a4a4e69

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZG6V3gAKCRDcUY/If5cW
qs+mAP0TYuNQf2Sdzig3w9WD/RQ2MlwLzJUAq+3vgw2ibo8KkAD+KPBspwdS9HMi
rrPVnERcuIK/qZASEelnStXgl0OQRQc=
=8Jfi
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60540@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60540
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help