[PATCH] gnu: ledger: Install example referenced in docs.

  • Done
  • quality assurance status badge
Details
3 participants
  • Frank Pursel
  • Ludovic Courtès
  • zimoun
Owner
unassigned
Submitted by
Frank Pursel
Severity
normal
F
F
Frank Pursel wrote on 4 Jan 2023 04:04
(address . guix-patches@gnu.org)
63b4ed52.630a0220.3aca4.ddd7@mx.google.com
* gnu/packages/finance.scm (ledger): Provide additional script from upstream.
---
gnu/packages/finance.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index f5906ec738..abc2134aee 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
;;; Copyright © 2022 Collin J. Doering <collin@rekahsoft.ca>
;;; Copyright © 2022 Justin Veilleux <terramorpha@cock.li>
+;;; Copyright © 2023 Frank Pursel <frank.pursel@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -342,7 +343,8 @@ (define-public ledger
(let ((examples (string-append (assoc-ref outputs "out")
"/share/doc/ledger/examples")))
(install-file "test/input/sample.dat" examples)
- (install-file "test/input/demo.ledger" examples))
+ (install-file "test/input/demo.ledger" examples)
+ (install-file "config/report" examples))
#t))
(add-after 'build 'build-doc
(lambda _ (invoke "make" "doc")))
--
2.38.1
F
F
Frank Pursel wrote on 4 Jan 2023 16:21
(address . 60537@debbugs.gnu.org)
87cz7uba1v.fsf@gmail.com
Better.

Toggle diff (24 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index f5906ec738..e96058e7b2 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
;;; Copyright © 2022 Collin J. Doering <collin@rekahsoft.ca>
;;; Copyright © 2022 Justin Veilleux <terramorpha@cock.li>
+;;; Copyright © 2023 Frank Pursel <frank.pursel@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -342,7 +343,8 @@ (define-public ledger
(let ((examples (string-append (assoc-ref outputs "out")
"/share/doc/ledger/examples")))
(install-file "test/input/sample.dat" examples)
- (install-file "test/input/demo.ledger" examples))
+ (install-file "test/input/demo.ledger" examples)
+ (install-file "contrib/report" examples))
#t))
(add-after 'build 'build-doc
(lambda _ (invoke "make" "doc")))
--
2.38.1
Z
Z
zimoun wrote on 21 Jan 2023 14:27
86sfg42f1o.fsf@gmail.com
Hi,

On Wed, 04 Jan 2023 at 07:21, Frank Pursel <frank.pursel@gmail.com> wrote:

Toggle quote (2 lines)
> Better.

Better compared to what? It is the same patch as the previous one, no ?


Cheers,
simon
F
F
Frank Pursel wrote on 23 Jan 2023 21:41
[PATCH] gnu: ledger: Install example referenced in docs.
(address . 60537@debbugs.gnu.org)
CANp2FMc1S-UgcbD-OG7wi4S65WKWr6W7-cOVLhCYjkRba5MuDw@mail.gmail.com
No, the second one is different. I made a typo on the first one and tried
to bring the file in from the config directory but it's actually in the
'contrib' directory. The second one is what we want.

Regards,
Frank
Attachment: file
F
F
Frank Pursel wrote on 27 Jan 2023 14:59
(address . 60537@debbugs.gnu.org)
87cz70xelr.fsf@gmail.com
It may be appropriate for me to provide a little more background on
this one line change to the ledger package.

I use the ledger package nearly daily and it works great. Still when
you use it a lot and read the documentation you come across
info:(ledger3)"Visualizing with Gnuplot" and you see that another simple
utility is described, report, that adds considerable functionality to
ledger but is not provided in the guix version. It seems to me that
this one line patch is the most trivial way to remedy this shortcoming.

Sincerely,
Frank
L
L
Ludovic Courtès wrote on 31 Jan 2023 23:11
(name . Frank Pursel)(address . frank.pursel@gmail.com)(address . 60537-done@debbugs.gnu.org)
874js6tkwb.fsf_-_@gnu.org
Frank Pursel <frank.pursel@gmail.com> skribis:

Toggle quote (22 lines)
> Better.
>
> diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
> index f5906ec738..e96058e7b2 100644
> --- a/gnu/packages/finance.scm
> +++ b/gnu/packages/finance.scm
> @@ -32,6 +32,7 @@
> ;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
> ;;; Copyright © 2022 Collin J. Doering <collin@rekahsoft.ca>
> ;;; Copyright © 2022 Justin Veilleux <terramorpha@cock.li>
> +;;; Copyright © 2023 Frank Pursel <frank.pursel@gmail.com>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -342,7 +343,8 @@ (define-public ledger
> (let ((examples (string-append (assoc-ref outputs "out")
> "/share/doc/ledger/examples")))
> (install-file "test/input/sample.dat" examples)
> - (install-file "test/input/demo.ledger" examples))
> + (install-file "test/input/demo.ledger" examples)
> + (install-file "contrib/report" examples))

Hi! Applied with a commit log, thanks.

Ludo’.
Closed
?