[PATCH 0/3] gnu: Add phantomsocks.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hilton Chain
  • Ludovic Courtès
Owner
unassigned
Submitted by
Hilton Chain
Severity
normal
H
H
Hilton Chain wrote on 3 Jan 2023 08:20
(address . guix-patches@gnu.org)
87v8lom6dm.wl-hako@ultrarare.space
*** BLURB HERE ***

Hilton Chain (3):
gnu: Add go-github-com-google-gopacket.
gnu: Add go-github-com-macronut-go-tproxy.
gnu: Add phantomsocks.

gnu/packages/golang.scm | 45 +++++++++++++++++++++++++++++++++++++
gnu/packages/networking.scm | 39 ++++++++++++++++++++++++++++++++
2 files changed, 84 insertions(+)


base-commit: 3354ca5970f150d99871f3a391a58d5f2cca8018
--
2.38.1
H
H
Hilton Chain wrote on 3 Jan 2023 08:21
[PATCH 1/3] gnu: Add go-github-com-google-gopacket.
(address . 60509@debbugs.gnu.org)
87tu18m6bf.wl-hako@ultrarare.space
* gnu/packages/golang.scm (go-github-com-google-gopacket): New variable.
---
gnu/packages/golang.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 70ddef52f1..ed482502a8 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7043,6 +7043,28 @@ (define-public go-github-com-google-uuid
4122 and DCE 1.1: Authentication and Security Services.")
(license license:bsd-3)))
+(define-public go-github-com-google-gopacket
+ (package
+ (name "go-github-com-google-gopacket")
+ (version "1.1.19")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/gopacket")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "048qwm2n0wrpql4qqgd7jyynn3gk069yvqbxnshlayzmbhf87ls4"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/google/gopacket"))
+ (home-page "https://github.com/google/gopacket")
+ (synopsis "Packet processing capabilities library")
+ (description
+ "This package provides packet processing capabilities for Go.")
+ (license license:bsd-3)))
+
(define-public go-github-com-google-goterm
(let ((commit "fc88cf888a3fa99ecc23d1efc1a44284268457d3")
(revision "1"))
--
2.38.1
H
H
Hilton Chain wrote on 3 Jan 2023 08:22
[PATCH 2/3] gnu: Add go-github-com-macronut-go-tproxy.
(address . 60509@debbugs.gnu.org)
87sfgsm6as.wl-hako@ultrarare.space
* gnu/packages/golang.scm (go-github-com-macronut-go-tproxy): New variable.
---
gnu/packages/golang.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ed482502a8..4c79f3dec2 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7357,6 +7357,29 @@ (define-public go-google-golang-org-protobuf
improved and cleaner API.")
(license license:bsd-3)))
+(define-public go-github-com-macronut-go-tproxy
+ (package
+ (name "go-github-com-macronut-go-tproxy")
+ (version "0.0.0-20190726054950-ef7efd7f24ed")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/FutureProtocolLab/go-tproxy")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0jibsg0xhsn0h1jq4g9qd4nr58w43y8majlwfri9ffk2cbfrwqdr"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/macronut/go-tproxy"))
+ (home-page "https://github.com/FutureProtocolLab/go-tproxy")
+ (synopsis "Linux Transparent Proxy library")
+ (description
+ "Golang TProxy provides an easy to use wrapper for the Linux Transparent
+Proxy functionality.")
+ (license license:expat)))
+
(define-public go-github-com-mattn-go-zglob
(package
(name "go-github-com-mattn-go-zglob")
--
2.38.1
H
H
Hilton Chain wrote on 3 Jan 2023 08:22
[PATCH 3/3] gnu: Add phantomsocks.
(address . 60509@debbugs.gnu.org)
87r0wcm6a9.wl-hako@ultrarare.space
* gnu/packages/networking.scm (phantomsocks): New variable.
---
gnu/packages/networking.scm | 39 +++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index a7b51ed1ff..b36bd1b9a7 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4478,6 +4478,45 @@ (define-public netdiscover
(home-page "https://github.com/netdiscover-scanner/netdiscover")
(license license:gpl3+)))
+(define-public phantomsocks
+ (package
+ (name "phantomsocks")
+ (version "0.0.0-20221222155609-14291e2c889e")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/macronut/phantomsocks")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13lllmh46xwns5ksqqdkl2p7vvnbzkzb6va005nk37bx6c4x2ixp"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:install-source? #f
+ #:import-path "github.com/macronut/phantomsocks"
+ #:build-flags #~'("-tags" #$(if (target-linux?)
+ "rawsocket"
+ "pcap"))))
+ (propagated-inputs
+ (list go-github-com-google-gopacket
+ go-github-com-macronut-go-tproxy))
+ (inputs
+ (if (target-linux?)
+ '()
+ (list libpcap)))
+ (home-page "https://github.com/macronut/phantomsocks")
+ (synopsis "Internet censorship circumvention tool")
+ (description
+ "Phantomsocks is an Internet censorship circumvention tool based on the
+desync technique, which was introduced in the 2017 paper
+@url{https://doi.org/10.1145/3131365.3131374, @cite{Your State is Not Mine: A
+Closer Look at Evading Stateful Internet Censorship}}.
+
+Further information on the usage could be found on the Wikibooks page
+@url{https://zh.wikibooks.org/wiki/Phantomsocks, @cite{Phantomsocks}}.")
+ (license license:lgpl3)))
+
(define-public putty
(package
(name "putty")
--
2.38.1
L
L
Ludovic Courtès wrote on 30 Jan 2023 23:44
Re: bug#60509: [PATCH 0/3] gnu: Add phantomsocks.
(name . Hilton Chain)(address . hako@ultrarare.space)(address . 60509-done@debbugs.gnu.org)
878rhjwsks.fsf@gnu.org
Hilton Chain <hako@ultrarare.space> skribis:

Toggle quote (4 lines)
> gnu: Add go-github-com-google-gopacket.
> gnu: Add go-github-com-macronut-go-tproxy.
> gnu: Add phantomsocks.

Hi! Applied the whole series. I change the license of ‘phantomsocks’
to ‘lgpl3+’ because I couldn’t see anything in the source stating it’s
version 3 only.

Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60509@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60509
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch