Document git-checkout

  • Open
  • quality assurance status badge
Details
2 participants
  • Tobias Geerinckx-Rice
  • mirai
Owner
unassigned
Submitted by
mirai
Severity
normal
M
M
mirai wrote on 2 Jan 2023 15:52
git-reference does not support file:// uri scheme
(name . bug-guix)(address . bug-guix@gnu.org)
b40364eb-4c5c-6e24-50c1-81de3c279bcb@makinata.eu
I'd like to build some specific programs that are git managed but not uploaded anywhere as packages in guix.
The rationale for this is that they're either too specific to be worth publishing or the programs are still
in their very early stages of development.

Using the file:// scheme in a package object does not work and the only workaround is passing the "--with-source=..."
command-line argument to 'guix build' which is rather selective in what it accepts, namely it does not work with bare repositories
meaning that a redundant git clone needs to be done beforehand.
T
T
Tobias Geerinckx-Rice wrote on 2 Jan 2023 18:24
228FFFB7-FF16-4616-A9B8-B246E0226C60@tobias.gr
retitle 60494 Document git-checkout
thanks

Hi!

That itself is not a bug: git-fetch is the wrong tool for this job. It should not have access to your files.

You can clone a local repository by directly calling git-checkout and passing it as the package source:

(source
(git-checkout (url "/home/mirai/foo")))

No need for a hash, either! \o/





Kind regards,

T G-R

Sent on the go. Excuse or enjoy my brevity.
T
T
Tobias Geerinckx-Rice wrote on 2 Jan 2023 18:26
bug#60494: git-reference does not support file:// uri scheme
(address . control@debbugs.gnu.org)
10296F83-4102-42A4-AB41-A2D52B5C0DEC@tobias.gr
retitle 60494 Document git-checkout
thanks

Hi!

That itself is not a bug: git-fetch is the wrong tool for this job. It should not have access to your files.

You can clone a local repository by directly calling git-checkout and passing it as the package source:

(source
(git-checkout (url "/home/mirai/foo")))

No need for a hash, either! \o/





Kind regards,

T G-R

Sent on the go. Excuse or enjoy my brevity.





Kind regards,

T G-R

Sent on the go. Excuse or enjoy my brevity.
?