[PATCHES] update python-tweepy to 4.12.1

  • Done
  • quality assurance status badge
Details
3 participants
  • goodoldpaul
  • jgart
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
goodoldpaul
Severity
normal

Debbugs page

goodoldpaul wrote 2 years ago
(address . guix-patches@gnu.org)
428f3d79be8e236db047148bedd44e40@autistici.org
Dear Guixers,
I'm sending a patchset updating python-tweepy to 4.12.1.

Thank you for your time and efforts,

giacomo
Giacomo Leidi wrote 2 years ago
[PATCH 2/3] gnu: Update python-oauthlib to 3.2.2.
(address . 60493@debbugs.gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20230102125207.16014-2-goodoldpaul@autistici.org
* gnu/packages/python-web.scm (python-oauthlib): Update to 3.2.2.
---
gnu/packages/python-web.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 25136c8448..2b8dbfca73 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3217,13 +3217,13 @@ (define-public oauth2ms
(define-public python-oauthlib
(package
(name "python-oauthlib")
- (version "3.1.0")
+ (version "3.2.2")
(source (origin
(method url-fetch)
(uri (pypi-uri "oauthlib" version))
(sha256
(base32
- "12gqnabwck30gdlpwm6af3s28qm9p2yc7b1w8s4fk9ncbz1irr5y"))))
+ "066r7mimlpb5q1fr2f1z59l4jc89kv4h2kgkcifyqav6544w8ncq"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
--
2.38.1
Giacomo Leidi wrote 2 years ago
[PATCH 1/3] gnu: Add python-async-lru.
(address . 60493@debbugs.gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20230102125207.16014-1-goodoldpaul@autistici.org
* gnu/packages/python-xyz.scm (python-async-lru): New variable.
---
gnu/packages/python-xyz.scm | 19 ++++++++++++++++++-
1 file changed, 18 insertions(+), 1 deletion(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3bdd1e00d6..10898be92d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -63,7 +63,7 @@
;;; Copyright © 2019, 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019, 2020, 2021, 2022 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
-;;; Copyright © 2019, 2020, 2021 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2019-2021, 2023 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
;;; Copyright © 2019, 2020, 2021, 2022 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2019, 2021, 2022 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
@@ -22728,6 +22728,23 @@ (define-public python-async-timeout
manager compatible with @code{asyncio}.")
(license license:asl2.0)))
+(define-public python-async-lru
+ (package
+ (name "python-async-lru")
+ (version "1.0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "async-lru" version))
+ (sha256
+ (base32
+ "0ankphghvzdgfwv64wvdb47gjnvi1ys58wbi7v7yc57b2llrpjy2"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/aio-libs/async_lru")
+ (synopsis "Simple lru_cache for asyncio")
+ (description "This package provides a simple @code{lru_cache} for Python's
+asyncio.")
+ (license license:expat)))
+
(define-public python-glob2
(package
(name "python-glob2")

base-commit: d7a9d72bb02a2a3b1a99183655bf878547116032
--
2.38.1
Giacomo Leidi wrote 2 years ago
[PATCH 3/3] gnu: Update python-tweepy to 4.12.1.
(address . 60493@debbugs.gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20230102125207.16014-3-goodoldpaul@autistici.org
* gnu/packages/python-web.scm (python-tweepy): Update to 4.12.1.
---
gnu/packages/python-web.scm | 12 ++++++++----
1 file changed, 8 insertions(+), 4 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 2b8dbfca73..a5896a0f13 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -39,7 +39,7 @@
;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
;;; Copyright © 2020, 2021, 2022 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Konrad Hinsen <konrad.hinsen@fastmail.net>
-;;; Copyright © 2020, 2022 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2020, 2022, 2023 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
@@ -7573,7 +7573,7 @@ (define-public python-mwparserfromhell
(define-public python-tweepy
(package
(name "python-tweepy")
- (version "4.4.0")
+ (version "4.12.1")
(source
(origin
(method git-fetch)
@@ -7584,7 +7584,7 @@ (define-public python-tweepy
(file-name (git-file-name name version))
(sha256
(base32
- "0jl3j20iqvzqqw5q5ldval5wrc2pdx94zff3b6b87j51yjx3qjhr"))))
+ "0c2zypsfspbjd1f5rgn2jnj05qxsmxh9gb93ciqf65hmkalgc8cg"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -7594,7 +7594,11 @@ (define-public python-tweepy
(when tests?
(invoke "python" "-m" "unittest" "discover" "tests")))))))
(propagated-inputs
- (list python-aiohttp python-requests python-requests-oauthlib))
+ (list python-aiohttp
+ python-async-lru
+ python-requests
+ python-requests-oauthlib
+ python-oauthlib))
(native-inputs
(list python-vcrpy))
(home-page "https://www.tweepy.org/")
--
2.38.1
goodoldpaul wrote 2 years ago
Re: [PATCHES] update python-tweepy to 4.12.1
(address . 60493@debbugs.gnu.org)(address . jgart@dismail.de)(address . lars@6xq.net)
12749b4d18369fd0f01359d6406ff37c@autistici.org
Dear Guixers,

this is a friendly ping :) I'm sending an updated patchset

Thank you for your time and efforts,

Giacomo
Giacomo Leidi wrote 2 years ago
[v2 3/3] gnu: Update python-tweepy to 4.12.1.
(address . 60493@debbugs.gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20230412205253.25395-3-goodoldpaul@autistici.org
* gnu/packages/python-web.scm (python-tweepy): Update to 4.12.1.
---
gnu/packages/python-web.scm | 12 ++++++++----
1 file changed, 8 insertions(+), 4 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 93bc7a0c0f..3d3662f1f2 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -39,7 +39,7 @@
;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
;;; Copyright © 2020, 2021, 2022, 2023 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Konrad Hinsen <konrad.hinsen@fastmail.net>
-;;; Copyright © 2020, 2022 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2020, 2022, 2023 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
@@ -7814,7 +7814,7 @@ (define-public python-mwparserfromhell
(define-public python-tweepy
(package
(name "python-tweepy")
- (version "4.4.0")
+ (version "4.12.1")
(source
(origin
(method git-fetch)
@@ -7825,7 +7825,7 @@ (define-public python-tweepy
(file-name (git-file-name name version))
(sha256
(base32
- "0jl3j20iqvzqqw5q5ldval5wrc2pdx94zff3b6b87j51yjx3qjhr"))))
+ "0c2zypsfspbjd1f5rgn2jnj05qxsmxh9gb93ciqf65hmkalgc8cg"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -7835,7 +7835,11 @@ (define-public python-tweepy
(when tests?
(invoke "python" "-m" "unittest" "discover" "tests")))))))
(propagated-inputs
- (list python-aiohttp python-requests python-requests-oauthlib))
+ (list python-aiohttp
+ python-async-lru
+ python-requests
+ python-requests-oauthlib
+ python-oauthlib))
(native-inputs
(list python-vcrpy))
(home-page "https://www.tweepy.org/")
--
2.39.2
Giacomo Leidi wrote 2 years ago
[v2 2/3] gnu: Update python-oauthlib to 3.2.2.
(address . 60493@debbugs.gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20230412205253.25395-2-goodoldpaul@autistici.org
* gnu/packages/python-web.scm (python-oauthlib): Update to 3.2.2.
---
gnu/packages/python-web.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 495e13acfe..93bc7a0c0f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3320,13 +3320,13 @@ (define-public oauth2ms
(define-public python-oauthlib
(package
(name "python-oauthlib")
- (version "3.1.0")
+ (version "3.2.2")
(source (origin
(method url-fetch)
(uri (pypi-uri "oauthlib" version))
(sha256
(base32
- "12gqnabwck30gdlpwm6af3s28qm9p2yc7b1w8s4fk9ncbz1irr5y"))))
+ "066r7mimlpb5q1fr2f1z59l4jc89kv4h2kgkcifyqav6544w8ncq"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
--
2.39.2
Giacomo Leidi wrote 2 years ago
[v2 1/3] gnu: Add python-async-lru.
(address . 60493@debbugs.gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20230412205253.25395-1-goodoldpaul@autistici.org
* gnu/packages/python-xyz.scm (python-async-lru): New variable.
---
gnu/packages/python-xyz.scm | 19 ++++++++++++++++++-
1 file changed, 18 insertions(+), 1 deletion(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 06eae3d62d..1f9fdb79c6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -63,7 +63,7 @@
;;; Copyright © 2019, 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019, 2020, 2021, 2022 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
-;;; Copyright © 2019, 2020, 2021 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2019-2021, 2023 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
;;; Copyright © 2019, 2020, 2021, 2022 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2019, 2021, 2022 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
@@ -23082,6 +23082,23 @@ (define-public python-async-timeout
manager compatible with @code{asyncio}.")
(license license:asl2.0)))
+(define-public python-async-lru
+ (package
+ (name "python-async-lru")
+ (version "1.0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "async-lru" version))
+ (sha256
+ (base32
+ "0ankphghvzdgfwv64wvdb47gjnvi1ys58wbi7v7yc57b2llrpjy2"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/aio-libs/async_lru")
+ (synopsis "Simple lru_cache for asyncio")
+ (description "This package provides a simple @code{lru_cache} for Python's
+asyncio.")
+ (license license:expat)))
+
(define-public python-glob2
(package
(name "python-glob2")

base-commit: dd3e5e71104a2bcbad80e52e062a144ea96b8c6a
--
2.39.2
jgart wrote 9 months ago
Re: [PATCHES] update python-tweepy to 4.12.1
(address . 60493@debbugs.gnu.org)(address . goodoldpaul@autistici.org)
32a7c80d75a2795e5c0b46d89ebeecf56e5ca06a@dismail.de
Hi Giacomo,

This patch series no longer applies. Would you be interested in sending an updated tweepy for me to review?

all best,

jgart
Sharlatan Hellseher wrote 5 months ago
[PATCHES] update python-tweepy to 4.12.1
(address . 60493@debbugs.gnu.org)
8734klnyq9.fsf@gmail.com
Hi,

python-async-lru was added in 116a6c78f131768c95af068d7ef8f11c430ac51f

--
Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmcakW4ACgkQdtcnv/Ys
0rULPw/9HZt82bWvq7QDpmqL7vot0ptHY3gBhfNVVfcOfwatmwK+vnrWw6Lw7Tue
VKg2JtQeNUqtZbmHcALATaCsd62usiFTanRYxoTSr+pBOoOWlFtqWfR8ana3GDCd
T1U5U4p5Yhk+qNwLknLtLYxhUl2s1KwVj9oV1D4tgLGQLSUBDGfRm8X4m6WPAY3b
ycfXU2eKPPqsGLkrVT8XcK2mdiKjoWt6H+FyXgdM45XB9ebHtHtAJetQ7PaECDsT
Lv1KoDfCI1gnEXloeGHqYcfCM5uTaIW4aAfjade9CLF5c8zp7SRi1TYJaQOKhTyi
MPidHngIhxE4RX1gERhTxM/cYQPj1U4cLI4sYwtPrClWhyGU248UdSccrm7Z7uo7
I1VeGxxdf5xoHFgvV6Ch0YfwokfdaEZOAb84JZDwTwdaFAAceJDV2M3LVyqTh2S1
C2DTlyRuQhD74CbhyEJ71sRmzKxTQJ+bIxXrnSbT3WLRVppIUdiwHUpmoLLRXIc9
IBm5wjiHegLe4i1U9IDf+kjDHLUSmXbmKWOIhUHQOqryNELTi6AoUN5I+JXB3uki
vu6Vq0ocenHKkpdhmNv8zue5zIvU6lutqzy1K6vX6yzgzWU3FFgbbUfL+ri/trKN
5czMtwIpGf7BHXJlaW4dpOys3+d973TiMcpaVzYd1kp6NbbSYpk=
=YLG4
-----END PGP SIGNATURE-----

jgart wrote 2 months ago
(address . 60493-done@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)(name . jgart)(address . jgart@dismail.de)
87h65yllcq.fsf@unknownee2179f0a061.attlocal.net
Hi,

Closing this issue.

Please open a new ticket for updating python-tweepy to the latest.

Latest version as of 2025-01-16 is 4.15.0:


--
all the best,
jgart
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60493@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60493
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help