[PATCH] gnu: Add gophernicus.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Paul A. Patience
Owner
unassigned
Submitted by
Paul A. Patience
Severity
normal
P
P
Paul A. Patience wrote on 1 Jan 2023 22:08
(address . guix-patches@gnu.org)(name . Paul A. Patience)(address . paul@apatience.com)
20230101210840.52240-1-paul@apatience.com
* gnu/packages/web.scm (gophernicus): New variable.
---
gnu/packages/web.scm | 67 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 67 insertions(+)

Toggle diff (78 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 90e388af76..532212ab56 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7468,6 +7468,73 @@ (define-public perl-html-tidy
in Perl but is not nearly as capable as @code{HTML::Tidy}.")
(license license:artistic2.0)))

+(define-public gophernicus
+ ;; Contains some unreleased fixes.
+ (let ((commit "da3390089c2a856db1ab2e3bd9751b9a9101a33a")
+ (revision "0"))
+ (package
+ (name "gophernicus")
+ (version (git-version "3.1.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gophernicus/gophernicus")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0a7kpymwqcsqzszdxvcqppbg61bpyg9f7raj783pldm4kf2wjyij"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ; No tests
+ #:configure-flags
+ ;; Listener and hostname used only in configuration files, which
+ ;; we don't install.
+ ;; This is what's done in the release.sh script.
+ #~(list "--listener=none" "--hostname=HOSTNAME")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-version
+ (lambda _
+ (substitute* "Makefile.in"
+ (("^(VERSION += ).*" _ prefix)
+ (string-append prefix #$version "\n")))
+ ;; This is done in the release.sh script.
+ (substitute* "README.md"
+ (("^(This release: Version )DEVEL\\b.*" _ prefix)
+ (string-append prefix #$version "\n"))
+ (("^NOTE: The master branch is rolling Development\\b.*")
+ ""))))
+ (replace 'configure
+ ;; The configure script is hand-written, not from GNU autotools.
+ (lambda* (#:key configure-flags #:allow-other-keys)
+ (setenv "CC" #$(cc-for-target))
+ (setenv "HOSTCC" "gcc")
+ (apply invoke "./configure"
+ (string-append "--prefix=" #$output)
+ configure-flags))))))
+ ;; TODO: Make configure script find libwrap.
+ ;;(inputs
+ ;; (list tcp-wrappers))
+ (home-page "https://gophernicus.org/")
+ (synopsis "Gopher protocol server")
+ (description
+ "Gophernicus is a Gopher protocol server. Its features include:
+@itemize
+@item written with security in mind;
+@item automatically generated Gopher menus;
+@item gophertags for virtually renaming directories;
+@item personal gopherspaces, located in @file{~/public_gopher/};
+@item virtual hosting;
+@item CGI support;
+@item output filtering and PHP support;
+@item charset support and conversions;
+@item selector rewriting;
+@item session tracking and statistics;
+@item TLS/SSL and proxy support.
+@end itemize")
+ (license license:bsd-2))))
+
(define-public geomyidae
(package
(name "geomyidae")
--
2.38.1
L
L
Ludovic Courtès wrote on 10 Jan 2023 11:25
(name . Paul A. Patience)(address . paul@apatience.com)(address . 60482-done@debbugs.gnu.org)
87h6wyofe5.fsf@gnu.org
"Paul A. Patience" <paul@apatience.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/web.scm (gophernicus): New variable.

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60482@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60482
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch