[PATCH] gnu: Add vger.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Paul A. Patience
Owner
unassigned
Submitted by
Paul A. Patience
Severity
normal
P
P
Paul A. Patience wrote on 1 Jan 2023 21:46
(address . guix-patches@gnu.org)(name . Paul A. Patience)(address . paul@apatience.com)
20230101204601.47767-1-paul@apatience.com
* gnu/packages/web.scm (vger): New variable.
---
gnu/packages/web.scm | 44 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (69 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index dcb7b3872a..90e388af76 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -59,6 +59,7 @@
;;; Copyright © 2022 Pradana Aumars <paumars@courrier.dev>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2023 Paul A. Patience <paul@apatience.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -147,6 +148,7 @@ (define-module (gnu packages web)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages kde)
#:use-module (gnu packages kerberos)
+ #:use-module (gnu packages libbsd)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libidn)
#:use-module (gnu packages libunistring)
@@ -8058,6 +8060,48 @@ (define-public gmnisrv
(license (list license:gpl3+
license:bsd-3)))) ;; for ini.c and ini.h

+(define-public vger
+ (package
+ (name "vger")
+ (version "2.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://tildegit.org/solene/vger")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jiwzn5dqadwq4ih3vzld66yq23gqsf7281sllh29bf6kmf9dz2k"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:test-target "test"
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-makefile
+ (lambda _
+ (substitute* "Makefile"
+ (("\\binstall -o root -g wheel vger ")
+ "install vger ")
+ (("\\binstall -o root -g wheel vger\\.8 ")
+ "install -m 644 vger.8 "))))
+ (add-before 'install 'make-install-dirs
+ (lambda _
+ (mkdir-p (string-append #$output "/bin"))
+ (mkdir-p (string-append #$output "/man/man8")))))))
+ (inputs
+ (list libbsd))
+ (home-page "https://tildegit.org/solene/vger")
+ (synopsis "Gemini protocol server")
+ (description "Vger is a Gemini protocol server that supports chroots,
+virtualhosts, CGI, default language choice, redirections and MIME-type
+detection. It delegates TLS support to an external daemon, for example
+@command{stunnel} on @command{inetd}.")
+ (license license:bsd-2)))
+
(define-public libzim
(package
(name "libzim")
--
2.38.1
L
L
Ludovic Courtès wrote on 10 Jan 2023 11:21
(name . Paul A. Patience)(address . paul@apatience.com)(address . 60481-done@debbugs.gnu.org)
87lemaoflf.fsf@gnu.org
Hi,

"Paul A. Patience" <paul@apatience.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/web.scm (vger): New variable.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60481@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60481
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch