[PATCH] gnu: Add guile-scheme-json-rpc

  • Done
  • quality assurance status badge
Details
2 participants
  • Abhishek Cherath
  • Ludovic Courtès
Owner
unassigned
Submitted by
Abhishek Cherath
Severity
normal
A
A
Abhishek Cherath wrote on 31 Dec 2022 08:28
(address . guix-patches@gnu.org)
20221231072814.44746-1-abhi@quic.us
* gnu/packages/guile-xyz.scm (guile-scheme-json-rpc): New variable.
---
gnu/packages/guile-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 50872b3f36..ab7f221f8c 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1028,6 +1028,37 @@ (define-public guile2.2-sjson
(name "guile2.2-sjson")
(inputs (list guile-2.2))))
+(define-public guile-scheme-json-rpc
+ (let ((commit "45ae6890f6619286f5679f88c094c88127b54c4a")
+ (revision "0")
+ (version "0.2.11"))
+ (package
+ (name "guile-scheme-json-rpc")
+ (version (git-version version revision commit))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'change-to-guile-dir
+ (lambda _
+ (chdir "guile"))))))
+ (inputs (list guile-3.0 guile-json-3))
+ (native-inputs (list pkg-config))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/rgherdt/scheme-json-rpc.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0w4m8xx8yyj0rv0q57mjr8ja87l7yikscj33i3ck26wg7230ppa5"))))
+ (synopsis "Library providing json-rpc capability in scheme")
+ (description
+ "Experimental implementation of https://www.jsonrpc.org/specification,
+allows for calling methods on remote servers by exchanging json objects.")
+ (license license:expat)
+ (home-page "https://codeberg.org/rgherdt/scheme-json-rpc/"))))
+
(define-public guile-squee
(let ((commit "a151fd006fa819945ca1d4749b173854269b9f70")
(revision "3"))
--
2.38.1
L
L
Ludovic Courtès wrote on 10 Jan 2023 11:32
(name . Abhishek Cherath)(address . abhi@quic.us)(address . 60444-done@debbugs.gnu.org)
87cz7mof32.fsf@gnu.org
Hi,

Abhishek Cherath <abhi@quic.us> skribis:

Toggle quote (2 lines)
> * gnu/packages/guile-xyz.scm (guile-scheme-json-rpc): New variable.

Applied with the cosmetic changes below: keeping a more conventional
order for fields, and improving the description as per

Thanks,
Ludo’.
Toggle diff (48 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 9866b60b16..3f84594014 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1027,6 +1027,15 @@ (define-public guile-scheme-json-rpc
(package
(name "guile-scheme-json-rpc")
(version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/rgherdt/scheme-json-rpc.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0w4m8xx8yyj0rv0q57mjr8ja87l7yikscj33i3ck26wg7230ppa5"))))
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -1035,21 +1044,13 @@ (define-public guile-scheme-json-rpc
(chdir "guile"))))))
(inputs (list guile-3.0 guile-json-3))
(native-inputs (list pkg-config))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://codeberg.org/rgherdt/scheme-json-rpc.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0w4m8xx8yyj0rv0q57mjr8ja87l7yikscj33i3ck26wg7230ppa5"))))
- (synopsis "Library providing json-rpc capability in scheme")
+ (synopsis "Library providing JSON-RPC capability in Scheme")
(description
- "Experimental implementation of https://www.jsonrpc.org/specification,
-allows for calling methods on remote servers by exchanging json objects.")
- (license license:expat)
- (home-page "https://codeberg.org/rgherdt/scheme-json-rpc/"))))
+ "This library implements parts of the
+@uref{https://www.jsonrpc.org/specification,JSON-RPC specification}, allowing
+for calling methods on remote servers by exchanging JSON objects.")
+ (home-page "https://codeberg.org/rgherdt/scheme-json-rpc/")
+ (license license:expat))))
(define-public guile-squee
(let ((commit "a151fd006fa819945ca1d4749b173854269b9f70")
Closed
?