[PATCH 1/3] gnu: Add flat-remix-icon-theme.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sughosha
  • Christopher Baines
Owner
unassigned
Submitted by
Sughosha
Severity
normal
S
S
Sughosha wrote on 31 Dec 2022 00:15
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
ou5NFy-AFwO4U-O0g4Hvhd7G94RpAoJbpwb7us3Nro3LUxy0dz2YD_c2H0mLFmVfHN3ux_3-5h3UvPGAxNuh_G9do-vSt0k7W7KlJACX6Lk=@proton.me
* gnu/packages/gnome-xyz.scm (flat-remix-icon-theme): New public variable.
---
gnu/packages/gnome-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 62ffddbb44..8734d087a8 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -225,6 +225,34 @@ (define-public papirus-icon-theme
and a few extra features.")
(license license:gpl3)))
+(define-public flat-remix-icon-theme
+ (package
+ (name "flat-remix-icon-theme")
+ (version "20220525")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/daniruiz/flat-remix")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ygazxccqf7hn1hxnf1mmsp17gm1m4hpcandfz9v5ijrgkd1m596"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:make-flags `(,(string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://drasite.com/flat-remix")
+ (synopsis "Icon theme with material design")
+ (description "Flat Remix is an icon theme inspired by material design. It
+is mostly flat using a colorful palette with some shadows, highlights, and
+gradients for some depth.")
+ (license license:gpl3+)))
+
(define-public gnome-plots
(package
(name "gnome-plots")
--
2.38.1
S
S
Sughosha wrote on 31 Dec 2022 00:17
[PATCH 2/3] gnu: Add flat-remix-gtk-theme.
(name . 60440@debbugs.gnu.org)(address . 60440@debbugs.gnu.org)
tla8VGh-m3hpWF36Sj49X__c0bJ3b1VcsdsA1_nzEFq536zhLPWE7dIHM_6_7zdDWZbPMgVOf27Z1njiwoLf_7bb3YM8Fy2VfxipdYJOFro=@proton.me
* gnu/packages/gnome-xyz.scm (flat-remix-gtk-theme): New public variable.
---
gnu/packages/gnome-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 8734d087a8..30249e4c8b 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -253,6 +253,34 @@ (define-public flat-remix-icon-theme
gradients for some depth.")
(license license:gpl3+)))
+(define-public flat-remix-gtk-theme
+ (package
+ (name "flat-remix-gtk-theme")
+ (version "20220627")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/daniruiz/flat-remix-gtk")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1kwahlrcm9rfsrd97q9lsbfz5390qafwbv78zl6j2vqgqnxhpwng"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:make-flags `(,(string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://drasite.com/flat-remix-gtk")
+ (synopsis "GTK application theme with material design")
+ (description "Flat Remix GTK is a GTK application theme inspired by
+material design. It is mostly flat using a colorful palette with some shadows,
+highlights, and gradients for some depth.")
+ (license license:gpl3+)))
+
(define-public gnome-plots
(package
(name "gnome-plots")
--
2.38.1
S
S
Sughosha wrote on 31 Dec 2022 00:18
[PATCH 3/3] gnu: Add flat-remix-gnome-theme.
(name . 60440@debbugs.gnu.org)(address . 60440@debbugs.gnu.org)
wqVprFAWLWF9W32-gSB_8IZUu5jb1G-TfBB4wiY9xMVooztSV-W6FyhZ6S-asYy7pk3RRoLglWPUpeal8vOgn4zmMT7hQ4SurbKO3LaT5yc=@proton.me
* gnu/packages/gnome-xyz.scm (flat-remix-gnome-theme): New public variable.
---
gnu/packages/gnome-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 30249e4c8b..45c4028e07 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -281,6 +281,33 @@ (define-public flat-remix-gtk-theme
highlights, and gradients for some depth.")
(license license:gpl3+)))
+(define-public flat-remix-gnome-theme
+ (package
+ (name "flat-remix-gnome-theme")
+ (version "20221107-1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/daniruiz/flat-remix-gnome")
+ ;; This commit adds GtkSourceView 5 theme, for GNOME Text Editor.
+ (commit "b5616efc515e9f1417436e67d94718db7529a2ba")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10fgdz8hz8rd7aj4vb3bvl8khzb2fvaia7n00gi0x19yvnnh36pr"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan
+ `(("share" "/")
+ ("themes" "/share/"))))
+ (home-page "https://drasite.com/flat-remix-gnome")
+ (synopsis "GNOME shell theme with material design")
+ (description "Flat Remix GNOME is a GNOME shell theme inspired by material
+design. It is mostly flat using a colorful palette with some shadows,
+highlights, and gradients for some depth.")
+ (license license:gpl3+)))
+
(define-public gnome-plots
(package
(name "gnome-plots")
--
2.38.1
C
C
Christopher Baines wrote on 1 Mar 2023 16:27
(name . Sughosha)(address . Sughosha@proton.me)
874jr4xziz.fsf@cbaines.net
Thanks, I've pushed these 3 patches to master as
fbcc42ad6c22ef7257daede968ff2b8d41bdd30d.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmP/buRfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdYMhAAkEML5sPdVU5kJiGvy2UAgLgU7w/uoJx8
LTS+p1OARUV9iDeEqu3R6ehk3yJBfEBGJZJ4Gm8HN0Xx10TWX2uRMkjcSiPiUFRl
6+AYNBGx7DprXsL5pBSLwCj/kRMp2JlOBdTBSdfBAzznbdMZgcrbb1a9+Ezvkqoq
nY7PujB5/6Y6vKPh3n9cSpmBysAmDcvzYheOlDTQKz22aXzLSPHvc+CFJLFjnMQV
PVMlVWQK9hcKezDRE9wOJ0AYnt+fkfixLrELWVj2py82/A+A3Yvyh/dv5Jyqb4pA
MvQaqa7Jc/2/630mCEy1Ia9Ri3s46T5+OQVLswl/h1e3Q7gvjQtu/NcKhMl43AUO
CA9Pk8VoLXKpAk/PVAnt7kyDym78iMtwIVrRDMFCqKsQCoNaeNzCnxDvCXG+G0EP
fo6ik+YzqJ0YNeoeGas0pIZ190ZELjG8SV3ca2CVmEt64jkS7eGRxIPwDlHfEw97
1F/J+IN9QDUYL+9miwykV3WUxwAR4RbuxzlWt5s0a1bi3cIDeJ/fWd1INSjHQYpl
KgHdHVtme/jfHqqEJPenjLfksabbQLWIk7YMII171LkWl+RmA5qyuhBjMUU4al7z
XAAPqybUtjS8V/z40S+6XDan51wuA/Yk48TCsLpWFF5YEm6GRSXuVMF4sY6Y0s87
KgKJ2KENGqw=
=FbX4
-----END PGP SIGNATURE-----

?