[PATCH] gnu: Add python-streamdeck-ui.

  • Open
  • quality assurance status badge
Details
One participant
  • Brian Cully
Owner
unassigned
Submitted by
Brian Cully
Severity
normal
B
B
Brian Cully wrote on 30 Dec 2022 22:46
(address . guix-patches@gnu.org)(name . Brian Cully)(address . bjc@spork.org)
aecfad737550208ff71824bdab57ebd2e88fad1f.1672436761.git.bjc@spork.org
* gnu/packages/python-xyz.scm: (python-streamdeck-ui) New variable.
---
This patch requires `python-elgato-streamdeck', which is in patch #60437.
gnu/packages/python-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 445efe563b..2f36342b62 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27734,6 +27734,42 @@ (define-public python-rnc2rng
equivalent schemata in the XML-based default RELAX NG syntax.")
(license license:expat)))
+(define-public python-streamdeck-ui
+ (package
+ (name "python-streamdeck-ui")
+ (version "2.0.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/timothycrosley/streamdeck-ui")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1kx2kns5fzqs5k0zp3x9365pjsk75k4dzx2by9x990wzhzk3xng5"))))
+ (build-system pyproject-build-system)
+ (arguments
+ ;; tests require `python-hypothesis-auto', which isn't (yet) in Guix.
+ `(#:tests? #f
+ #:phases (modify-phases %standard-phases
+ ;; sanity check uses precise dependency versions, and as a result,
+ ;; will break constantly for no good reason all the time.
+ (delete 'sanity-check))))
+ (home-page "https://timothycrosley.github.io/streamdeck-ui/")
+ (synopsis "User interface for controlling an Elgato Stream Deck")
+ (description
+ "This package provides a service, Web Interface, and UI for interacting with your
+computer using a Stream Deck")
+ (license license:expat)
+ (propagated-inputs (list python-cairosvg
+ python-elgato-streamdeck
+ python-filetype
+ python-pillow
+ python-pynput
+ python-pyside-2
+ python-xlib))
+ (native-inputs (list poetry python-toolchain))))
+
(define-public python-elgato-streamdeck
(package
(name "python-elgato-streamdeck")
--
2.38.1
B
B
Brian Cully wrote on 6 Apr 2023 20:56
(address . 60439@debbugs.gnu.org)
87zg7kx2jj.fsf@psyduck.jhoto.kublai.com
Can someone please take a look at this patch? It still applies cleanly
to master, and I've been using it for months now.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 60439@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60439
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch