[PATCH] gnu: Add python-elgato-streamdeck.

  • Open
  • quality assurance status badge
Details
One participant
  • Brian Cully
Owner
unassigned
Submitted by
Brian Cully
Severity
normal
B
B
Brian Cully wrote on 30 Dec 2022 22:45
(address . guix-patches@gnu.org)(name . Brian Cully)(address . bjc@spork.org)
2a939ae3310e4a6973507cd7af4daecc6eeb72cd.1672436745.git.bjc@spork.org
* gnu/packages/python-xyz.scm: (python-elgato-streamdeck) New variable.
---
gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d2623bc32d..445efe563b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27734,6 +27734,35 @@ (define-public python-rnc2rng
equivalent schemata in the XML-based default RELAX NG syntax.")
(license license:expat)))
+(define-public python-elgato-streamdeck
+ (package
+ (name "python-elgato-streamdeck")
+ (version "0.9.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "streamdeck" version))
+ (sha256
+ (base32
+ "0wgcvz3l3qllwvsadsq6y96wc3p16agzmwwx26v3ir0ns6q5dczm"))))
+ (build-system python-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/StreamDeck/Transport/LibUSBHIDAPI.py"
+ (("libhidapi-libusb.so")
+ (search-input-file inputs
+ "/lib/libhidapi-libusb.so"))))))))
+ (home-page "https://github.com/abcminiuser/python-elgato-streamdeck")
+ (synopsis "Library to control Elgato StreamDeck devices")
+ (description "Library to control Elgato StreamDeck devices.")
+ (license (license:non-copyleft
+ (string-append
+ "https://github.com/abcminiuser/python-elgato-streamdeck"
+ "/blob/master/LICENSE")))
+ (propagated-inputs (list python-pillow))
+ (inputs (list hidapi))))
+
(define-public python-pynput
(package
(name "python-pynput")
--
2.38.1
B
B
Brian Cully wrote on 6 Apr 2023 20:56
(address . 60437@debbugs.gnu.org)
87355cyh4r.fsf@psyduck.jhoto.kublai.com
Can someone please take a look at this patch? It still applies cleanly
to master.

I've been using this, by way of ‘python-streamdeck-ui’ for many months
now.
?