[PATCH] gnu: Add python-setuptools-lint.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brian Cully
  • ???
Owner
unassigned
Submitted by
Brian Cully
Severity
normal
B
B
Brian Cully wrote on 30 Dec 2022 22:42
(address . guix-patches@gnu.org)(name . Brian Cully)(address . bjc@spork.org)
d41be2518bb150cb647bbad8cdcd687df9619dce.1672436522.git.bjc@spork.org
* gnu/packages/check.scm: (python-setuptools-lint) New variable.
---
gnu/packages/check.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (30 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index aaa41777dc..7c351fb1ac 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2672,6 +2672,23 @@ (define-public python-pylint
possible to write plugins to add your own checks.")
(license license:gpl2+)))
+(define-public python-setuptools-lint
+ (package
+ (name "python-setuptools-lint")
+ (version "0.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "setuptools-lint" version))
+ (sha256
+ (base32
+ "16a1ac5n7k7sx15cnk03gw3fmslab3a7m74dc45rgpldgiff3577"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-pylint))
+ (home-page "https://github.com/johnnoone/setuptools-pylint")
+ (synopsis "Setuptools command for pylint")
+ (description "Setuptools command for pylint")
+ (license license:bsd-3)))
+
(define-public python-paramunittest
(package
(name "python-paramunittest")
--
2.38.1
?
(name . Brian Cully)(address . bjc@spork.org)(address . 60436-done@debbugs.gnu.org)
874jrzmfxd.fsf@envs.net
Brian Cully <bjc@spork.org> writes:

Toggle quote (2 lines)
> * gnu/packages/check.scm: (python-setuptools-lint) New variable.

Applied with adjusted synopsis and description:
Toggle snippet (7 lines)
- (synopsis "Setuptools command for pylint")
- (description "Setuptools command for pylint")
+ (synopsis "Run pylint with @command{python setup.py lint}")
+ (description "This package expose pylint as a lint command into
+setup.py.")

Thank you!
Closed
?