[PATCH] gnu: Add giada.

  • Open
  • quality assurance status badge
Details
3 participants
  • Sughosha
  • Ludovic Courtès
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Sughosha
Severity
normal
S
S
Sughosha wrote on 30 Dec 2022 22:26
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
X8A2B7nUmrnZvUkd4H4qZCNKyrndvxFWXT380wB8sgQMbCGA7sdxxD0va7dyMUHdlvUWea7tqQc8wU0oX6Pv9RRfIAcT93J7MESa3C4Sayw=@proton.me
* gnu/packages/music.scm (giada): New public variable.
---
gnu/packages/music.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 5be767a138..e15cf5efb7 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -156,6 +156,7 @@ (define-module (gnu packages music)
#:use-module (gnu packages perl-web)
#:use-module (gnu packages php)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages pretty-print) ;for fmt
#:use-module (gnu packages protobuf)
#:use-module (gnu packages pulseaudio) ;libsndfile
#:use-module (gnu packages python)
@@ -4059,6 +4060,45 @@ (define-public sooperlooper
available memory.")
(license license:gpl2+)))
+(define-public giada
+ (package
+ (name "giada")
+ (version "0.23.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/monocasual/giada")
+ (commit (string-append "v" version))
+ ;; TODO: Use installed libraries.
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "01r7iz8s33cdiia3gxb6s1nb4h4fzc3sr8gv1is0axjqwzbmqg3c"))))
+ (build-system cmake-build-system)
+ (arguments (list #:tests? #f)) ;no test target
+ (native-inputs (list imagemagick json-modern-cxx pkg-config))
+ (inputs (list alsa-lib
+ fmt
+ hicolor-icon-theme
+ jack-1
+ libsamplerate
+ libsndfile
+ libx11
+ libxcursor
+ libxft
+ libxinerama
+ libxpm
+ libxrandr
+ pulseaudio
+ rtmidi))
+ (home-page "https://giadamusic.com")
+ (synopsis "Music production tool")
+ (description
+ "Giada is a music production tool featuring a sample player, loop machine,
+song editor, live recorder, FX processor and MIDI controller.")
+ (license license:gpl3+)))
+
(define-public moc
(package
(name "moc")
--
2.38.1
M
M
Maxim Cournoyer wrote on 21 Mar 2023 16:03
(name . Sughosha)(address . Sughosha@proton.me)(address . 60435@debbugs.gnu.org)
87mt46p2nz.fsf@gmail.com
Hi Sugosha,

Sughosha <Sughosha@proton.me> writes:

Toggle quote (60 lines)
> * gnu/packages/music.scm (giada): New public variable.
> ---
> gnu/packages/music.scm | 40 ++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 40 insertions(+)
>
> diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
> index 5be767a138..e15cf5efb7 100644
> --- a/gnu/packages/music.scm
> +++ b/gnu/packages/music.scm
> @@ -156,6 +156,7 @@ (define-module (gnu packages music)
> #:use-module (gnu packages perl-web)
> #:use-module (gnu packages php)
> #:use-module (gnu packages pkg-config)
> + #:use-module (gnu packages pretty-print) ;for fmt
> #:use-module (gnu packages protobuf)
> #:use-module (gnu packages pulseaudio) ;libsndfile
> #:use-module (gnu packages python)
> @@ -4059,6 +4060,45 @@ (define-public sooperlooper
> available memory.")
> (license license:gpl2+)))
>
> +(define-public giada
> + (package
> + (name "giada")
> + (version "0.23.0")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/monocasual/giada")
> + (commit (string-append "v" version))
> + ;; TODO: Use installed libraries.
> + (recursive? #t)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "01r7iz8s33cdiia3gxb6s1nb4h4fzc3sr8gv1is0axjqwzbmqg3c"))))
> + (build-system cmake-build-system)
> + (arguments (list #:tests? #f)) ;no test target
> + (native-inputs (list imagemagick json-modern-cxx pkg-config))
> + (inputs (list alsa-lib
> + fmt
> + hicolor-icon-theme
> + jack-1
> + libsamplerate
> + libsndfile
> + libx11
> + libxcursor
> + libxft
> + libxinerama
> + libxpm
> + libxrandr
> + pulseaudio
> + rtmidi))
> + (home-page "https://giadamusic.com")
> + (synopsis "Music production tool")
> + (description
> + "Giada is a music production tool featuring a sample player, loop machine,
> +song editor, live recorder, FX processor and MIDI controller.")
> + (license license:gpl3+)))

Thanks for this work! It seems Debian has done the hard un-bundling
work for 0.22.0 [0]; it'd be a shame not to reuse it. Could you give it
a try? It may involve adding a couple dependencies to Guix, such as
juce, which doesn't seem to be packaged.


--
Thanks,
Maxim
L
L
Ludovic Courtès wrote on 7 Apr 2023 17:27
control message for bug #60435
(address . control@debbugs.gnu.org)
878rf3d86q.fsf@gnu.org
tags 60435 + moreinfo
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 60435@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60435
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch