[PATCH] gnu: oksh: Updated definition

  • Open
  • quality assurance status badge
Details
One participant
  • Niklas Arendt
Owner
unassigned
Submitted by
Niklas Arendt
Severity
normal
N
N
Niklas Arendt wrote on 29 Dec 2022 17:18
(address . guix-patches@gnu.org)
167c7aa0-ad50-31cd-5166-4877de9161f8@nikken.org
Sending my first patch; linted, styled & built. Feedback welcome!

* gnu/packages/shells.scm (oksh): Updates package definition.
---
gnu/packages/shells.scm | 30 +++++++++++++++---------------
1 file changed, 15 insertions(+), 15 deletions(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 128e557a21..d147125ec6 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -755,25 +755,25 @@ (define-public s-shell
(define-public oksh
(package
(name "oksh")
- (version "0.5.9")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://connochaetos.org/oksh/oksh-"
- version ".tar.gz"))
- (sha256
- (base32
- "0ln9yf6pxngsviqszv8klnnvn8vcpplvj1njdn8xr2y8frkbw8r3"))))
+ (version "7.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ibara/oksh")
+ (commit (string-append "oksh-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02bnsyc19rcjgzp6ck9743dh28fsdmmr2yq6gj8rhk7na8b1chnw"))))
(build-system gnu-build-system)
+ (inputs (list ncurses))
(arguments
- `(; The test files are not part of the distributed tarball.
- #:tests? #f))
- (home-page "https://connochaetos.org/oksh")
+ `(#:tests? #f))
+ (home-page "https://github.com/ibara/oksh")
(synopsis "Port of OpenBSD Korn Shell")
(description
- "Oksh is a port of the OpenBSD Korn Shell.
-The OpenBSD Korn Shell is a cleaned up and enhanced ksh.")
- (license license:gpl3+)))
+ "Portable OpenBSD ksh, based on the Public Domain Korn Shell
(pdksh).")
+ (license license:public-domain)))

(define-public loksh
(package
--
2.38.1
?