[PATCH] gnu: cifs-utils: Update to 7.0 [fixes CVE-2022-27239].

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Timotej Lazar
Owner
unassigned
Submitted by
Timotej Lazar
Severity
normal
T
T
Timotej Lazar wrote on 29 Dec 2022 20:37
(address . guix-patches@gnu.org)(name . Timotej Lazar)(address . timotej.lazar@araneo.si)
20221229193720.17591-1-timotej.lazar@araneo.si
* gnu/packages/samba.scm (cifs-utils): Update to 7.0.
[arguments]: Use new style. Drop unneeded phase 'install-man-pages.
[inputs]: Drop labels.
---
gnu/packages/samba.scm | 45 ++++++++++++++----------------------------
1 file changed, 15 insertions(+), 30 deletions(-)

Toggle diff (73 lines)
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 2a01279161..24dc0e4379 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -71,49 +71,34 @@ (define-module (gnu packages samba)
(define-public cifs-utils
(package
(name "cifs-utils")
- (version "6.14")
+ (version "7.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://download.samba.org/pub/linux-cifs/"
"cifs-utils/cifs-utils-" version ".tar.bz2"))
(sha256 (base32
- "1f2n0yzqsy5v5qv83731bi0mi86rrh11z8qjy1gjj8al9c3yh2b6"))))
+ "0qc1ph94yvg87m87xangw9dd0m5ds2q1zd2sqkzldsnkbfwamvqd"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf automake pkg-config
;; To generate the manpages.
python-docutils)) ; rst2man
(inputs
- `(("keytuils" ,keyutils)
- ("linux-pam" ,linux-pam)
- ("libcap-ng" ,libcap-ng)
- ("mit-krb5" ,mit-krb5)
- ("samba" ,samba)
- ("talloc" ,talloc)))
+ (list keyutils libcap-ng linux-pam mit-krb5 samba talloc))
(arguments
- `(#:configure-flags
- (list "--enable-man")
- #:phases
- (modify-phases %standard-phases
- (add-before 'bootstrap 'trigger-bootstrap
- ;; The shipped configure script is buggy, e.g., it contains a
- ;; unexpanded literal ‘LIBCAP_NG_PATH’ line).
- (lambda _
- (delete-file "configure")))
- (add-before 'configure 'set-root-sbin
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Don't try to install into "/sbin".
- (setenv "ROOTSBINDIR"
- (string-append (assoc-ref outputs "out") "/sbin"))))
- (add-before 'install 'install-man-pages
- ;; Create a directory that isn't created since version 6.10.
- (lambda* (#:key make-flags parallel-build? #:allow-other-keys)
- (apply invoke "make" "install-man"
- `(,@(if parallel-build?
- `("-j" ,(number->string (parallel-job-count)))
- '())
- ,@make-flags)))))))
+ (list #:configure-flags #~(list "--enable-man")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'bootstrap 'trigger-bootstrap
+ ;; The shipped configure script is buggy, e.g., it contains a
+ ;; unexpanded literal ‘LIBCAP_NG_PATH’ line).
+ (lambda _
+ (delete-file "configure")))
+ (add-before 'configure 'set-root-sbin
+ ;; Don't try to install into "/sbin".
+ (lambda _
+ (setenv "ROOTSBINDIR" (string-append #$output "/sbin")))))))
(synopsis "User-space utilities for Linux CIFS (Samba) mounts")
(description "@code{cifs-utils} is a set of user-space utilities for
mounting and managing @acronym{CIFS, Common Internet File System} shares using

base-commit: d07d6ea31a883d395d692483d84e7797b4c2ce0f
--
2.38.1
L
L
Ludovic Courtès wrote on 17 Jan 2023 15:44
(name . Timotej Lazar)(address . timotej.lazar@araneo.si)(address . 60409-done@debbugs.gnu.org)
87wn5lgqzf.fsf@gnu.org
Hi,

Timotej Lazar <timotej.lazar@araneo.si> skribis:

Toggle quote (4 lines)
> * gnu/packages/samba.scm (cifs-utils): Update to 7.0.
> [arguments]: Use new style. Drop unneeded phase 'install-man-pages.
> [inputs]: Drop labels.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60409@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60409
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch