[PATCH] gnu: darktable: update to 4.2.0

  • Done
  • quality assurance status badge
Details
2 participants
  • Alex Devaure
  • Ludovic Courtès
Owner
unassigned
Submitted by
Alex Devaure
Severity
normal
A
A
Alex Devaure wrote on 28 Dec 2022 12:58
(address . guix-patches@gnu.org)
875ydu5xl7.fsf@gmail.com
---
1 file changed, 9 insertions(+), 4 deletions(-)
gnu/packages/photo.scm | 13 +++++++++----

modified gnu/packages/photo.scm
@@ -43,6 +43,7 @@ (define-module (gnu packages photo)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages boost)
#:use-module (gnu packages build-tools)
#:use-module (gnu packages check)
@@ -81,6 +82,7 @@ (define-module (gnu packages photo)
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
#:use-module (gnu packages ruby)
+ #:use-module (gnu packages sdl)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages tex)
#:use-module (gnu packages time)
@@ -461,7 +463,7 @@ (define-public lensfun
(define-public darktable
(package
(name "darktable")
- (version "4.0.1")
+ (version "4.2.0")
(source
(origin
(method url-fetch)
@@ -469,7 +471,7 @@ (define-public darktable
"download/release-" version "/darktable-" version ".tar.xz"))
(sha256
- (base32 "0s0xwp5n4jhzdhbmsg02dlsc503jfznpwqn3rnipg687q3h83vsz"))))
+ (base32 "1y8sn7yyqyg1n82byaw5csjr8a6m7g6839krq9k9zc79vxzr3c0q"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DBINARY_PACKAGE_BUILD=On"
@@ -526,10 +528,11 @@ (define-public darktable
("perl" ,perl)
("pkg-config" ,pkg-config)
("po4a" ,po4a)
- ("python" ,python-wrapper)
+ ("python-wrapper" ,python-wrapper)
("ruby" ,ruby)))
(inputs
- (list cairo
+ (list bash-minimal
+ cairo
colord-gtk ;optional, for color profile support
cups ;optional, for printing support
curl
@@ -557,6 +560,7 @@ (define-public darktable
libwebp ;optional, for WebP support
libxml2
libxslt
+ libheif
lua-5.4 ;optional, for plugins
opencl-icd-loader ;optional, for OpenCL support
openexr ;optional, for EXR import/export
@@ -564,6 +568,7 @@ (define-public darktable
osm-gps-map ;optional, for geotagging view
pugixml
python-jsonschema
+ sdl2
sqlite))
(home-page "https://www.darktable.org")
(synopsis "Virtual lighttable and darkroom for photographers")
--
L
L
Ludovic Courtès wrote on 10 Jan 2023 11:46
(name . Alex Devaure)(address . ajadevaure@gmail.com)(address . 60400-done@debbugs.gnu.org)
877cxuoefe.fsf@gnu.org
Hi,

Alex Devaure <ajadevaure@gmail.com> skribis:

Toggle quote (4 lines)
> ---
> 1 file changed, 9 insertions(+), 4 deletions(-)
> gnu/packages/photo.scm | 13 +++++++++----

Applied, thanks!

Please use ‘git send-email’ or similar. Pasting the Magit buffer
doesn’t work: it lacks proper patch headers that say which files are
modified, and so it needed manual tweaks.

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60400@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60400
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch