[PATCH] gnu: Add sxmo-dmenu.

  • Done
  • quality assurance status badge
Details
One participant
  • jgart
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20221229045849.4882-1-jgart@dismail.de
* gnu/packages/suckless.scm (sxmo-dmenu): New variable.
---
gnu/packages/suckless.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 2ab5d9ea7b..f8db386365 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -503,6 +503,28 @@ (define-public sxmo-surf
(synopsis "The suckless surf browser fork for sxmo")
(license license:expat)))
+(define-public sxmo-dmenu
+ (package
+ (inherit dmenu)
+ (name "sxmo-dmenu")
+ (version "5.0.11")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://git.sr.ht/~mil/sxmo-dmenu")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19lqdv0b4b76vblbarrbs46i19vxwpsjb6gmi7hcii62rzhm52kp"))))
+ (home-page "https://git.sr.ht/~mil/sxmo-dmenu")
+ (synopsis "Dmenu for sxmo")
+ (description
+ "sxmo-dmenu works primarily by using volume/power keys for
+selection along with some other patches.")
+ (license license:expat)))
+
(define-public surf
(package
(name "surf")
--
2.38.1
J
(address . 60395-done@debbugs.gnu.org)
2515c385fbfe7d6c0ab7d9f306113dccc36a663f@dismail.de
Feel free to reopen if working on it.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60395@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60395
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch