[PATCH 0/2] Update dpf-plugins and use new package style.

  • Open
  • quality assurance status badge
Details
One participant
  • kiasoc5
Owner
unassigned
Submitted by
kiasoc5
Severity
normal
K
K
kiasoc5 wrote on 29 Dec 2022 00:18
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221228231848.44605-1-kiasoc5@disroot.org
kiasoc5 (2):
gnu: dpf-plugins: Update to 1.6.
gnu: dpf-plugins: Use new package style.

gnu/packages/music.scm | 18 +++++++++---------
1 file changed, 9 insertions(+), 9 deletions(-)


base-commit: 4ca649e978f08335fcabdcef693a7049082b5373
--
2.39.0
K
K
kiasoc5 wrote on 29 Dec 2022 00:21
[PATCH 1/2] gnu: dpf-plugins: Update to 1.6.
(address . 60390@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221228232132.45064-1-kiasoc5@disroot.org
* gnu/packages/music.scm (dpf-plugins): Update to 1.6.
---
gnu/packages/music.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 5be767a138..09c4bf6afd 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -6105,7 +6105,7 @@ (define-public mamba
(define-public dpf-plugins
(package
(name "dpf-plugins")
- (version "1.4")
+ (version "1.6")
(source
(origin
(method git-fetch)
@@ -6115,7 +6115,7 @@ (define-public dpf-plugins
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0y7qvpfm34g6f7d786c6c9043dlbg5c4h71l2s24dsc9m8i7x2ww"))))
+ (base32 "017d4cw3kkkxdpry4ya1c6kv8bsfiraij9dgqqcj07hb9dy0xnxi"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no "check" target
--
2.39.0
K
K
kiasoc5 wrote on 29 Dec 2022 00:21
[PATCH 2/2] gnu: dpf-plugins: Use new package style.
(address . 60390@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221228232132.45064-2-kiasoc5@disroot.org
* gnu/packages/music (dpf-plugins)[arguments]: Use G-expressions. Use #$output
instead of assoc-ref.
---
gnu/packages/music.scm | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 09c4bf6afd..50dbb744e6 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -6118,13 +6118,13 @@ (define-public dpf-plugins
(base32 "017d4cw3kkkxdpry4ya1c6kv8bsfiraij9dgqqcj07hb9dy0xnxi"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no "check" target
- #:make-flags
- (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
- (string-append "CC=" ,(cc-for-target)))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure))))
+ (list #:tests? #f ; no "check" target
+ #:make-flags
+ #~(list (string-append "PREFIX=" #$output)
+ (string-append "CC=" #$(cc-for-target)))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
(inputs
(list cairo
liblo ; for dssi plugins
--
2.39.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 60390@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60390
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch