[PATCH 0/2] Update lsp-plugins and use new package style.

  • Open
  • quality assurance status badge
Details
One participant
  • kiasoc5
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 2 years ago
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221228230337.35289-1-kiasoc5@disroot.org
kiasoc5 (2):
gnu: lsp-plugins: Update to 1.2.4.
gnu: lsp-plugins: Use new package style.

gnu/packages/music.scm | 36 ++++++++++++++++++------------------
1 file changed, 18 insertions(+), 18 deletions(-)


base-commit: 7c476873e0300711bf92668cf01abd28f7295ead
--
2.39.0
kiasoc5 wrote 2 years ago
[PATCH 1/2] gnu: lsp-plugins: Update to 1.2.4.
(address . 60388@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221228230609.36095-1-kiasoc5@disroot.org
* gnu/packages/music.scm (lsp-plugins): Update to 1.2.4.
---
gnu/packages/music.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 5be767a138..6f21a69473 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5767,7 +5767,7 @@ (define-public artyfx
(define-public lsp-plugins
(package
(name "lsp-plugins")
- (version "1.2.3")
+ (version "1.2.4")
(source
(origin
(method url-fetch)
@@ -5775,7 +5775,7 @@ (define-public lsp-plugins
"/releases/download/" version
"/lsp-plugins-src-" version ".tar.gz"))
(sha256
- (base32 "0asgwrkyncxz5h7kjkbwm78z8l2jndxvsrgd634m5x9n37gjsgvs"))))
+ (base32 "0anbymniyfcg9kbhd7b9spl9rk9znbhvlfv2ixbxyv3l5m9xqfhr"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
--
2.39.0
kiasoc5 wrote 2 years ago
[PATCH 2/2] gnu: lsp-plugins: Use new package style.
(address . 60388@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221228230609.36095-2-kiasoc5@disroot.org
* gnu/packages/music (lsp-plugins)[arguments]: Use G-expressions. Use #$output
instead of assoc-ref.
---
gnu/packages/music.scm | 32 ++++++++++++++++----------------
1 file changed, 16 insertions(+), 16 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 6f21a69473..b9d67d52fd 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5778,23 +5778,23 @@ (define-public lsp-plugins
(base32 "0anbymniyfcg9kbhd7b9spl9rk9znbhvlfv2ixbxyv3l5m9xqfhr"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags
- (list
- (string-append "CC=" ,(cc-for-target))
+ (list
+ #:make-flags
+ #~(list
+ (string-append "CC=" #$(cc-for-target))
"BUILD_MODULES=\"lv2 ladspa jack\"" "VST_UI=0"
- (string-append "PREFIX=" (assoc-ref %outputs "out"))
- (string-append "ETC_PATH=" (assoc-ref %outputs "out") "/etc"))
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (invoke "make" "config" "TEST=1"
- (string-append "PREFIX=" out)
- (string-append "ETCDIR=" out "/etc")))))
- (replace 'check
- (lambda _
- (invoke ".build/host/lsp-plugin-fw/lsp-plugins-test" "utest"))))))
+ (string-append "PREFIX=" #$output)
+ (string-append "ETC_PATH=" #$output "/etc"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (invoke "make" "config" "TEST=1"
+ (string-append "PREFIX=" #$output)
+ (string-append "ETCDIR=" #$output "/etc"))))
+ (replace 'check
+ (lambda _
+ (invoke ".build/host/lsp-plugin-fw/lsp-plugins-test" "utest"))))))
(inputs
(list cairo
freetype
--
2.39.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 60388@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60388
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help