[PATCH] gnu: zynaddsubfx: Update to 3.0.6.

  • Done
  • quality assurance status badge
Details
2 participants
  • 宋文武
  • kiasoc5
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 2 years ago
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221228223959.3372-1-kiasoc5@disroot.org
* gnu/packages/music.scm (zynaddsubfx): Update to 3.0.6.
[phases]: Remove trailing #t.
[inputs]: Add fftwf.
[native-inputs]: Add ruby.
---
gnu/packages/music.scm | 12 +++++++-----
1 file changed, 7 insertions(+), 5 deletions(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 5be767a138..4d5686f634 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -168,6 +168,7 @@ (define-module (gnu packages music)
#:use-module (gnu packages rdf)
#:use-module (gnu packages readline)
#:use-module (gnu packages rsync)
+ #:use-module (gnu packages ruby)
#:use-module (gnu packages sdl)
#:use-module (gnu packages serialization)
#:use-module (gnu packages sphinx)
@@ -3047,7 +3048,7 @@ (define-public vmpk
(define-public zynaddsubfx
(package
(name "zynaddsubfx")
- (version "3.0.5")
+ (version "3.0.6")
(source (origin
(method url-fetch)
(uri (string-append
@@ -3055,7 +3056,7 @@ (define-public zynaddsubfx
version "/zynaddsubfx-" version ".tar.bz2"))
(sha256
(base32
- "0qwzg14h043rmyf9jqdylxhyfy4sl0vsr0gjql51wjhid0i34ivl"))))
+ "1bkirvcg0lz1i7ypnz3dyh218yhrqpnijxs8n3wlgwbcixvn1lfb"))))
(build-system cmake-build-system)
(arguments
`(#:phases
@@ -3068,8 +3069,7 @@ (define-public zynaddsubfx
(substitute* "src/CMakeLists.txt"
(("-msse -msse2 -mfpmath=sse") "")
(("-march=(athlon64|core2)" flag)
- (string-append flag " -msse -msse2 -mfpmath=sse")))
- #t)))))
+ (string-append flag " -msse -msse2 -mfpmath=sse"))))))))
(inputs
(list liblo
ntk
@@ -3077,11 +3077,13 @@ (define-public zynaddsubfx
alsa-lib
jack-1
fftw
+ fftwf
minixml
libxpm
zlib))
(native-inputs
- (list pkg-config))
+ (list pkg-config
+ ruby))
(home-page "http://zynaddsubfx.sf.net/")
(synopsis "Software synthesizer")
(description

base-commit: 4ca649e978f08335fcabdcef693a7049082b5373
--
2.39.0
宋文武 wrote 2 years ago
(name . kiasoc5)(address . kiasoc5@disroot.org)(address . 60387-done@debbugs.gnu.org)
87wn5491h7.fsf@envs.net
kiasoc5 <kiasoc5@disroot.org> writes:

Toggle quote (5 lines)
> * gnu/packages/music.scm (zynaddsubfx): Update to 3.0.6.
> [phases]: Remove trailing #t.
> [inputs]: Add fftwf.
> [native-inputs]: Add ruby.

Pushed, thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60387@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60387
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help