[PATCH] gnu: Update podman to 4.3.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • 宋文武
  • Simon Josefsson
Owner
unassigned
Submitted by
Simon Josefsson
Severity
normal

Debbugs page

Simon Josefsson wrote 2 years ago
(address . guix-patches@gnu.org)
87ilhwuzbg.fsf@josefsson.org
Hi. This updates podman to 4.3.1. I haven't done extensive testing,
but the following launches a Trisquel images that appears to work:

echo 'unqualified-search-registries=["docker.io"]' > $HOME/.config/containers/registries.conf
echo '{ "default": [{"type": "insecureAcceptAnything"}] }' > $HOME/.config/containers/policy.json
#sudo mount -t cgroup2 none /sys/fs/cgroup
echo $USER:10000:65536 | sudo tee /etc/subuid
echo $USER:10000:65536 | sudo tee /etc/subgid
#podman system migrate
podman run -it --rm kpengboy/trisquel:11.0

/Simon
From 98ef2db67c652ef28c32fd1c9b964d6b04be5439 Mon Sep 17 00:00:00 2001
From: Simon Josefsson <simon@josefsson.org>
Date: Wed, 28 Dec 2022 01:42:33 +0100
Subject: [PATCH] gnu: Update podman to 4.3.1.

* gnu/packages/containers.scm (podman): Update to 4.3.1.
[native-inputs]: Add python, for hack/markdown-preprocess.
---
gnu/packages/containers.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index e2d698dcc2..985dea7bdb 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -274,7 +274,7 @@ (define-public cni-plugins
(define-public podman
(package
(name "podman")
- (version "4.2.1")
+ (version "4.3.1")
(source
(origin
(method git-fetch)
@@ -282,7 +282,7 @@ (define-public podman
(url "https://github.com/containers/podman")
(commit (string-append "v" version))))
(sha256
- (base32 "0ph8gf5gk9z1hm1v5kv924dipswvgrz0sgk23plnh2q0vbnh4wvv"))
+ (base32 "05hv4xdf06n728lmsx793zygypc9i404bgcgpy0fyrg8c2s11q2h"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
@@ -346,7 +346,8 @@ (define-public podman
git
go
; strace ; XXX debug
- pkg-config))
+ pkg-config
+ python))
(home-page "https://podman.io")
(synopsis "Manage containers, images, pods, and their volumes")
(description
--
2.38.1
-----BEGIN PGP SIGNATURE-----

iIoEARYIADIWIQSjzJyHC50xCrrUzy9RcisI/kdFogUCY6uSsxQcc2ltb25Aam9z
ZWZzc29uLm9yZwAKCRBRcisI/kdFooOQAQCsARXpYbPLoA0o75lJzlwnPfECxZS2
OVFs7tl8ebkitgEA0sbWNzVLZ5Tg3hKjflWCb1kba+msYjJb6++vULxkYgg=
=L0qz
-----END PGP SIGNATURE-----

宋文武 wrote 2 years ago
(name . Simon Josefsson)(address . simon@josefsson.org)(address . 60370-done@debbugs.gnu.org)
87pmc37zjw.fsf@envs.net
Simon Josefsson <simon@josefsson.org> writes:

Toggle quote (2 lines)
> Subject: [PATCH] gnu: Update podman to 4.3.1.

Applied, thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60370@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60370
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help