[PATCH] gnu: asciinema: Update to 2.2.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • ???
  • Timotej Lazar
Owner
unassigned
Submitted by
Timotej Lazar
Severity
normal
T
T
Timotej Lazar wrote on 27 Dec 2022 19:52
(address . guix-patches@gnu.org)(name . Timotej Lazar)(address . timotej.lazar@araneo.si)
20221227185225.10821-1-timotej.lazar@araneo.si
* gnu/packages/terminals.scm (asciinema): Update to 2.2.0.
[build-system]: Use pyproject-build-system.
[arguments]: Drop custom 'check phase. Add 'fix-python-path phase.
[native-inputs]: Drop python-nose. Add python-pytest.
---
gnu/packages/terminals.scm | 19 +++++++++++--------
1 file changed, 11 insertions(+), 8 deletions(-)

Toggle diff (51 lines)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index f6673388d2..06b7b8b725 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -56,6 +56,7 @@ (define-module (gnu packages terminals)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system go)
#:use-module (guix build-system meson)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -241,7 +242,7 @@ (define-public termite
(define-public asciinema
(package
(name "asciinema")
- (version "2.1.0")
+ (version "2.2.0")
(source
(origin
(method git-fetch)
@@ -250,16 +251,18 @@ (define-public asciinema
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1alcz018jrrpasrmgs8nw775a6pf62xq2xgs54c4mb396prdqy4x"))))
- (build-system python-build-system)
+ (base32 "0pcrghfi9p1p40d0339lcmhcv24hm1vxqr4rsdln34v385vqv14a"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _ (invoke "nosetests" "-v"))))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-python-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "tests/pty_test.py"
+ (("python3") (search-input-file inputs "/bin/python3"))))))))
(native-inputs
;; For tests.
- (list python-nose))
+ (list python-pytest))
(home-page "https://asciinema.org")
(synopsis "Terminal session recorder")
(description

base-commit: 8f93a1e01a879ae026678dd92c18e2a2a49be540
--
2.38.1
?
(name . Timotej Lazar)(address . timotej.lazar@araneo.si)(address . 60362-done@debbugs.gnu.org)
87mt777z4f.fsf@envs.net
Timotej Lazar <timotej.lazar@araneo.si> writes:

Toggle quote (8 lines)
> * gnu/packages/terminals.scm (asciinema): Update to 2.2.0.
> [build-system]: Use pyproject-build-system.
> [arguments]: Drop custom 'check phase. Add 'fix-python-path phase.
> [native-inputs]: Drop python-nose. Add python-pytest.
> ---
> gnu/packages/terminals.scm | 19 +++++++++++--------
> 1 file changed, 11 insertions(+), 8 deletions(-)

Pushed, thank you!
Closed
?