[PATCH] gnu: perl-image-exiftool: Update to 12.50, use new package style.

  • Done
  • quality assurance status badge
Details
2 participants
  • kiasoc5
  • Christopher Baines
Owner
unassigned
Submitted by
kiasoc5
Severity
normal
K
K
kiasoc5 wrote on 26 Dec 2022 22:01
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221226210133.16139-1-kiasoc5@disroot.org
* gnu/packages/photo.scm (perl-image-exiftool): Update to 12.50.
[arguments]: Use G-expresisons. Remove trailing #t. Use #$output instead of assoc-ref.
---
gnu/packages/photo.scm | 27 ++++++++++++---------------
1 file changed, 12 insertions(+), 15 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 4d85611101..2a8a8de25d 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -299,7 +299,7 @@ (define-public gphoto2
(define-public perl-image-exiftool
(package
(name "perl-image-exiftool")
- (version "12.16")
+ (version "12.50")
(source
(origin
(method url-fetch)
@@ -309,24 +309,21 @@ (define-public perl-image-exiftool
;; New releases may take a while to hit CPAN.
(string-append "https://www.sno.phy.queensu.ca/~phil/exiftool/"
"Image-ExifTool-" version ".tar.gz")))
- (patches (search-patches "perl-image-exiftool-CVE-2021-22204.patch"))
(sha256
(base32
- "0skm22b3gg1bfk0amklrprpva41m6mkrhqp0gi7z1nmcf9ypjh61"))))
+ "1a605rz00d7p866a22sw0s63m5a6y4xqqrzp7q7jyc0hbky43s5w"))))
(build-system perl-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'install 'post-install
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Make sure the 'exiftool' commands finds the library.
- ;; XXX: Shouldn't it be handled by PERL-BUILD-SYSTEM?
- (let* ((out (assoc-ref outputs "out"))
- (pm (find-files out "^ExifTool\\.pm$"))
- (lib (dirname (dirname (car pm)))))
- (wrap-program (string-append out "/bin/exiftool")
- `("PERL5LIB" prefix (,lib)))
- #t))))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Make sure the 'exiftool' commands finds the library.
+ ;; XXX: Shouldn't it be handled by PERL-BUILD-SYSTEM?
+ (let* ((pm (find-files #$output "^ExifTool\\.pm$"))
+ (lib (dirname (dirname (car pm)))))
+ (wrap-program (string-append #$output "/bin/exiftool")
+ `("PERL5LIB" prefix (,lib)))))))))
(home-page "https://metacpan.org/release/Image-ExifTool")
(synopsis "Program and Perl library to manipulate EXIF and other metadata")
(description "This package provides the @code{exiftool} command and the

base-commit: 7c476873e0300711bf92668cf01abd28f7295ead
--
2.39.0
C
C
Christopher Baines wrote on 16 Jan 2023 21:39
(name . kiasoc5)(address . kiasoc5@disroot.org)
878ri243ka.fsf@cbaines.net
kiasoc5 via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (6 lines)
> * gnu/packages/photo.scm (perl-image-exiftool): Update to 12.50.
> [arguments]: Use G-expresisons. Remove trailing #t. Use #$output instead of assoc-ref.
> ---
> gnu/packages/photo.scm | 27 ++++++++++++---------------
> 1 file changed, 12 insertions(+), 15 deletions(-)

Looks good to me, pushed to master as
ab09e8e578480463bafd8e21451acf9dd6ddd74f.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmPFtfVfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xfy9w/+O/GLZ9Y9V3Rr6w+Ltb0Du0o8a8c5gfSc
4RuV4acK5g5AMSlJvcLyTqYOzHqmQ1RaUZkq5bLAU0G5G6pRobVS2S4crxGqlwyW
33x7G7gcDht489VV6sS81lOnF6KU0QX2uyvySt0MXgF8IAehVZNzX+SPqUzvEcMw
WO1751MP2FiBQI/9OqqZxbrvwJ57pg2q5siWKvHzd3R1rDIYgUUabmYGe1UZ7hVK
yImoKLDvnrX2dwg1wRrAmUKoRMX5mVthrq4LWVBVH8KaO08E/diN9R/3DMWH0em6
GfJscAfoJG85MmmTy/hEJceZ31xksAvViq0KCyx/6D3NCvODui8sIcSjJQciwg1I
kVxsxLwGUFkXbVJBK5319H2AeE6RuCzCx+TsiqoyUCnNYsz9dc0Dat+s7/XTfY0x
Dy000CzPt4yJVUxY08kOgZn+JTIh/F/KbvQ7pHzCCKATkYa349YrNdXI9rxb6fZw
bIGmjAtZpooIHKkqwB/ukICb8M3cZMhXDdgNIWuAqrRHiQbxCPwyc7LH5vUb3+WQ
mhhfsCyzEE2Ttc+4UZtBgcQ4wRiuVJF8R6EDKFHoKTYniHcNm7Yry5/n1GaD8hx2
De3XrEyngYvKY/coNfg4sE80TviFTutzKyGLwGiV5eve9sa7F46LAgSYMQE7hPYp
9KrkRTh5Ijs=
=kEPz
-----END PGP SIGNATURE-----

?