[PATCH] services: certbot: Fix broken link.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Maxim Cournoyer
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20221225210317.20572-1-jgart@dismail.de
* gnu/services/certbot.scm (certbot-renewal-jobs): Fix broken link.
---
gnu/services/certbot.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/services/certbot.scm b/gnu/services/certbot.scm
index 7dfdad9874..cf3112a7dc 100644
--- a/gnu/services/certbot.scm
+++ b/gnu/services/certbot.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -148,7 +149,7 @@ (define certbot-command
(define (certbot-renewal-jobs config)
(list
;; Attempt to renew the certificates twice per day, at a random minute
- ;; within the hour. See https://certbot.eff.org/all-instructions/.
+ ;; within the hour. See https://eff-certbot.readthedocs.io/
#~(job '(next-minute-from (next-hour '(0 12)) (list (random 60)))
#$(certbot-command config))))
--
2.38.1
M
M
Maxim Cournoyer wrote on 3 Jan 2023 22:36
(name . jgart)(address . jgart@dismail.de)(address . 60319-done@debbugs.gnu.org)
87358r1et2.fsf@gmail.com
Hi,

jgart <jgart@dismail.de> writes:

Toggle quote (17 lines)
> * gnu/services/certbot.scm (certbot-renewal-jobs): Fix broken link.
> ---
> gnu/services/certbot.scm | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/services/certbot.scm b/gnu/services/certbot.scm
> index 7dfdad9874..cf3112a7dc 100644
> --- a/gnu/services/certbot.scm
> +++ b/gnu/services/certbot.scm
> @@ -6,6 +6,7 @@
> ;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
> ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
> ;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
> +;;; Copyright © 2022 jgart <jgart@dismail.de>
> ;;;
> ;;; This file is part of GNU Guix.

Changes of less than 10 lines of code are not substantial enough to be
protected by copyright, so I've dropped the above hunk.

Toggle quote (9 lines)
> @@ -148,7 +149,7 @@ (define certbot-command
> (define (certbot-renewal-jobs config)
> (list
> ;; Attempt to renew the certificates twice per day, at a random minute
> - ;; within the hour. See https://certbot.eff.org/all-instructions/.
> + ;; within the hour. See https://eff-certbot.readthedocs.io/
> #~(job '(next-minute-from (next-hour '(0 12)) (list (random 60)))
> #$(certbot-command config))))

I've re-added the trailing period and pushed!

--
Thanks,
Maxim
Closed
J
J
jgart wrote on 4 Jan 2023 02:23
Re: bug#60319: closed (Re: bug#60319: [PATCH] services: certbot: Fix broken link.)
(address . 60319@debbugs.gnu.org)
ebd27d9bf7b49ceae37f4c672375fe41@dismail.de
Thanks for the review! Much appreciated. I'll keep that in mind for the next patches.

all best,

jgart
?