[PATCH] gnu: flightgear: Update to 2020.3.17.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Parnikkapore
Owner
unassigned
Submitted by
Parnikkapore
Severity
normal

Debbugs page

Parnikkapore wrote 2 years ago
(address . guix-patches@gnu.org)(name . Parnikkapore)(address . poomklao@yahoo.com)
7da3c7a11d3512b06b77587a89f065e9a1a68c2a.1671895296.git.poomklao@yahoo.com
* gnu/packages/games (flightgear): Update to 2020.3.17.
Add nss-certs dependency as it is required for TerraSync, an
optional feature - do comment if this is not correct
---
gnu/packages/games.scm | 13 ++++++++-----
1 file changed, 8 insertions(+), 5 deletions(-)

Toggle diff (77 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 19c689dee1..1a8519692b 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -74,6 +74,7 @@
;;; Copyright © 2022 Gabriel Arazas <foo.dogsquared@gmail.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Hendursaga <hendursaga@aol.com>
+;;; Copyright © 2022 Parnikkapore <poomklao@yahoo.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -113,6 +114,7 @@ (define-module (gnu packages games)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages certs)
#:use-module (gnu packages check)
#:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
@@ -9100,7 +9102,7 @@ (define-public marble-marcher
(define simgear
(package
(name "simgear")
- (version "2020.3.11")
+ (version "2020.3.17")
(source
(origin
(method url-fetch)
@@ -9108,7 +9110,7 @@ (define simgear
(version-major+minor version) "/"
"simgear-" version ".tar.bz2"))
(sha256
- (base32 "0g2g3n3sb6kdimvcrn9kvlhyyrp5c6lx20fgzz8l609v5aygr3dv"))
+ (base32 "0z1pkxs4fw8xkiainxgcpayhmn0b4c0sc2j6q88x66zzvk89qpjc"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -9153,7 +9155,7 @@ (define-public flightgear
(version-major+minor version) "/"
"flightgear-" version ".tar.bz2"))
(sha256
- (base32 "15sar94x13j2y1m6adgmz2q1m1i9bzj3sxqla6y3m9vyf33hc9zy"))
+ (base32 "0m0qbyf9i84avkfmjm1a5bijl1nqs7wnpw7rfz53ls52mkgdww36"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -9203,6 +9205,7 @@ (define-public flightgear
freetype
glew
libpng
+ nss-certs ; TerraSync
openal
openscenegraph
plib
@@ -9216,7 +9219,7 @@ (define-public flightgear
(native-inputs
`(("cppunit" ,cppunit)
("pkg-config" ,pkg-config)
- ("qttools-5" ,qttools-5)
+ ("qttools" ,qttools-5)
("flightgear-data"
,(origin
(method url-fetch)
@@ -9225,7 +9228,7 @@ (define-public flightgear
"FlightGear-" version "-data.txz"))
(sha256
(base32
- "0n5mw9vw1snab16c1y3i9ylkiv54az57bs2mvpq20hhg5hdiagqj"))))))
+ "1s6qahfia3llghfqgx990brg7gbb7z7accsq528kcyp6k8mvlpia"))))))
(home-page "https://www.flightgear.org/")
(synopsis "Flight simulator")
(description "The goal of the FlightGear project is to create a

base-commit: 9cadac9787a03093550a1132bf7d20eb4eaf4df9
--
2.34.1
Ludovic Courtès wrote 2 years ago
(name . Parnikkapore)(address . poomklao@yahoo.com)(address . 60306@debbugs.gnu.org)
87a638bhiq.fsf_-_@gnu.org
Hi,

Parnikkapore <poomklao@yahoo.com> skribis:

Toggle quote (4 lines)
> * gnu/packages/games (flightgear): Update to 2020.3.17.
> Add nss-certs dependency as it is required for TerraSync, an
> optional feature - do comment if this is not correct

The patch is all good:


However, could you send a v2 without ‘nss-certs’? The ‘nss-certs’
package is probably not necessary at build time; if it’s necessary at
run time, there’s no use in adding it as ‘inputs’.

(Sending v2 will get qa.guix.gnu.org to build it and make sure
everything’s alright.)

Thanks in advance,
Ludo’.
Parnikkapore wrote 2 years ago
[PATCH] gnu: flightgear: Update to 2020.3.17.
(address . 60306@debbugs.gnu.org)(name . Parnikkapore)(address . poomklao@yahoo.com)
e2c53babba2648a7d50044da77038c3ed25f0eec.1672227953.git.poomklao@yahoo.com
* gnu/packages/games (flightgear): Update to 2020.3.17.
---

Sal' Ludo! For future packages, may I know what the best practices are for
dependencies that must be visible at runtime but aren't used at compile time?

gnu/packages/games.scm | 12 +++++++-----
1 file changed, 7 insertions(+), 5 deletions(-)

Toggle diff (69 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 19c689dee1..a0767f80ff 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -74,6 +74,7 @@
;;; Copyright © 2022 Gabriel Arazas <foo.dogsquared@gmail.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Hendursaga <hendursaga@aol.com>
+;;; Copyright © 2022 Parnikkapore <poomklao@yahoo.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -113,6 +114,7 @@ (define-module (gnu packages games)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages certs)
#:use-module (gnu packages check)
#:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
@@ -9100,7 +9102,7 @@ (define-public marble-marcher
(define simgear
(package
(name "simgear")
- (version "2020.3.11")
+ (version "2020.3.17")
(source
(origin
(method url-fetch)
@@ -9108,7 +9110,7 @@ (define simgear
(version-major+minor version) "/"
"simgear-" version ".tar.bz2"))
(sha256
- (base32 "0g2g3n3sb6kdimvcrn9kvlhyyrp5c6lx20fgzz8l609v5aygr3dv"))
+ (base32 "0z1pkxs4fw8xkiainxgcpayhmn0b4c0sc2j6q88x66zzvk89qpjc"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -9153,7 +9155,7 @@ (define-public flightgear
(version-major+minor version) "/"
"flightgear-" version ".tar.bz2"))
(sha256
- (base32 "15sar94x13j2y1m6adgmz2q1m1i9bzj3sxqla6y3m9vyf33hc9zy"))
+ (base32 "0m0qbyf9i84avkfmjm1a5bijl1nqs7wnpw7rfz53ls52mkgdww36"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -9216,7 +9218,7 @@ (define-public flightgear
(native-inputs
`(("cppunit" ,cppunit)
("pkg-config" ,pkg-config)
- ("qttools-5" ,qttools-5)
+ ("qttools" ,qttools-5)
("flightgear-data"
,(origin
(method url-fetch)
@@ -9225,7 +9227,7 @@ (define-public flightgear
"FlightGear-" version "-data.txz"))
(sha256
(base32
- "0n5mw9vw1snab16c1y3i9ylkiv54az57bs2mvpq20hhg5hdiagqj"))))))
+ "1s6qahfia3llghfqgx990brg7gbb7z7accsq528kcyp6k8mvlpia"))))))
(home-page "https://www.flightgear.org/")
(synopsis "Flight simulator")
(description "The goal of the FlightGear project is to create a

base-commit: 9cadac9787a03093550a1132bf7d20eb4eaf4df9
--
2.34.1
Parnikkapore wrote 2 years ago
(address . 60306@debbugs.gnu.org)(name . Parnikkapore)(address . poomklao@yahoo.com)
000d44d55093746824d4e3790caf5e0ae3e46f5c.1672228594.git.poomklao@yahoo.com
* gnu/packages/games (flightgear): Update to 2020.3.17.
---

Insta-edit to remove unused import - eep!

gnu/packages/games.scm | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 19c689dee1..63ea76e45b 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -74,6 +74,7 @@
;;; Copyright © 2022 Gabriel Arazas <foo.dogsquared@gmail.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Hendursaga <hendursaga@aol.com>
+;;; Copyright © 2022 Parnikkapore <poomklao@yahoo.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9100,7 +9101,7 @@ (define-public marble-marcher
(define simgear
(package
(name "simgear")
- (version "2020.3.11")
+ (version "2020.3.17")
(source
(origin
(method url-fetch)
@@ -9108,7 +9109,7 @@ (define simgear
(version-major+minor version) "/"
"simgear-" version ".tar.bz2"))
(sha256
- (base32 "0g2g3n3sb6kdimvcrn9kvlhyyrp5c6lx20fgzz8l609v5aygr3dv"))
+ (base32 "0z1pkxs4fw8xkiainxgcpayhmn0b4c0sc2j6q88x66zzvk89qpjc"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -9153,7 +9154,7 @@ (define-public flightgear
(version-major+minor version) "/"
"flightgear-" version ".tar.bz2"))
(sha256
- (base32 "15sar94x13j2y1m6adgmz2q1m1i9bzj3sxqla6y3m9vyf33hc9zy"))
+ (base32 "0m0qbyf9i84avkfmjm1a5bijl1nqs7wnpw7rfz53ls52mkgdww36"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -9216,7 +9217,7 @@ (define-public flightgear
(native-inputs
`(("cppunit" ,cppunit)
("pkg-config" ,pkg-config)
- ("qttools-5" ,qttools-5)
+ ("qttools" ,qttools-5)
("flightgear-data"
,(origin
(method url-fetch)
@@ -9225,7 +9226,7 @@ (define-public flightgear
"FlightGear-" version "-data.txz"))
(sha256
(base32
- "0n5mw9vw1snab16c1y3i9ylkiv54az57bs2mvpq20hhg5hdiagqj"))))))
+ "1s6qahfia3llghfqgx990brg7gbb7z7accsq528kcyp6k8mvlpia"))))))
(home-page "https://www.flightgear.org/")
(synopsis "Flight simulator")
(description "The goal of the FlightGear project is to create a

base-commit: 9cadac9787a03093550a1132bf7d20eb4eaf4df9
--
2.34.1
Parnikkapore wrote 2 years ago
[PATCH v2] gnu: flightgear: Update to 2020.3.17.
(address . 60306@debbugs.gnu.org)(name . Parnikkapore)(address . poomklao@yahoo.com)
000d44d55093746824d4e3790caf5e0ae3e46f5c.1672232113.git.poomklao@yahoo.com
* gnu/packages/games (flightgear): Update to 2020.3.17.
---

(Resending the last revision with a v2, just in case)

gnu/packages/games.scm | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 19c689dee1..63ea76e45b 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -74,6 +74,7 @@
;;; Copyright © 2022 Gabriel Arazas <foo.dogsquared@gmail.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Hendursaga <hendursaga@aol.com>
+;;; Copyright © 2022 Parnikkapore <poomklao@yahoo.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9100,7 +9101,7 @@ (define-public marble-marcher
(define simgear
(package
(name "simgear")
- (version "2020.3.11")
+ (version "2020.3.17")
(source
(origin
(method url-fetch)
@@ -9108,7 +9109,7 @@ (define simgear
(version-major+minor version) "/"
"simgear-" version ".tar.bz2"))
(sha256
- (base32 "0g2g3n3sb6kdimvcrn9kvlhyyrp5c6lx20fgzz8l609v5aygr3dv"))
+ (base32 "0z1pkxs4fw8xkiainxgcpayhmn0b4c0sc2j6q88x66zzvk89qpjc"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -9153,7 +9154,7 @@ (define-public flightgear
(version-major+minor version) "/"
"flightgear-" version ".tar.bz2"))
(sha256
- (base32 "15sar94x13j2y1m6adgmz2q1m1i9bzj3sxqla6y3m9vyf33hc9zy"))
+ (base32 "0m0qbyf9i84avkfmjm1a5bijl1nqs7wnpw7rfz53ls52mkgdww36"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -9216,7 +9217,7 @@ (define-public flightgear
(native-inputs
`(("cppunit" ,cppunit)
("pkg-config" ,pkg-config)
- ("qttools-5" ,qttools-5)
+ ("qttools" ,qttools-5)
("flightgear-data"
,(origin
(method url-fetch)
@@ -9225,7 +9226,7 @@ (define-public flightgear
"FlightGear-" version "-data.txz"))
(sha256
(base32
- "0n5mw9vw1snab16c1y3i9ylkiv54az57bs2mvpq20hhg5hdiagqj"))))))
+ "1s6qahfia3llghfqgx990brg7gbb7z7accsq528kcyp6k8mvlpia"))))))
(home-page "https://www.flightgear.org/")
(synopsis "Flight simulator")
(description "The goal of the FlightGear project is to create a

base-commit: 9cadac9787a03093550a1132bf7d20eb4eaf4df9
--
2.34.1
Ludovic Courtès wrote 2 years ago
Re: bug#60306: [PATCH] gnu: flightgear: Update to 2020.3.17.
(name . Parnikkapore)(address . poomklao@yahoo.com)(address . 60306-done@debbugs.gnu.org)
877cy01vhj.fsf_-_@gnu.org
Hi,

Parnikkapore <poomklao@yahoo.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/games (flightgear): Update to 2020.3.17.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60306@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60306
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help