Parnikkapore wrote 2 years ago
(address . guix-patches@gnu.org)(name . Parnikkapore)(address . poomklao@yahoo.com)
* gnu/packages/games (flightgear): Update to 2020.3.17.
Add nss-certs dependency as it is required for TerraSync, an
optional feature - do comment if this is not correct
---
gnu/packages/games.scm | 13 ++++++++-----
1 file changed, 8 insertions(+), 5 deletions(-)
Toggle diff (77 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 19c689dee1..1a8519692b 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -74,6 +74,7 @@
;;; Copyright © 2022 Gabriel Arazas <foo.dogsquared@gmail.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Hendursaga <hendursaga@aol.com>
+;;; Copyright © 2022 Parnikkapore <poomklao@yahoo.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -113,6 +114,7 @@ (define-module (gnu packages games)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages certs)
#:use-module (gnu packages check)
#:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
@@ -9100,7 +9102,7 @@ (define-public marble-marcher
(define simgear
(package
(name "simgear")
- (version "2020.3.11")
+ (version "2020.3.17")
(source
(origin
(method url-fetch)
@@ -9108,7 +9110,7 @@ (define simgear
(version-major+minor version) "/"
"simgear-" version ".tar.bz2"))
(sha256
- (base32 "0g2g3n3sb6kdimvcrn9kvlhyyrp5c6lx20fgzz8l609v5aygr3dv"))
+ (base32 "0z1pkxs4fw8xkiainxgcpayhmn0b4c0sc2j6q88x66zzvk89qpjc"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -9153,7 +9155,7 @@ (define-public flightgear
(version-major+minor version) "/"
"flightgear-" version ".tar.bz2"))
(sha256
- (base32 "15sar94x13j2y1m6adgmz2q1m1i9bzj3sxqla6y3m9vyf33hc9zy"))
+ (base32 "0m0qbyf9i84avkfmjm1a5bijl1nqs7wnpw7rfz53ls52mkgdww36"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -9203,6 +9205,7 @@ (define-public flightgear
freetype
glew
libpng
+ nss-certs ; TerraSync
openal
openscenegraph
plib
@@ -9216,7 +9219,7 @@ (define-public flightgear
(native-inputs
`(("cppunit" ,cppunit)
("pkg-config" ,pkg-config)
- ("qttools-5" ,qttools-5)
+ ("qttools" ,qttools-5)
("flightgear-data"
,(origin
(method url-fetch)
@@ -9225,7 +9228,7 @@ (define-public flightgear
"FlightGear-" version "-data.txz"))
(sha256
(base32
- "0n5mw9vw1snab16c1y3i9ylkiv54az57bs2mvpq20hhg5hdiagqj"))))))
+ "1s6qahfia3llghfqgx990brg7gbb7z7accsq528kcyp6k8mvlpia"))))))
(home-page "https://www.flightgear.org/")
(synopsis "Flight simulator")
(description "The goal of the FlightGear project is to create a
base-commit: 9cadac9787a03093550a1132bf7d20eb4eaf4df9
--
2.34.1