[PATCH v1] gnu: Add u-boot-qemu-arm

  • Done
  • quality assurance status badge
Details
2 participants
  • Denis 'GNUtoo' Carikli
  • Leo Famulari
Owner
unassigned
Submitted by
Denis 'GNUtoo' Carikli
Severity
normal
D
D
Denis 'GNUtoo' Carikli wrote on 23 Dec 2022 23:31
(address . guix-patches@gnu.org)(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)
20221223223109.14720-1-GNUtoo@cyberdimension.org
* gnu/packages/bootloaders.scm (u-boot-qemu-arm): New variable.
---
gnu/packages/bootloaders.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (23 lines)
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 57705cf596..5ead34c293 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -1019,6 +1019,14 @@ (define-public u-boot-puma-rk3399
`(("firmware" ,arm-trusted-firmware-rk3399)
,@(package-native-inputs base))))))
+(define-public u-boot-qemu-arm
+ (make-u-boot-package "qemu_arm" "arm-linux-gnueabihf"
+ ;; Disable features that require OpenSSL due
+ ;; to GPL/Openssl license incompatibilities.
+ ;; See https://bugs.gnu.org/34717 for
+ ;; details.
+ #:configs '("# CONFIG_FIT_SIGNATURE is not set")))
+
(define-public u-boot-qemu-riscv64
(make-u-boot-package "qemu-riscv64" "riscv64-linux-gnu"))

base-commit: b6d9e266a740c9706524bdd5c978f70e088675f1
--
2.38.1
D
D
Denis 'GNUtoo' Carikli wrote on 24 Dec 2022 07:15
[PATCH v1] gnu: Add u-boot-qemu-arm64
(address . 60289@debbugs.gnu.org)(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)
20221224061517.21568-1-GNUtoo@cyberdimension.org
* gnu/packages/bootloaders.scm (u-boot-qemu-arm64): New variable.
---
gnu/packages/bootloaders.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (23 lines)
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 5ead34c293..cb86f0154c 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -1027,6 +1027,14 @@ (define-public u-boot-qemu-arm
;; details.
#:configs '("# CONFIG_FIT_SIGNATURE is not set")))
+(define-public u-boot-qemu-arm64
+ (make-u-boot-package "qemu_arm64" "aarch64-linux-gnu"
+ ;; Disable features that require OpenSSL due
+ ;; to GPL/Openssl license incompatibilities.
+ ;; See https://bugs.gnu.org/34717 for
+ ;; details.
+ #:configs '("# CONFIG_FIT_SIGNATURE is not set")))
+
(define-public u-boot-qemu-riscv64
(make-u-boot-package "qemu-riscv64" "riscv64-linux-gnu"))

base-commit: 48f6de89bf090e0918a91b494da40fa9edf2b8d9
--
2.38.1
L
L
Leo Famulari wrote on 14 Feb 2023 23:17
Re: [bug#60289] [PATCH v1] gnu: Add u-boot-qemu-arm
(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)(address . 60289-done@debbugs.gnu.org)
Y+wIYTkdpQIYTYBt@jasmine.lan
On Fri, Dec 23, 2022 at 11:31:09PM +0100, Denis 'GNUtoo' Carikli wrote:
Toggle quote (2 lines)
> * gnu/packages/bootloaders.scm (u-boot-qemu-arm): New variable.

Thanks! I pushed the patch series as
8a68407ac1eb1f6fca245efcc9c372df52045e96
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60289@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60289
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch