arm-linux-gnueabihf: system image: kernel module not found "ahci"

  • Open
  • quality assurance status badge
Details
One participant
  • Denis 'GNUtoo' Carikli
Owner
unassigned
Submitted by
Denis 'GNUtoo' Carikli
Severity
normal
D
D
Denis 'GNUtoo' Carikli wrote on 23 Dec 2022 23:03
(address . bug-guix@gnu.org)
20221223230301.0614fb46@primary_laptop
Hi,

I've been trying to build a system image with the following command:
Toggle quote (3 lines)
> $ guix system image --target=arm-linux-gnueabihf -t raw-with-offset \
> minimal.scm

And the following minimal.scm:
Toggle quote (31 lines)
> (use-modules (gnu)
> (gnu bootloader u-boot))
> (use-service-modules networking ssh)
> (use-package-modules bootloaders screen ssh)
>
> (operating-system
> (host-name "qemu-arm")
> (timezone "Europe/Paris")
> (locale "en_US.utf8")
> (bootloader (bootloader-configuration
> (bootloader (bootloader (inherit u-boot-bootloader)
> (installer #~(const #t))))))
> (kernel-arguments '("console=ttyS0,115200"))
> (file-systems (cons (file-system
> (device (file-system-label "my-root"))
> (mount-point "/")
> (needed-for-boot? #t)
> (type "ext4")) %base-file-systems))
> (users (cons (user-account
> (name "gnutoo")
> (group "users")
> (supplementary-groups '("wheel" "audio" "video")))
> %base-user-accounts))
> (packages (append (list screen) %base-packages))
> (services
> (append (list (agetty-service (agetty-configuration (extra-options '("-L"))
> (baud-rate "115200")
> (term "xterm-256color")
> (tty "ttyS0"))))
> %base-services)))

And it gives me that error:
$ zcat qsh8mas9r3fsmd7q1rn8idaj8ja57n-linux-modules.drv.gz | sed 's#^#> #'
Toggle quote (13 lines)
> Backtrace:
> 5 (primitive-load "/gnu/store/p3anj14w2svvcrchshnfkxap6j3?")
> In ice-9/eval.scm:
> 619:8 4 (_ #f)
> 626:19 3 (_ #<directory (guile-user) 7ffff5fdbc80>)
> 293:34 2 (_ #(#<directory (guile-user) 7ffff5fdbc80> #<procedu?>))
> In srfi/srfi-1.scm:
> 586:17 1 (map1 ("ahci" "usb-storage" "uas" "usbhid" "hid-gene?" ?))
> In gnu/build/linux-modules.scm:
> 269:5 0 (_)
>
> gnu/build/linux-modules.scm:269:5: kernel module not found "ahci" "/gnu/store/0v0b3vb7wgavq9s4yck6hpqjm981ixg3-linux-libre-6.0.15/lib/modules"

It worked long time ago (probably around the time where Guix 1.3 was
released),
so some regression probably happened somewhere.

Denis.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEeC+d2+Nrp/PU3kkGX138wUF34mMFAmOmJZUACgkQX138wUF3
4mM6tw//V6yD6h20ZwQK6qJpC0ZdxLVL2UIZ3Dotcp4COIfeBNOTc4HFGOGfzu0S
TXFv/uIYlpzycCH7UPoJmYNYckNC+Zc7vwtxU1vOhfaaT01XNMOOo7VtbUi0BieZ
YV53Y9XslXph13GR0TuIobrcJqrsONkKKVfyd1+ywl66p5VWjJ+9wRT0etX9vx5q
hstrItlVPezVqzgvYILI4ccD0QceVPtiyJodmo8okV1LLqhIBiwjGZLBtEMJlAQn
YlumSVr4kSlT6s0jYshFy5DuVrzXveLKIHEC5+uD0Z2qJDVR7XgeqJGzWeORIJTP
DpYP/dnYkFP/8oftoIn4DPhSs9qn6FSbNLNmyLKPK72yNGDfGHKXZR6RO7H0VdGq
R/zY1X2GjiuDaU7FgY1lVkAjWLNgQcbZieYtUVzvzo0WJROlS9ThWB2yvJgGUdM9
viKx6VoQDuRi8nvilSRvsbFxBcpBTMof8p2mD1n80YjNUM7FlCSJkvV/LdTnF4H1
3UdB+wlTZHhooRpdFZYKU88nkAtZgHBhD6KYE0k3ZwOtbMO33FZ1gMaUEVVtpBT/
vEwYhfp1Z1y90I6t3sYT/rrVupodnsB8cipWNR8rkcW/cYxUszWiUosZI5EUl+tZ
ZxIulSm7nqOUM5HP1je3CInEjPhJmaTN9Qg5m0o9ExGy3EPR1uo=
=kSJr
-----END PGP SIGNATURE-----


?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 60287@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60287
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch