[PATCH] gnu: Add python-pyee.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
N
N
Nicolas Graves wrote on 23 Dec 2022 19:22
(address . guix-patches@gnu.org)(address . ngraves@ngraves.fr)
20221223182232.4666-1-ngraves@ngraves.fr
* gnu/packages/python-xyz.scm (python-pyee): New variable.
---
gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 486d7bc664..5cc2061ec1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30705,6 +30705,27 @@ (define-public python-pydispatcher
and to reference instance methods using weak-references.")
(license license:bsd-3)))
+(define-public python-pyee
+ (package
+ (name "python-pyee")
+ (version "9.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyee" version))
+ (sha256
+ (base32 "0cjbxbqr9f8bn2h3ra69d550qj2r1hmsgrh5nx31ywmwia9c8w17"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-typing-extensions))
+ (native-inputs (list python-twisted python-trio))
+ (home-page "https://github.com/jfhbrook/pyee")
+ (synopsis "Emit events with Python")
+ (description
+ "This package provides a port of node.js's EventEmitter to python.
+Additionally, it includes a number of subclasses useful for implementing async
+and threaded programming in python, such as async/await.")
+ (license license:expat)))
+
(define-public python-queuelib
(package
(name "python-queuelib")
--
2.38.1
C
C
Christopher Baines wrote on 1 Mar 2023 16:25
(name . Nicolas Graves)(address . ngraves@ngraves.fr)
87cz5sxzmi.fsf@cbaines.net
Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (5 lines)
> * gnu/packages/python-xyz.scm (python-pyee): New variable.
> ---
> gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
> 1 file changed, 21 insertions(+)

Thanks, pushed to master as f9abf24f242348db4af469c567f58b62cc181b2a.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmP/bmVfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xe/NhAArDMz15X+Nk85geKfxXynEB/rFB+sksUy
TRvXgaIUm5kzb6QxDqFeYsykLDRsoByLFkfNXXatNyS7wQWTO4HWb9k2AbMiNal3
9cr1gF3qiOAkND4GuYtcyRRvzlWYZaqX92A/UJQdZi9tmTUn27028QxCyHTqb7I3
ZXyAzA5i4Sc5wz4BtL/c/JXwYtifoUFrHtq1WpXCs/EVPSR6HFEjz7b4EXvZIF7o
uHfu5fiR6YkiOya1Q6o0UFfW9UKBicRyBogRWgqhxmTKftdnPrdvddex0MD0tliK
DTAACdJOKdsNprlqlu1uWJ6qOY1XY5H72nzBU9CUsWTnVHID5puPHyfrr6eNdTRk
Bl5H4OXc4v4Rla2tVeRdQV0IePwY8an8U57At8q2u1/7dxGtnDd6LrD6MoRpQhTJ
TJuAfB48YoIsBccqjCb6Bben9h2vzBr4YCJDrrzWghcNxAoML2E7hbgTg6/4cFOk
PhqXfmaPKQPzo0Hvo1MHoiBpLDsMNiYrRAInl7zSzyzgAlvtxIRiLpiy/GDoF4jv
GlSI9sJyQ1LNI3UytQSf5gLGCCfBALpuzGedVA22nUzlFGn8lnZH1ILvTrnwvZ61
RiOBk84JkUAkNcyr7cpoaPJpPAcGMGIg+vQhx8wUTVf0777mBHnqnFdobxJGuqiC
X6znI+BIiAk=
=+HAQ
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 60281@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60281
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch