[PATCH] gnu: lite-xl: Update to 2.1.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • 宋文武
  • Parnikkapore
Owner
unassigned
Submitted by
Parnikkapore
Severity
normal

Debbugs page

Parnikkapore wrote 2 years ago
(address . guix-patches@gnu.org)(name . Parnikkapore)(address . poomklao@yahoo.com)
2ec4ac48b951f419f1feb638ed86fd6688056f2a.1671808087.git.poomklao@yahoo.com
* gnu/packages/text-editors.scm (lite-xl): Update to 2.1.0.
Lua input is updated because the new version would not build
with Lua 5.2 .
---
gnu/packages/text-editors.scm | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 854a424b8a..6adf7122bd 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -1359,7 +1359,7 @@ (define-public mle
(define-public lite-xl
(package
(name "lite-xl")
- (version "2.0.5")
+ (version "2.1.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1368,15 +1368,15 @@ (define-public lite-xl
(file-name (git-file-name name version))
(sha256
(base32
- "0l2i9mvbkc4kqkwk2p17zd1rlm5v41acdyp2xivi53p2hkj4x6pf"))
+ "08s6hsi57nnmcs22fk6nj7pjwjsh0cnjlyz919w8sjds51v0ax7n"))
(modules '((guix build utils)))
(snippet '(substitute* "meson.build"
- (("dependency\\('lua5\\.2',")
- "dependency('lua-5.2',")))))
+ (("dependency\\('lua5\\.4',")
+ "dependency('lua-5.4',")))))
(build-system meson-build-system)
(inputs (list agg
freetype
- lua-5.2
+ lua-5.4
pcre2
reproc
sdl2))

base-commit: dd8a20355e6e2bc349b7af00f309629fb054ed09
--
2.34.1
Parnikkapore wrote 2 years ago
[PATCH v2] gnu: lite-xl: Update to 2.2.0.
(address . 60277@debbugs.gnu.org)
69e7475f64b20080fe0a21c0231e8685cac8e3c6.1673170036.git.poomklao@yahoo.com
* gnu/packages/text-editors.scm (lite-xl): Update to 2.2.0.
Lua input is updated because the new version would not build
with Lua 5.2 .
---

Upstream released a new version so here's an updated patch to match!

gnu/packages/text-editors.scm | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 0094959cbb..0c1776326f 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -1359,7 +1359,7 @@ (define-public mle
(define-public lite-xl
(package
(name "lite-xl")
- (version "2.0.5")
+ (version "2.1.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1368,15 +1368,15 @@ (define-public lite-xl
(file-name (git-file-name name version))
(sha256
(base32
- "0l2i9mvbkc4kqkwk2p17zd1rlm5v41acdyp2xivi53p2hkj4x6pf"))
+ "08s6hsi57nnmcs22fk6nj7pjwjsh0cnjlyz919w8sjds51v0ax7n"))
(modules '((guix build utils)))
(snippet '(substitute* "meson.build"
- (("dependency\\('lua5\\.2',")
- "dependency('lua-5.2',")))))
+ (("dependency\\('lua5\\.4',")
+ "dependency('lua-5.4',")))))
(build-system meson-build-system)
(inputs (list agg
freetype
- lua-5.2
+ lua-5.4
pcre2
reproc
sdl2))

base-commit: db3fdbbdfee9d412053cc9538ad76abee7c2cb89
--
2.38.1
Parnikkapore wrote 2 years ago
[PATCH v3] gnu: lite-xl: Update to 2.1.1
(address . 60277@debbugs.gnu.org)
3556760c35de2f500c7cdace5c71ae602c675b62.1673364707.git.poomklao@yahoo.com
* gnu/packages/text-editors.scm (lite-xl): Update to 2.1.1
Lua input is updated because the new version would not build
with Lua 5.2 .
---

And here's the *actual* updated version. Sorry about that! (forgot
to stage my changes before amending lol)

gnu/packages/text-editors.scm | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 0094959cbb..d96abd7e5b 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -1359,7 +1359,7 @@ (define-public mle
(define-public lite-xl
(package
(name "lite-xl")
- (version "2.0.5")
+ (version "2.1.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1368,15 +1368,15 @@ (define-public lite-xl
(file-name (git-file-name name version))
(sha256
(base32
- "0l2i9mvbkc4kqkwk2p17zd1rlm5v41acdyp2xivi53p2hkj4x6pf"))
+ "1pnmax68hvk1ry4bjsxwq4qimfn55pai8jlljw6jiqzcmh4mp7xm"))
(modules '((guix build utils)))
(snippet '(substitute* "meson.build"
- (("dependency\\('lua5\\.2',")
- "dependency('lua-5.2',")))))
+ (("dependency\\('lua5\\.4',")
+ "dependency('lua-5.4',")))))
(build-system meson-build-system)
(inputs (list agg
freetype
- lua-5.2
+ lua-5.4
pcre2
reproc
sdl2))

base-commit: db3fdbbdfee9d412053cc9538ad76abee7c2cb89
--
2.38.1
宋文武 wrote 2 years ago
Re: bug#60277: [PATCH] gnu: lite-xl: Update to 2.1.0.
(name . Parnikkapore)(address . poomklao@yahoo.com)(address . 60277-done@debbugs.gnu.org)
87sffs917c.fsf_-_@envs.net
Parnikkapore <poomklao@yahoo.com> writes:

Toggle quote (4 lines)
> * gnu/packages/text-editors.scm (lite-xl): Update to 2.1.1
> Lua input is updated because the new version would not build
> with Lua 5.2 .

Pushed, thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60277@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60277
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help