[PATCH 0/3] gnu: abc: Update to 0.0-2.70cb339.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Simon South
Owner
unassigned
Submitted by
Simon South
Severity
normal

Debbugs page

Simon South wrote 2 years ago
(address . guix-patches@gnu.org)
cover.1671713787.git.simon@simonsouth.net
Here's a patch series that aims to improve the package for abc, "a program for
sequential logic synthesis and formal verification", by

- properly conveying license information in its "license" field and its
output;

- updating it to the modern style using gexps; and

- updating abc itself to commit 70cb339 (not quite the latest, but the
revision expected by the current version of its one direct dependent,
yosys---patches to follow), which includes updating the location of its
source-code repository.

I've tested building the package and its dependents on x86-64 and AArch64 and
everything seems okay. Note arachne-pnr fails to build in any case and will
need further attention.

--
Simon South
simon@simonsouth.net


Simon South (3):
gnu: abc: Convey license information.
gnu: abc: Use gexps.
gnu: abc: Update to 0.0-2.70cb339.

gnu/packages/fpga.scm | 37 ++++++++++++++++++-------------------
1 file changed, 18 insertions(+), 19 deletions(-)


base-commit: c1d543203e6de2ca31da82097f23b31a4250315e
--
2.38.1
Simon South wrote 2 years ago
[PATCH 3/3] gnu: abc: Update to 0.0-2.70cb339.
(address . 60258@debbugs.gnu.org)
6e42f9b72b36602a460667f2680da8e711eb8b70.1671713787.git.simon@simonsouth.net
* gnu/packages/fpga.scm (abc): Update to 0.0-2.70cb339.
[source]: Fetch from current source-code repository.
[native-inputs]: Remove as obsolete.
[arguments]<#:tests?>: Update comment.
---
gnu/packages/fpga.scm | 19 +++++++++----------
1 file changed, 9 insertions(+), 10 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 9bc387c762..acce5f8f82 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -65,27 +65,26 @@ (define-module (gnu packages fpga)
#:use-module (gnu packages libusb))
(define-public abc
- (let ((commit "5ae4b975c49c")
- (revision "1"))
+ (let ((commit "70cb339f869e")
+ (revision "2"))
(package
(name "abc")
(version (git-version "0.0" revision commit))
(source (origin
- (method url-fetch)
- (uri
- (string-append "https://bitbucket.org/alanmi/abc/get/" commit ".zip"))
- (file-name (string-append name "-" version "-checkout.zip"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/berkeley-abc/abc")
+ (commit commit)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1syygi1x40rdryih3galr4q8yg1w5bvdzl75hd27v1xq0l5bz3d0"))))
+ "1ngxg4jvz8vwm74sbidysgz3v5lrzjcabkqj4nhcksi6hnhyc9m8"))))
(build-system gnu-build-system)
- (native-inputs
- (list unzip))
(inputs
(list readline))
(arguments
(list #:license-file-regexp "copyright.txt"
- #:tests? #f ; no check target
+ #:tests? #f ; no tests
#:phases
#~(modify-phases %standard-phases
(delete 'configure)
--
2.38.1
Simon South wrote 2 years ago
[PATCH 2/3] gnu: abc: Use gexps.
(address . 60258@debbugs.gnu.org)
fe7fc0e500d0f21ad400d434f215df4ab1a92c99.1671713787.git.simon@simonsouth.net
* gnu/packages/fpga.scm (abc)[arguments]: Use gexps; simplify "install" phase.
---
gnu/packages/fpga.scm | 18 ++++++++----------
1 file changed, 8 insertions(+), 10 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 8784ba9c12..9bc387c762 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -84,16 +84,14 @@ (define-public abc
(inputs
(list readline))
(arguments
- `(#:license-file-regexp "copyright.txt"
- #:tests? #f ; no check target
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (out-bin (string-append out "/bin")))
- (install-file "abc" out-bin)))))))
+ (list #:license-file-regexp "copyright.txt"
+ #:tests? #f ; no check target
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda _
+ (install-file "abc" (string-append #$output "/bin")))))))
(home-page "https://people.eecs.berkeley.edu/~alanmi/abc/")
(synopsis "Sequential logic synthesis and formal verification")
(description "ABC is a program for sequential logic synthesis and
--
2.38.1
Simon South wrote 2 years ago
[PATCH 1/3] gnu: abc: Convey license information.
(address . 60258@debbugs.gnu.org)
3d565c90a0b28f442dd260484e41d800581afc03.1671713787.git.simon@simonsouth.net
* gnu/packages/fpga.scm (abc)[arguments]: Add #:license-file-regexp so license
information is included in package output.
[license]: Specify URI of actual package license.
---
gnu/packages/fpga.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index b2b3b63672..8784ba9c12 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -84,7 +84,8 @@ (define-public abc
(inputs
(list readline))
(arguments
- `(#:tests? #f ; no check target
+ `(#:license-file-regexp "copyright.txt"
+ #:tests? #f ; no check target
#:phases
(modify-phases %standard-phases
(delete 'configure)
@@ -98,7 +99,8 @@ (define-public abc
(description "ABC is a program for sequential logic synthesis and
formal verification.")
(license
- (license:non-copyleft "https://fedoraproject.org/wiki/Licensing:MIT#Modern_Variants")))))
+ (license:non-copyleft
+ "https://people.eecs.berkeley.edu/~alanmi/abc/copyright.htm")))))
(define-public iverilog
(package
--
2.38.1
Ludovic Courtès wrote 2 years ago
Re: bug#60258: [PATCH 0/3] gnu: abc: Update to 0.0-2.70cb339.
(name . Simon South)(address . simon@simonsouth.net)(address . 60258-done@debbugs.gnu.org)
875ydwbh97.fsf@gnu.org
Hi Simon,

Simon South <simon@simonsouth.net> skribis:

Toggle quote (4 lines)
> gnu: abc: Convey license information.
> gnu: abc: Use gexps.
> gnu: abc: Update to 0.0-2.70cb339.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60258@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60258
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help