gajim: dlopen()s non-Guix libc

  • Open
  • quality assurance status badge
Details
One participant
  • Alex Martin
Owner
unassigned
Submitted by
Alex Martin
Severity
normal
A
A
Alex Martin wrote on 21 Dec 2022 02:09
(address . bug-guix@gnu.org)
20221220200917.122378e0@spock.hosts.alm.website
I run Guix on an Alpine Linux host system. Alpine uses the musl C
library. This seems to be what exposes an issue in the gajim Guix
package for me.

I believe what is happening is the following: Gajim dlopen()s libc via
Python's ctypes library, and ends up finding the system libc, not the
Guix-provided libc it is supposed to be linked against.

The result is the following crash:

Traceback (most recent call last):
File "/gnu/store/n2f3pi9cciaxgbvc4nhqzswslv4wycj2-gajim-1.4.6/bin/.gajim-real", line 33, in <module>
sys.exit(load_entry_point('gajim==1.4.6', 'gui_scripts', 'gajim')())
File "/gnu/store/n2f3pi9cciaxgbvc4nhqzswslv4wycj2-gajim-1.4.6/lib/python3.9/site-packages/gajim/gajim.py", line 159, in main
_set_proc_title()
File "/gnu/store/n2f3pi9cciaxgbvc4nhqzswslv4wycj2-gajim-1.4.6/lib/python3.9/site-packages/gajim/gajim.py", line 138, in _set_proc_title
libc = CDLL(find_library('c'))
File "/gnu/store/lvip6h5pamjwmvnkwg60sjb63ph8698k-python-3.9.9/lib/python3.9/ctypes/__init__.py", line 374, in __init__
self._handle = _dlopen(self._name, mode)
OSError: libc.musl-x86_64.so.1: cannot open shared object file: No such file or directory
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEELAGoSzc6nHIdbhP+S8DcQuG8sXMFAmOiXL0ACgkQS8DcQuG8
sXOKmggArK50IhHcXxxhatBP30vcOfjCSKpy7ajl+lZUiZxtqvufrd06TdaYr2m6
tWmQb7mgm3brrN5VXqKDoRiGL1oaVxJWellIrOBJJVh4yIvaLkYKQdpOLtIA+lRK
cZLl30F6OG+WwI7wL7xvSolVeosXJa7iqe8hH7Bc6u0CkjjifUoTkO8m+hEs6jGT
nEO1tX2z/UteQAQMibl4xXEM2l+FR2gMi1KVO+SWJ61/BjSTBJvPkIyhXPXtTZZd
crRXjC4bsHPlJI+P0mkytSz0cHusReyl+rjZH6EXkSnTnTM7r4X/2HaxZO1iF27j
V1ZiiDk3oXohCePFaq3AdUX8cE3LIA==
=TvPI
-----END PGP SIGNATURE-----


?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 60235@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60235
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch