[PATCH][WIP] gnu: zrythm: Update to 1.0.0-beta.4.5.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sughosha
  • Antero Mejr
Owner
unassigned
Submitted by
Antero Mejr
Severity
normal

Debbugs page

Antero Mejr wrote 2 years ago
(address . guix-patches@gnu.org)(name . Antero Mejr)(address . antero@mailbox.org)
20221221031254.2933-1-antero@mailbox.org
* gnu/packages/music.scm (zrythm): Update to 1.0.0-beta.4.5.1.
---
Currently zrythm does not build, and before that it would crash immediately:
This patchset is better than what we have now, but still doesn't work.

zrythm silently fails to launch the main window after the project selection
screen, my guess is that it may be an issue with libpanel, or the app itself.

I may come back to this in the future, not sure.

gnu/packages/music.scm | 112 ++++++++++++++++++++++++++---------------
1 file changed, 72 insertions(+), 40 deletions(-)

Toggle diff (149 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 614eb57791..2ec2880c49 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -110,6 +110,7 @@ (define-module (gnu packages music)
#:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages datastructures)
+ #:use-module (gnu packages digest)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
#:use-module (gnu packages emacs)
@@ -138,6 +139,7 @@ (define-module (gnu packages music)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages java)
+ #:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages libffi)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libusb)
@@ -6237,7 +6239,7 @@ (define-public zrythm
;; distros to make necessary changes to integrate the software into the
;; distribution.
(name "zrythm")
- (version "1.0.0-alpha.12.0.1")
+ (version "1.0.0-beta.4.5.1")
(source
(origin
(method url-fetch)
@@ -6245,48 +6247,78 @@ (define-public zrythm
version ".tar.xz"))
(sha256
(base32
- "1si4n8rdg0a3frlbj6yqpyzr4f20v3cpl4m6kv0yf7r25psyl5pk"))))
+ "03p958xir2p1pzhiqbqq8sax8zaw4b7ww64ymxcvznjrcj4clrpm"))))
(build-system meson-build-system)
(arguments
- `(#:glib-or-gtk? #t
- #:configure-flags
- `("-Dtests=true"
- "-Dmanpage=true"
- "-Ddseg_font=false"
- "-Dgraphviz=enabled" ; for exporting routing graphs
- "-Dguile=enabled" ; for Guile scripting
- "-Djack=enabled" ; for JACK audio/MIDI backend
- "-Drtmidi=enabled" ; for RtMidi backend (ALSA sequencer)
- "-Dsdl=enabled"))) ; for SDL audio backend (which uses ALSA)
- (inputs
- `(("alsa-lib" ,alsa-lib)
- ("jack" ,jack-1)
- ("font-dseg" ,font-dseg)
- ("fftw" ,fftw)
- ("fftwf" ,fftwf)
- ("gettext" ,gettext-minimal)
- ("glibc" ,glibc)
- ("graphviz" ,graphviz)
- ("gtk+" ,gtk+)
- ("gtksourceview" ,gtksourceview)
- ("guile" ,guile-2.2)
- ("libaudec" ,libaudec)
- ("libcyaml" ,libcyaml)
- ("libsamplerate" ,libsamplerate)
- ("libsndfile" ,libsndfile)
- ("libyaml" ,libyaml)
- ("lilv" ,lilv)
- ("lv2" ,lv2)
- ("pulseaudio" ,pulseaudio)
- ("reproc" ,reproc)
- ("rubberband" ,rubberband)
- ("rtmidi" ,rtmidi-4.0)
- ("sdl2" ,sdl2)
- ("xdg-utils" ,xdg-utils)
- ("zstd" ,zstd "lib")))
+ (list #:tests? #f ;123 pass, 3 fail. Appears network-related.
+ #:glib-or-gtk? #t
+ #:configure-flags
+ #~(list "-Dtests=true"
+ "-Dmanpage=false" ; fish-completions breaks this
+ "-Ddseg_font=false"
+ "-Dgraphviz=enabled" ; for exporting routing graphs
+ "-Dguile=enabled" ; for Guile scripting
+ "-Djack=enabled" ; for JACK audio/MIDI backend
+ "-Drtmidi=enabled" ; for RtMidi backend (ALSA sequencer)
+ "-Dsdl=enabled") ; for SDL audio backend (which uses ALSA)
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'adjust-build
+ (lambda _
+ (setenv "GUILE_AUTO_COMPILE" "0")))
+ (add-after 'install 'wrap-program
+ (lambda _
+ (wrap-program (string-append #$output "/bin/zrythm")
+ `("GDK_PIXBUF_MODULE_FILE" =
+ (,(getenv "GDK_PIXBUF_MODULE_FILE")))))))))
+ (propagated-inputs (list breeze-icons
+ gdk-pixbuf
+ librsvg)) ;needed for pixbuf SVG loading
+ (inputs (list alsa-lib
+ boost
+ carla
+ curl
+ fftw
+ fftwf
+ flex
+ font-dseg
+ gettext-minimal
+ glib-next
+ glibc
+ graphviz
+ gtk
+ gtksourceview
+ guile-2.2
+ jack-2
+ json-glib
+ libadwaita
+ libaudec
+ (module-ref
+ (resolve-interface '(gnu packages debug)) 'libbacktrace)
+ libcyaml
+ libpanel
+ libsamplerate
+ libsndfile
+ libyaml
+ lilv
+ lv2
+ pango-next
+ pulseaudio
+ reproc
+ rtmidi
+ rubberband
+ sdl2
+ vamp
+ xdg-utils
+ xxhash
+ zix
+ `(,zstd "lib")))
(native-inputs
- (list pkg-config help2man
- `(,glib "bin"))) ; for 'glib-compile-resources'
+ (list help2man
+ `(,glib-next "bin") ; for 'glib-compile-resources'
+ pkg-config
+ python-sphinx
+ python-sphinx-intl
+ sassc))
(synopsis "Digital audio workstation focusing on usability")
(description "Zrythm is a digital audio workstation designed to be
featureful and easy to use. It offers unlimited automation options, LV2
--
2.38.1
Antero Mejr wrote 2 years ago
[PATCH 1/4] gnu: Add libpanel.
(address . 60232@debbugs.gnu.org)(name . Antero Mejr)(address . antero@mailbox.org)
20221221031804.3191-1-antero@mailbox.org
* gnu/packages/gtk.scm (libpanel): New variable.
---
gnu/packages/gtk.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index de82b9e55f..23b5110a44 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -3037,3 +3037,38 @@ (define-public webp-pixbuf-loader
(synopsis "WebP GdkPixbuf loader library")
(description "Webp-pixbuf-loader is a WebP format loader of GdkPixbuf.")
(license license:lgpl2.0+)))
+
+(define-public libpanel
+ (package
+ (name "libpanel")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.gnome.org/GNOME/libpanel")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10lkysbwg9w0lm1hj7lw4g7y9j8b88kmq07nfgx0r6f319znj12v"))))
+ (build-system meson-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-Ddocs=disabled") ;fontconfig issue
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-gtk-update-icon-cache
+ (lambda _
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false")))))))
+ (native-inputs (list `(,glib-next "bin")
+ gobject-introspection
+ pkg-config
+ vala))
+ (inputs (list glib-next gtk libadwaita))
+ (home-page "https://gitlab.gnome.org/GNOME/libpanel")
+ (synopsis "Dock and panel library for GTK 4")
+ (description "Libpanel provides a library to create IDE-like applications
+using GTK 4 and @code{libadwaita}. It has widgets for panels, docks, columns
+and grids of pages. Primarily, it's design and implementation focus around
+GNOME Builder and Drafting projects.")
+ (license license:lgpl3)))
--
2.38.1
Antero Mejr wrote 2 years ago
[PATCH 2/4] gnu: Add zix.
(address . 60232@debbugs.gnu.org)(name . Antero Mejr)(address . antero@mailbox.org)
20221221031804.3191-2-antero@mailbox.org
* gnu/packages/datastructures.scm (zix): New variable.
---
gnu/packages/datastructures.scm | 40 +++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/datastructures.scm b/gnu/packages/datastructures.scm
index d40051506f..3d179624b8 100644
--- a/gnu/packages/datastructures.scm
+++ b/gnu/packages/datastructures.scm
@@ -26,6 +26,7 @@ (define-module (gnu packages datastructures)
#:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages pkg-config)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix gexp)
@@ -390,3 +391,42 @@ (define-public robin-map
policy, the last two use a prime growth policy instead and are able to cope
better with a poor hash function.")
(license license:expat)))
+
+(define-public zix
+ (let ((commit "56ec14c4369c591f5efbb500b0829b760bee7800")
+ (revision "0"))
+ (package
+ (name "zix")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/drobilla/zix.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "095b2vjmwh9swbwkkkjpcdhsi0c93lxrzd76k7hzdyyf7zb5rgdx"))))
+ (build-system meson-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-Ddocs=disabled"))) ;needs "sphinxygen"
+ (native-inputs (list pkg-config))
+ (home-page "https://gitlab.com/drobilla/zix")
+ (synopsis "C library of portability wrappers and data structures")
+ (description
+ "Zix is a C library of portability wrappers and data structures. It
+provides the following components:
+@enumerate
+@item @code{ZixAllocator}: A customizable allocator.
+@item @code{ZixBumpAllocator}: A simple realtime-safe bump-pointer allocator.
+@item @code{ZixBTree}: A page-allocated B-tree.
+@item @code{ZixHash}: An open-addressing hash table.
+@item @code{ZixRing}: A lock-free realtime-safe ring buffer.
+@item @code{ZixSem}: A portable semaphore wrapper.
+@item @code{ZixThread}: A portable thread wrapper.
+@item @code{ZixTree}: A binary search tree.
+@item @code{zix/digest.h}: Digest functions suitable for hashing arbitrary data.
+@item @code{zix/filesystem.h}: Functions for working with filesystems.
+@item @code{zix/path.h}: Functions for working with filesystem paths lexically.
+@end enumerate\n")
+ (license license:isc))))
--
2.38.1
Antero Mejr wrote 2 years ago
[PATCH 3/4] gnu: carla: Update to 2.6.0 pre-release.
(address . 60232@debbugs.gnu.org)(name . Antero Mejr)(address . antero@mailbox.org)
20221221031804.3191-3-antero@mailbox.org
* gnu/packages/audio.scm (carla): Update to 2.6.0 pre-release.
---
gnu/packages/audio.scm | 10 ++++++----
1 file changed, 6 insertions(+), 4 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index b1d3007b8c..e119565551 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5182,19 +5182,21 @@ (define-public redkite
(license license:gpl3+)))
(define-public carla
+ (let ((commit "aa400535b31c67f4b6c1b28e6e20e4d4f82111a3")
+ (revision "0"))
(package
(name "carla")
- (version "2.4.1")
+ (version (git-version "2.6.0" revision commit))
(source
(origin
(method git-fetch)
(uri
(git-reference
(url "https://github.com/falkTX/Carla")
- (commit (string-append "v" version))))
+ (commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "01ngkmfcxyg1bb4qmfvlkkjbx4lx62akxqhizl8zmqnhfcy4p9bx"))))
+ (base32 "0cnj2sgr60f5h6wdfmihc214wf3n74686sipl3iyzmylqrcyhbjn"))))
(build-system gnu-build-system)
(arguments
(list #:tests? #f ; no "check" target
@@ -5247,7 +5249,7 @@ (define-public carla
over OSC. Carla currently supports LADSPA (including LRDF), DSSI, LV2, VST2,
and VST3 plugin formats, plus SF2 and SFZ file support. It uses JACK as the
default and preferred audio driver but also supports native drivers like ALSA.")
- (license license:gpl2+)))
+ (license license:gpl2+))))
(define-public ecasound
(package
--
2.38.1
Antero Mejr wrote 2 years ago
[PATCH 4/4] gnu: libaudec: Update to 0.3.4.
(address . 60232@debbugs.gnu.org)(name . Antero Mejr)(address . antero@mailbox.org)
20221221031804.3191-4-antero@mailbox.org
* gnu/packages/audio.scm (libaudec): Update to 0.3.4.
---
gnu/packages/audio.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index e119565551..2fc555e4dc 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5297,7 +5297,7 @@ (define-public ecasound
(define-public libaudec
(package
(name "libaudec")
- (version "0.2.4")
+ (version "0.3.4")
(source
(origin
(method git-fetch)
@@ -5307,7 +5307,7 @@ (define-public libaudec
(file-name (git-file-name name version))
(sha256
(base32
- "1570m2dfia17dbkhd2qhx8jjihrpm7g8nnyg6n4wif4vv229s7dz"))))
+ "02hhhpcfkycicygh6g9hzps255zkbbi33vks6yv6zk5wp9p2nspj"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags
--
2.38.1
Sughosha wrote 2 years ago
(No Subject)
(name . 60232@debbugs.gnu.org)(address . 60232@debbugs.gnu.org)
qNW-fhxsE7v8hT7r1sZDmvY8PS98-tBHohEal1OIzMIi6bsYY9rZPOL_nQK8SZlpe9QwoO-KdUCMbIQi_PQjAXS2Vj_S34r3zkEkUj3GCew=@proton.me
Thank you for your great work. I had these two problems as of now:
1. zrythm calls for locale-gen, if the system locale is not English. I tried moving "glibc" from inputs to propagated-inputs, didn't work. But strangly, if I run zrythm inside `guix shell glibc@2.33`, it worked.
2. ALSA is not listed under audio backends, only Dummy and JACK are visible.
Other than these two problems, I didn't find any problem yet.
Antero Mejr wrote 2 years ago
(no subject)
(address . 60232-done@debbugs.gnu.org)
87a5xldekb.fsf@mailbox.org

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60232@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60232
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help