[PATCH] gnu: stockfish: Update to 15.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 2 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20221220000746.10992-1-mike@rohleder.de
* gnu/packages/games.scm (stockfish): Update to 15.1.
[arguments]: Renamed phase remove-m-flag to remove-m-flag-and-net-target.
Add removing of the net target in the Makefile, because it wants networking.
---
gnu/packages/games.scm | 18 ++++++++++--------
1 file changed, 10 insertions(+), 8 deletions(-)

Toggle diff (63 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 6064dabbaa..e178536087 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -52,7 +52,7 @@
;;; Copyright © 2020 Vitaliy Shatrov <D0dyBo0D0dyBo0@protonmail.com>
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
-;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020, 2021, 2022 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Trevor Hass <thass@okstate.edu>
;;; Copyright © 2020, 2021 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;; Copyright © 2020 Lu hux <luhux@outlook.com>
@@ -10336,10 +10336,10 @@ (define-public chessx
(license license:gpl2+)))
(define-public stockfish
- (let ((neural-network-revision "6877cd24400e")) ; also update hash below
+ (let ((neural-network-revision "ad9b42354671")) ; also update hash below
(package
(name "stockfish")
- (version "15")
+ (version "15.1")
(source
(origin
(method git-fetch)
@@ -10348,7 +10348,7 @@ (define-public stockfish
(commit (string-append "sf_" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1v19v6qhwbf31wpc3qcih4dvqxwqkh0p426skgjin6ags31hkbmh"))))
+ (base32 "0zmnv8vbhhid73pjyxg56r4ckm887znv4d55br370plm3p5b56xa"))))
(build-system gnu-build-system)
(inputs
`(("neural-network"
@@ -10358,7 +10358,7 @@ (define-public stockfish
neural-network-revision ".nnue"))
(sha256
(base32
- "1qyna598c0v7gdpycc6kpl12h5a2wa50dqray6gv208f80jcsxv8"))))))
+ "11mpdhnsfggldgvmzwmya64pp3fndyppi2fkdf8kfhbi8qsl56xd"))))))
(arguments
`(#:tests? #f
#:make-flags (list "-C" "src"
@@ -10388,11 +10388,13 @@ (define-public stockfish
(copy-file (assoc-ref inputs "neural-network")
(format #f "src/nn-~a.nnue"
,neural-network-revision))))
- ;; Guix doesn't use a multiarch gcc.
- (add-after 'unpack 'remove-m-flag
+ (add-after 'unpack 'remove-m-flag-and-net-target
(lambda _
(substitute* "src/Makefile"
- (("-m\\$\\(bits\\)") "")))))))
+ ;; Guix doesn't use a multiarch gcc.
+ (("-m\\$\\(bits\\)") "")
+ ;; Dont depend on net target.
+ ((": net") ": ")))))))
(synopsis "Strong chess engine")
(description
"Stockfish is a very strong chess engine. It is much stronger than the
--
2.38.1
Guillaume Le Vaillant wrote 2 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 60211-done@debbugs.gnu.org)
87bknv4dkj.fsf@kitej
Patch pushed as d2cd3290ea4fed6417e6192676a55ee158256df0.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCY6SDTA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8nTQD/Sr3qKIz6wKz5ZmBfo5bCr/KHknwnDYCrCbvv
3rJ61E8A/1g1SC+VaPHjA038gdyN8ahZqp0h/GyxcleLsEfvx2i3
=YG7G
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60211@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60211
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help