Stack smashing detected after first guix pull on fresh Ubuntu 22.04 guix install

  • Done
  • quality assurance status badge
Details
4 participants
  • Andrews, Kyle (KC)
  • Liliana Marie Prikler
  • Ludovic Courtès
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Andrews, Kyle (KC)
Severity
normal
Merged with
A
A
Andrews, Kyle (KC) wrote on 16 Dec 2022 18:15
(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
SJ0P164MB014589973A873837A3E902E6B9E69@SJ0P164MB0145.NAMP164.PROD.OUTLOOK.COM
My system administrator just installed guix for me thanks to it being so easy on Ubuntu.

To show it off, I wanted to make a quick demonstration to a colleague on how it makes it easy to create a reproducible python environment using `guix shell`. That command didn't seem to exist on the version of guix available from ubuntu (1.3.0). Not anticipating any problems, I thought I just needed to run `guix pull`.

#+BEGIN_QUOTE
me@ubuntu:~$ guix pull
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
Authenticating channel 'guix', commits 9edb3f6 to 8548ba5 (45,920 new commits)...
Building from this channel:
...
#+END_QUOTE

That errored out for me at the "computing derivation" stage the first time I ran it.

#+BEGIN_QUOTE
./guix/store.scm:1419:15: ERROR:
1. &store-protocol-error:
message: "`/usr/bin/guix substitute' died unexpectedly"
status: 1
guix pull: error: You found a bug: the program '/gnu/store/4fcbgpasw95hrbz7n7pnx6wnsc174vds-compute-guix-derivation'
failed to compute the derivation for Guix (version: "8548ba5847417eabe14aa08fa9861f91743bd3a1"; system: "x86_64-linux";
host version: "1.3.0"; pull-version: 1).
Please report the COMPLETE output above by email to <bug-guix@gnu.org>.
#+END_QUOTE

Thankfully, running `guix pull` again immediately afterwards worked. This left me with the following familiar output.

#+BEGIN_QUOTE
building profile with 1 package...
hint: Consider setting the necessary environment variables by running:

GUIX_PROFILE="/home/u548962/.config/guix/current"
. "$GUIX_PROFILE/etc/profile"

Alternately, see `guix package --search-paths -p "/home/u548962/.config/guix/current"'.

hint: After setting `PATH', run `hash guix' to make sure your shell refers to `/home/u548962/.config/guix/current/bin/guix'.
#+END_QOUTE

Being that this is a foreign distro, I thought I needed to run the hint lines to get the updated guix executable in my current terminal.

Instead, now I see:

#+BEGIN_QUOTE
me@ubuntu:~$ GUIX_PROFILE="/home/me/.config/guix/current"
me@ubuntu:~$ . "$GUIX_PROFILE/etc/profile"
me@ubuntu:~$ hash guix
me@ubuntu:~$ guix shell --help
*** stack smashing detected ***: terminated
Aborted (core dumped)
u548962@mdu20prst01:~$ guix --help
*** stack smashing detected ***: terminated
Aborted (core dumped)
u548962@mdu20prst01:~$ guix
*** stack smashing detected ***: terminated
Aborted (core dumped)
#+END_QUOTE

I was hopeful, but now the guix command does nothing at all.



General Business
L
L
Liliana Marie Prikler wrote on 17 Dec 2022 12:57
Re: Processed: your mail
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)(address . tracker@debbugs.gnu.org)
d6346932adea38f6bd1426762c6285b107cc0e9a.camel@gmail.com
merge 60139 60141
thanks
T
T
Tobias Geerinckx-Rice wrote on 17 Dec 2022 18:43
(no subject)
(name . GNU Debbugs)(address . control@debbugs.gnu.org)
87pmcic4d8.fsf@nckx
merge 60140 60139
A
A
Andrews, Kyle (KC) wrote on 12 Jan 2023 23:27
Follow-up
(name . 60141@debbugs.gnu.org)(address . 60141@debbugs.gnu.org)
SJ0P164MB01453403CC361A06CB245829B9FD9@SJ0P164MB0145.NAMP164.PROD.OUTLOOK.COM
I moved .config/guix to .config/guix.bkp and that allowed me to execute the basic guix 1.3.0 commands again. However, whatever I create the result is always the same. I get segmentation fault (core dumped). For example:

$ guix install hello
$ {{source the profile}}
$ hello
Segmentation fault (core dumped)

General Business
A
A
Andrews, Kyle (KC) wrote on 13 Jan 2023 17:43
(name . 60141@debbugs.gnu.org)(address . 60141@debbugs.gnu.org)
SA0P164MB0151B283F9A4515D1998D040B9C29@SA0P164MB0151.NAMP164.PROD.OUTLOOK.COM
My system administrator let me know that the terminal I was presented with was sandboxed by RStudio Server (not running on Guix) and that this was responsible for causing the error.

I was able to run the hello command from an unsandboxed shell. I was also able to pull the latest version of guix using the same method.


General Business

-----Original Message-----
From: Andrews, Kyle (KC)
Sent: Thursday, January 12, 2023 5:28 PM
To: 60141@debbugs.gnu.org
Subject: Follow-up

I moved .config/guix to .config/guix.bkp and that allowed me to execute the basic guix 1.3.0 commands again. However, whatever I create the result is always the same. I get segmentation fault (core dumped). For example:

$ guix install hello
$ {{source the profile}}
$ hello
Segmentation fault (core dumped)

General Business
L
L
Ludovic Courtès wrote on 17 Jan 2023 16:20
Re: bug#60141: Stack smashing detected after first guix pull on fresh Ubuntu 22.04 guix install
(name . Andrews, Kyle (KC))(address . KCAndrews@dow.com)(name . 60141@debbugs.gnu.org)(address . 60141@debbugs.gnu.org)
87r0vtfarn.fsf_-_@gnu.org
Hi,

"Andrews, Kyle (KC)" <KCAndrews@dow.com> skribis:

Toggle quote (4 lines)
> My system administrator let me know that the terminal I was presented with was sandboxed by RStudio Server (not running on Guix) and that this was responsible for causing the error.
>
> I was able to run the hello command from an unsandboxed shell. I was also able to pull the latest version of guix using the same method.

Thanks for reporting back. My guess would be that RStudio Server was
setting ‘LD_LIBRARY_PATH’, which in turn caused ‘guix’ to use the wrong
shared library at run-time, leading to that segfault.

I gather we can close this issue now, thanks.

Ludo’.
L
L
Ludovic Courtès wrote on 17 Jan 2023 16:20
control message for bug #60141
(address . control@debbugs.gnu.org)
87pmbdfar7.fsf@gnu.org
tags 60141 notabug
close 60141
quit
?