[PATCH] gnu: megacmd: Update to 1.5.1 and add libuv dependency for webdav functionality.

  • Done
  • quality assurance status badge
Details
2 participants
  • Wamm K. D
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Wamm K. D
Severity
normal
W
W
Wamm K. D wrote on 17 Dec 2022 03:50
(address . guix-patches@gnu.org)(name . Wamm K. D)(address . jaft.r@outlook.com)
BY5PR07MB7029E8D0FF6E28D4D066E43199E79@BY5PR07MB7029.namprd07.prod.outlook.com
* gnu/packages/sync.scm (megacmd): Update to 1.5.1 and add libuv dependency.
---
current megacmd doesn't have the webdav functionality because it's missing
libuv as a dependency. It's also an older version so I've updated that, as
well.

gnu/packages/sync.scm | 31 ++++++++++++++++---------------
1 file changed, 16 insertions(+), 15 deletions(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 8330b96dd7..66a573f665 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -217,7 +217,7 @@ (define-public nextcloud-client
(define-public megacmd
(package
(name "megacmd")
- (version "1.1.0")
+ (version "1.5.1")
(source
(origin
(method git-fetch)
@@ -227,28 +227,29 @@ (define-public megacmd
(recursive? #t)))
(sha256
(base32
- "004j8m3xs6slx03g2g6wzr97myl2v3zc09wxnfar5c62a625pd53"))
+ "12v46jyxdgp2qqdpmd084d60hd5srjbgwpk082b3rp5dl7yg1rd8"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
;; XXX: Disabling tests because they depend on libgtest.la from googletest,
;; which is not installed for unclear reasons.
(arguments
- `(#:tests? #f
- #:configure-flags '("--with-pcre")))
+ (list #:tests? #f
+ #:configure-flags #~'("--with-pcre")))
(native-inputs
(list autoconf automake libtool))
(inputs
- `(("c-ares" ,c-ares)
- ("crypto++" ,crypto++)
- ("curl" ,curl)
- ("freeimage" ,freeimage)
- ("gtest" ,googletest)
- ("openssl" ,openssl)
- ("pcre" ,pcre)
- ("readline" ,readline)
- ("sodium" ,libsodium)
- ("sqlite3" ,sqlite)
- ("zlib" ,zlib)))
+ (list c-ares
+ crypto++
+ curl
+ freeimage
+ googletest
+ libuv
+ openssl
+ pcre
+ readline
+ libsodium
+ sqlite
+ zlib))
(home-page "https://mega.nz/cmd")
(synopsis
"Command Line Interactive and Scriptable Application to access mega.nz")
--
2.38.1
N
N
Nicolas Goaziou wrote on 4 Feb 2023 00:07
(name . Wamm K. D)(address . jaft.r@outlook.com)(address . 60138-done@debbugs.gnu.org)
878rhez6u6.fsf@nicolasgoaziou.fr
Hello,

"Wamm K. D" <jaft.r@outlook.com> writes:

Toggle quote (3 lines)
> * gnu/packages/sync.scm (megacmd): Update to 1.5.1 and add libuv
> dependency.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60138@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60138
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch