[PATCH 1/3] patman: remove extraneous imports

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Simon Glass
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 17 Dec 2022 02:45
(address . guix-patches@gnu.org)
20221217014530.27772-1-maxim.cournoyer@savoirfairelinux.com
* tools/patman/main.py: Remove extraneous imports and fix indentation.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@savoirfairelinux.com>
---

tools/patman/main.py | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)

Toggle diff (41 lines)
diff --git a/tools/patman/main.py b/tools/patman/main.py
index 5a7756a221..8067a288ab 100755
--- a/tools/patman/main.py
+++ b/tools/patman/main.py
@@ -9,7 +9,6 @@
from argparse import ArgumentParser
import os
import re
-import shutil
import sys
import traceback
@@ -19,7 +18,6 @@ if __name__ == "__main__":
sys.path.append(os.path.join(our_path, '..'))
# Our modules
-from patman import command
from patman import control
from patman import gitutil
from patman import project
@@ -136,7 +134,6 @@ if not args.debug:
# Run our meagre tests
if args.cmd == 'test':
- import doctest
from patman import func_test
result = test_util.run_test_suites(
@@ -183,7 +180,7 @@ elif args.cmd == 'status':
args.show_comments, args.patchwork_url)
except Exception as e:
terminal.tprint('patman: %s: %s' % (type(e).__name__, e),
- colour=terminal.Color.RED)
+ colour=terminal.Color.RED)
if args.debug:
print()
traceback.print_exc()

base-commit: 9bd3d354a1a0712ac27c717df9ad60566b0406ee
--
2.38.1
M
M
Maxim Cournoyer wrote on 17 Dec 2022 03:22
control message for bug #60132
(address . control@debbugs.gnu.org)
871qoybwhc.fsf@gmail.com
tags 60132 notabug
close 60132
quit
S
S
Simon Glass wrote on 17 Dec 2022 23:24
Re: [PATCH 1/3] patman: remove extraneous imports
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
CAPnjgZ1rKRGrmEymEpaAGcqCQG5LuGusYoUdeGNwKo-K3Boksg@mail.gmail.com
On Fri, 16 Dec 2022 at 18:45, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
Toggle quote (9 lines)
>
> * tools/patman/main.py: Remove extraneous imports and fix indentation.
>
> Signed-off-by: Maxim Cournoyer <maxim.cournoyer@savoirfairelinux.com>
> ---
>
> tools/patman/main.py | 5 +----
> 1 file changed, 1 insertion(+), 4 deletions(-)

Reviewed-by: Simon Glass <sjg@chromium.org>
S
S
Simon Glass wrote on 21 Dec 2022 01:28
Re: [PATCH 3/3] patman: locate README.rst via importlib
(name . Simon Glass)(address . sjg@chromium.org)
CAPnjgZ3dV+JAN6NdFAcr=sj3B5Q+JVHa5Twhu6oMH1zssO5s3Q@mail.gmail.com
On Fri, 16 Dec 2022 at 18:45, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
Toggle quote (12 lines)
>
> Rationale: this is more robust than assumptions about the file
> hierarchy layout of the installation of patman, for example on non
> file-hierarchy standard (FHS) systems such as Guix System or Nix OS.
>
> Signed-off-by: Maxim Cournoyer <maxim.cournoyer@savoirfairelinux.com>
> ---
>
> tools/patman/main.py | 8 +++-----
> 1 file changed, 3 insertions(+), 5 deletions(-)
>

Reviewed-by: Simon Glass <sjg@chromium.org>

Applied to u-boot-dm/next, thanks!
S
S
Simon Glass wrote on 21 Dec 2022 01:28
Re: [PATCH 1/3] patman: remove extraneous imports
(name . Simon Glass)(address . sjg@chromium.org)
CAPnjgZ0KuR2Ut248H44dt86cuc0PspD+OK4WbmUPaPrB-5gUKw@mail.gmail.com
On Fri, 16 Dec 2022 at 18:45, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
Toggle quote (9 lines)
>
> * tools/patman/main.py: Remove extraneous imports and fix indentation.
>
> Signed-off-by: Maxim Cournoyer <maxim.cournoyer@savoirfairelinux.com>
> ---
>
> tools/patman/main.py | 5 +----
> 1 file changed, 1 insertion(+), 4 deletions(-)

Reviewed-by: Simon Glass <sjg@chromium.org>

Applied to u-boot-dm/next, thanks!
S
S
Simon Glass wrote on 21 Dec 2022 01:28
Re: [PATCH 2/3] patman: fix installation of README.rst data file
(name . Simon Glass)(address . sjg@chromium.org)
CAPnjgZ0XCnTrN4c7pEr-c52H_xQsZdS18RcFCGYw1tVwan09hw@mail.gmail.com
On Fri, 16 Dec 2022 at 18:45, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
Toggle quote (10 lines)
>
> This fixes a regression introduced in commit 74df491051d6 ("buildman:
> Convert documentation to rST").
>
> Signed-off-by: Maxim Cournoyer <maxim.cournoyer@savoirfairelinux.com>
> ---
>
> tools/patman/setup.py | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)

Reviewed-by: Simon Glass <sjg@chromium.org>

Applied to u-boot-dm/next, thanks!
?