[PATCH] gnu: Add python-bamnostic.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)
20221216160115.32252-1-navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (python-bamnostic): New variable.
---
gnu/packages/bioinformatics.scm | 72 +++++++++++++++++++++++++++++++++
1 file changed, 72 insertions(+)

Toggle diff (85 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e8da00d805..cb423312a8 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3646,6 +3646,78 @@ (define-public edirect-go-programs
go-golang-org-x-image
go-golang-org-x-text))))
+(define-public python-bamnostic
+ (package
+ (name "python-bamnostic")
+ (version "1.1.8")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "bamnostic" version))
+ (sha256
+ (base32
+ "0cjpzyqz6r4lmiwry2gcxdczwpkhl3lyyjg4s8addln17691ysxk"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-pytest))
+ (home-page "https://github.com/betteridiot/bamnostic/")
+ (synopsis
+ "A tool for binary alignment map, random access and parsing")
+ (description
+ "A tool for binary alignment map, random access and parsing.")
+ (license license:bsd-3)))
+
+(define-public python-episcanpy
+ (package
+ (name "python-episcanpy")
+ (version "0.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "episcanpy" version))
+ (sha256
+ (base32
+ "1qqcyhyzy6idpjmidfdpzwk02hbxm25rymz42h51nlk0vd4r2wwm"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:phases
+ '(modify-phases %standard-phases
+ ;; Numba needs a writable dir to cache functions.
+ (add-before 'build 'set-numba-cache-dir
+ (lambda _
+ (setenv "NUMBA_CACHE_DIR" "/tmp"))))))
+ (propagated-inputs (list python-anndata
+ python-bamnostic
+ python-h5py
+ python-intervaltree
+ python-joblib
+ python-kneed
+ python-legacy-api-wrap
+ python-matplotlib
+ python-natsort
+ python-networkx
+ python-numba
+ python-numpy
+ python-packaging
+ python-pandas
+ python-scanpy
+ python-scikit-learn
+ python-scipy
+ python-seaborn
+ python-setuptools-scm
+ python-statsmodels
+ python-tqdm
+ python-pysam
+ python-pytest
+ python-tbb
+ python-umap-learn))
+ (native-inputs (list python-pytest))
+ (home-page "http://github.com/colomemaria/epiScanpy")
+ (synopsis "A tool for epigenomics single cell analysis")
+ (description
+ "A toolkit to analyse single-cell open chromatin
+and single-cell DNA methylation data.")
+ (license license:bsd-3)))
+
(define-public exonerate
(package
(name "exonerate")
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 60124-done@debbugs.gnu.org)
87zgbgmjli.fsf@elephly.net
Thanks for the patches!

I split them into two commits, changed the synopses and descriptions,
and moved some inputs around as suggested by “guix lint”.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60124@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60124
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help