[PATCH 0/8] Update openjdk.

  • Done
  • quality assurance status badge
Details
3 participants
  • Greg Hogan
  • Efraim Flashner
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal
G
G
Greg Hogan wrote on 12 Dec 2022 22:18
(address . guix-patches@gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
cover.1670879700.git.code@greghogan.com
These look to be the latest updates to openjdk11+.

The openjdk build process creates thousands of defunct bash processes,
necessitating the increase in maximum number of tasks.

Greg Hogan (8):
Increase "TasksMax" in 'guix-daemon.service'.
gnu: openjdk11: Update to 11.0.17.
gnu: openjdk13: Update to 13.0.13.
gnu: openjdk15: Update to 15.0.9.
gnu: openjdk16: Update to 16.0.2.
gnu: openjdk17: Update to 17.0.5.
gnu: openjdk18: Update to 18.0.2.
gnu: openjdk: Update to 19.

etc/guix-daemon.service.in | 2 +-
gnu/packages/java.scm | 44 +++++++++++++++++++++++++++-----------
2 files changed, 32 insertions(+), 14 deletions(-)

--
2.38.1
G
G
Greg Hogan wrote on 12 Dec 2022 22:19
[PATCH 1/8] Increase "TasksMax" in 'guix-daemon.service'.
(address . 60020@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20a264e6511ad4a92553f977628bff8ac82b9770.1670879700.git.code@greghogan.com
* etc/guix-daemon.service.in (TasksMax): Increase to 16384.
---
etc/guix-daemon.service.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/etc/guix-daemon.service.in b/etc/guix-daemon.service.in
index 9dbc3b5678..25e895235f 100644
--- a/etc/guix-daemon.service.in
+++ b/etc/guix-daemon.service.in
@@ -22,7 +22,7 @@ Restart=always
# See <https://lists.gnu.org/archive/html/guix-devel/2016-04/msg00608.html>.
# Some package builds (for example, go@1.8.1) may require even more than
# 1024 tasks.
-TasksMax=8192
+TasksMax=16384
[Install]
WantedBy=multi-user.target
--
2.38.1
G
G
Greg Hogan wrote on 12 Dec 2022 22:19
[PATCH 2/8] gnu: openjdk11: Update to 11.0.17.
(address . 60020@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
25f1db22e8685b5aa7879ffbe5fa6c5df9cd0ce0.1670879700.git.code@greghogan.com
* gnu/packages/java.scm (openjdk11): Update to 11.0.17.
[native-inputs]: Add bash.
---
gnu/packages/java.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index f80406cab9..d4dfd4be39 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1761,7 +1761,7 @@ (define-public openjdk10
(define-public openjdk11
(package
(name "openjdk")
- (version "11.0.15")
+ (version "11.0.17")
(source (origin
(method url-fetch)
(uri (string-append "https://openjdk-sources.osci.io/openjdk11/openjdk-"
@@ -1769,7 +1769,7 @@ (define-public openjdk11
(file-name (string-append name "-" version ".tar.bz2"))
(sha256
(base32
- "0di91nnms2iq1svgq72r5y17am17r4vh2lq43k0bkcwpc84d6nd8"))
+ "1prvqy0ysz0999wrhsrbz6vrknpqfihl9l74l16ph93g89dqi5ia"))
(modules '((guix build utils)))
(snippet
'(for-each delete-file (find-files "." ".*.(bin|exe|jar)$")))))
@@ -2019,6 +2019,7 @@ (define-public openjdk11
libxtst))
(native-inputs
(list autoconf
+ bash
openjdk10
`(,openjdk10 "jdk")
gnu-make-4.2
--
2.38.1
G
G
Greg Hogan wrote on 12 Dec 2022 22:19
[PATCH 3/8] gnu: openjdk13: Update to 13.0.13.
(address . 60020@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
bada8f92a623f9008e67de4c5004b4ab891b5ae4.1670879700.git.code@greghogan.com
* gnu/packages/java.scm (openjdk13): Update to 13.0.13.
---
gnu/packages/java.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index d4dfd4be39..d19c10062b 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2101,8 +2101,8 @@ (define-public openjdk12
"#! java BlacklistedCertsConverter SHA-256\n"))))))))))
(define-public openjdk13
- (make-openjdk openjdk12 "13.0.7"
- "0wrrr0d7lz1v8qqm752mn4gz5l2vpl2kmx4ac3ysvk4mljc924hp"))
+ (make-openjdk openjdk12 "13.0.13"
+ "0pxf4dlig61k0pg7amg4mi919hzam7nzwckry01avgq1wj8ambji"))
(define-public openjdk14
(make-openjdk
--
2.38.1
G
G
Greg Hogan wrote on 12 Dec 2022 22:19
[PATCH 4/8] gnu: openjdk15: Update to 15.0.9.
(address . 60020@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
8cfdf6e7f3eab4541a208acfc2d53b78dab1b554.1670879700.git.code@greghogan.com
* gnu/packages/java.scm (openjdk15): Update to 15.0.9.
---
gnu/packages/java.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index d19c10062b..9a0ed07ed3 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2120,8 +2120,8 @@ (define-public openjdk14
(define-public openjdk15
(make-openjdk
- openjdk14 "15.0.3"
- "168cr08nywp0q3vyj8njkhsmmnyd8rz9r58hk4xhzdzc6bdfkl1i"
+ openjdk14 "15.0.9"
+ "1k3x06fv89l84ysjsyw8s89q8blghq85m6xjzv373x6297ln8n7a"
(source (origin
(inherit (package-source base))
(modules '())
--
2.38.1
G
G
Greg Hogan wrote on 12 Dec 2022 22:19
[PATCH 5/8] gnu: openjdk16: Update to 16.0.2.
(address . 60020@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
30d592f189f6a3215e7bb47ee5266e54ec68c2a0.1670879700.git.code@greghogan.com
* gnu/packages/java.scm (openjdk16): Update to 16.0.2.
---
gnu/packages/java.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 9a0ed07ed3..0c57dca114 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2138,8 +2138,8 @@ (define-public openjdk15
(append `(,openjdk14 "jdk"))))))
(define-public openjdk16
- (make-openjdk openjdk15 "16.0.1"
- "1ggddsbsar4dj2fycfqqqagqil7prhb30afvq6933rz7pa9apm2f"))
+ (make-openjdk openjdk15 "16.0.2"
+ "0587px2qbz07g3xi4a3ya6m630p72dvkxcn0bj1813pxnwvcgigz"))
(define-public openjdk17
(make-openjdk
--
2.38.1
G
G
Greg Hogan wrote on 12 Dec 2022 22:19
[PATCH 6/8] gnu: openjdk17: Update to 17.0.5.
(address . 60020@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
ecdd799cc36938f514ec05e31d2d55ba47d04cb4.1670879700.git.code@greghogan.com
* gnu/packages/java.scm (openjdk17): Update to 17.0.5.
---
gnu/packages/java.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 0c57dca114..2dbcdce44f 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2143,8 +2143,8 @@ (define-public openjdk16
(define-public openjdk17
(make-openjdk
- openjdk16 "17.0.3"
- "0slmd6ww947gxpp4yr2wmr5z975bg86qh7zqfp2radf2q77ql65b"
+ openjdk16 "17.0.5"
+ "1asnysg6kxdkrmb88y6qihdr12ljsyxv0mg6hlcs7cwxgsdlqkfs"
(arguments
(substitute-keyword-arguments (package-arguments openjdk16)
((#:phases phases)
--
2.38.1
G
G
Greg Hogan wrote on 12 Dec 2022 22:19
[PATCH 7/8] gnu: openjdk18: Update to 18.0.2.
(address . 60020@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
ff1bb22098040974c2e54f607c459859bd0e800c.1670879700.git.code@greghogan.com
* gnu/packages/java.scm (openjdk18): Update to 18.0.2.
---
gnu/packages/java.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 2dbcdce44f..afd8c60f55 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2156,8 +2156,8 @@ (define-public openjdk17
(("^#!.*") "#! java BlockedCertsConverter SHA-256\n"))))))))))
(define-public openjdk18
- (make-openjdk openjdk17 "18"
- "1bv6bdhkmwvn10l0xy8yi9xibds640hs5zsvx0jp7wrxa3qw4qy8"))
+ (make-openjdk openjdk17 "18.0.2"
+ "1yimfdkwpinhg5cf1mcrzk9xvjwnray3cx762kypb9jcwbranjwx"))
;;; Convenience alias to point to the latest version of OpenJDK.
(define-public openjdk openjdk18)
--
2.38.1
G
G
Greg Hogan wrote on 12 Dec 2022 22:19
[PATCH 8/8] gnu: openjdk: Update to 19.
(address . 60020@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
6387d3878e0aeb3677003e5243fb58ff3c2864fa.1670879700.git.code@greghogan.com
* gnu/packages/java.scm (openjdk): Update to 19.
(openjdk19): New variable.
---
gnu/packages/java.scm | 19 ++++++++++++++++++-
1 file changed, 18 insertions(+), 1 deletion(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index afd8c60f55..05a1b8996a 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2159,8 +2159,25 @@ (define-public openjdk18
(make-openjdk openjdk17 "18.0.2"
"1yimfdkwpinhg5cf1mcrzk9xvjwnray3cx762kypb9jcwbranjwx"))
+(define-public openjdk19
+ (make-openjdk openjdk18 "19.0.1"
+ "0kyalb391znw6idmfn3dsx6c2mal1hl63f0bwa4mlnsxfl380bi1"
+ (arguments
+ (substitute-keyword-arguments (package-arguments openjdk18)
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (replace 'fix-java-shebangs
+ (lambda _
+ ;; Update file path.
+ (substitute* "src/java.base/share/data/blockedcertsconverter/blocked.certs.pem"
+ (("^#!.*") "#! java BlockedCertsConverter SHA-256\n"))))
+ (add-before 'configure 'define-java-environment-variables
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Fix for "valid range 1980-01-01T00:00:02Z to 2099-12-31T23:59:59Z".
+ (setenv "SOURCE_DATE_EPOCH" "1234567890")))))))))
+
;;; Convenience alias to point to the latest version of OpenJDK.
-(define-public openjdk openjdk18)
+(define-public openjdk openjdk19)
(define-public icedtea icedtea-8)
--
2.38.1
M
M
Maxim Cournoyer wrote on 16 Jan 2023 18:59
Re: bug#60020: [PATCH 0/8] Update openjdk.
(name . Greg Hogan)(address . code@greghogan.com)(address . 60020@debbugs.gnu.org)
87a62i5pjc.fsf@gmail.com
Hello,

Greg Hogan <code@greghogan.com> writes:

Toggle quote (8 lines)
> These look to be the latest updates to openjdk11+.
>
> The openjdk build process creates thousands of defunct bash processes,
> necessitating the increase in maximum number of tasks.
>
> Greg Hogan (8):
> Increase "TasksMax" in 'guix-daemon.service'.

This doesn't appear to have been merged yet. Is it still neeeded?

Toggle quote (8 lines)
> gnu: openjdk11: Update to 11.0.17.
> gnu: openjdk13: Update to 13.0.13.
> gnu: openjdk15: Update to 15.0.9.
> gnu: openjdk16: Update to 16.0.2.
> gnu: openjdk17: Update to 17.0.5.
> gnu: openjdk18: Update to 18.0.2.
> gnu: openjdk: Update to 19.

These appear to have been merged already. Feel free to close if there's
nothing left to do here.

--
Thanks,
Maxim
G
G
Greg Hogan wrote on 17 Jan 2023 17:04
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 60020@debbugs.gnu.org)
CA+3U0ZkqfK0FQ5JVDDWmn8OEyR9QJJdmbg=-rYzU6BRueCLzyg@mail.gmail.com
On Mon, Jan 16, 2023 at 12:59 PM Maxim Cournoyer
<maxim.cournoyer@gmail.com> wrote:
Toggle quote (15 lines)
>
> Hello,
>
> Greg Hogan <code@greghogan.com> writes:
>
> > These look to be the latest updates to openjdk11+.
> >
> > The openjdk build process creates thousands of defunct bash processes,
> > necessitating the increase in maximum number of tasks.
> >
> > Greg Hogan (8):
> > Increase "TasksMax" in 'guix-daemon.service'.
>
> This doesn't appear to have been merged yet. Is it still needed?

Yes. Do we know what TasksMax is set to on the build farms?

Toggle quote (11 lines)
> > gnu: openjdk11: Update to 11.0.17.
> > gnu: openjdk13: Update to 13.0.13.
> > gnu: openjdk15: Update to 15.0.9.
> > gnu: openjdk16: Update to 16.0.2.
> > gnu: openjdk17: Update to 17.0.5.
> > gnu: openjdk18: Update to 18.0.2.
> > gnu: openjdk: Update to 19.
>
> These appear to have been merged already. Feel free to close if there's
> nothing left to do here.

Everything except openjdk@19 was merged, so I don't know if that was
an editorial decision by the committer because version 19 was so new
(19.0.1 has since been released). I would close this ticket except for
waiting to confirm and accept the increase to TasksMax.

Toggle quote (3 lines)
> --
> Thanks,
> Maxim
M
M
Maxim Cournoyer wrote on 17 Jan 2023 20:38
(name . Greg Hogan)(address . code@greghogan.com)
87v8l5ymrv.fsf@gmail.com
+CC Efram

Hi Greg,

Greg Hogan <code@greghogan.com> writes:

Toggle quote (34 lines)
> On Mon, Jan 16, 2023 at 12:59 PM Maxim Cournoyer
> <maxim.cournoyer@gmail.com> wrote:
>>
>> Hello,
>>
>> Greg Hogan <code@greghogan.com> writes:
>>
>> > These look to be the latest updates to openjdk11+.
>> >
>> > The openjdk build process creates thousands of defunct bash processes,
>> > necessitating the increase in maximum number of tasks.
>> >
>> > Greg Hogan (8):
>> > Increase "TasksMax" in 'guix-daemon.service'.
>>
>> This doesn't appear to have been merged yet. Is it still needed?
>
> Yes. Do we know what TasksMax is set to on the build farms?
>
>> > gnu: openjdk11: Update to 11.0.17.
>> > gnu: openjdk13: Update to 13.0.13.
>> > gnu: openjdk15: Update to 15.0.9.
>> > gnu: openjdk16: Update to 16.0.2.
>> > gnu: openjdk17: Update to 17.0.5.
>> > gnu: openjdk18: Update to 18.0.2.
>> > gnu: openjdk: Update to 19.
>>
>> These appear to have been merged already. Feel free to close if there's
>> nothing left to do here.
>
> Everything except openjdk@19 was merged, so I don't know if that was
> an editorial decision by the committer because version 19 was so new
> (19.0.1 has since been released).

Efraim, was this an oversight or you were waiting to upload the new
release?

Toggle quote (3 lines)
> I would close this ticket except for
> waiting to confirm and accept the increase to TasksMax.

OK; there doesn't seem to be anything particular on the build farm, per
(sysadmin services) in the guix-maintenance repository:

Toggle snippet (21 lines)
(define* (guix-daemon-config #:key (max-jobs 5) (cores 4)
(build-accounts-to-max-jobs-ratio 4)
(authorized-keys '()))
(guix-configuration
(substitute-urls '())
(authorized-keys authorized-keys)

;; We don't want to let builds get stuck for too long, but we still want
;; to allow building, say, Guile 2.2 on armhf-linux, which takes < 3h on
;; an OverDrive 1000.
(max-silent-time 3600)
(timeout (* 6 3600))

(log-compression 'gzip) ;be friendly to 'guix publish' users

(build-accounts (* build-accounts-to-max-jobs-ratio max-jobs))
(extra-options (list "--max-jobs" (number->string max-jobs)
"--cores" (number->string cores)
"--gc-keep-outputs" "--gc-keep-derivations"))))

And it uses the guix-daemon from the latest Guix package in Guix, so it
doesn't seem to be needed there?

--
Thanks,
Maxim
E
E
Efraim Flashner wrote on 18 Jan 2023 10:40
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
Y8e+kYwU0cFFfYW4@3900XT
On Tue, Jan 17, 2023 at 02:38:28PM -0500, Maxim Cournoyer wrote:
Toggle quote (43 lines)
> +CC Efram
>
> Hi Greg,
>
> Greg Hogan <code@greghogan.com> writes:
>
> > On Mon, Jan 16, 2023 at 12:59 PM Maxim Cournoyer
> > <maxim.cournoyer@gmail.com> wrote:
> >>
> >> Hello,
> >>
> >> Greg Hogan <code@greghogan.com> writes:
> >>
> >> > These look to be the latest updates to openjdk11+.
> >> >
> >> > The openjdk build process creates thousands of defunct bash processes,
> >> > necessitating the increase in maximum number of tasks.
> >> >
> >> > Greg Hogan (8):
> >> > Increase "TasksMax" in 'guix-daemon.service'.
> >>
> >> This doesn't appear to have been merged yet. Is it still needed?
> >
> > Yes. Do we know what TasksMax is set to on the build farms?
> >
> >> > gnu: openjdk11: Update to 11.0.17.
> >> > gnu: openjdk13: Update to 13.0.13.
> >> > gnu: openjdk15: Update to 15.0.9.
> >> > gnu: openjdk16: Update to 16.0.2.
> >> > gnu: openjdk17: Update to 17.0.5.
> >> > gnu: openjdk18: Update to 18.0.2.
> >> > gnu: openjdk: Update to 19.
> >>
> >> These appear to have been merged already. Feel free to close if there's
> >> nothing left to do here.
> >
> > Everything except openjdk@19 was merged, so I don't know if that was
> > an editorial decision by the committer because version 19 was so new
> > (19.0.1 has since been released).
>
> Efraim, was this an oversight or you were waiting to upload the new
> release?

I meant to come back to this one. I wasn't able to build version 19
locally and I guess I forgot to say anything :/


Toggle quote (35 lines)
> > I would close this ticket except for
> > waiting to confirm and accept the increase to TasksMax.
>
> OK; there doesn't seem to be anything particular on the build farm, per
> (sysadmin services) in the guix-maintenance repository:
>
> --8<---------------cut here---------------start------------->8---
> (define* (guix-daemon-config #:key (max-jobs 5) (cores 4)
> (build-accounts-to-max-jobs-ratio 4)
> (authorized-keys '()))
> (guix-configuration
> (substitute-urls '())
> (authorized-keys authorized-keys)
>
> ;; We don't want to let builds get stuck for too long, but we still want
> ;; to allow building, say, Guile 2.2 on armhf-linux, which takes < 3h on
> ;; an OverDrive 1000.
> (max-silent-time 3600)
> (timeout (* 6 3600))
>
> (log-compression 'gzip) ;be friendly to 'guix publish' users
>
> (build-accounts (* build-accounts-to-max-jobs-ratio max-jobs))
> (extra-options (list "--max-jobs" (number->string max-jobs)
> "--cores" (number->string cores)
> "--gc-keep-outputs" "--gc-keep-derivations"))))
> --8<---------------cut here---------------end--------------->8---
>
> And it uses the guix-daemon from the latest Guix package in Guix, so it
> doesn't seem to be needed there?
>
> --
> Thanks,
> Maxim

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmPHvpEACgkQQarn3Mo9
g1GYQw/7BU+Us1qoeyRbJcBX2V0V1cdJ0+09MYpOt9zKRRapZTecjfCMoqPo2nxW
9YUd7LdGcDAPKLpfpr/x5A03dLtalxs2YP2dPeTVEgESUwQOpOtRBEvd3ZxT7XCW
sNheLNeUbE7NIuqn/RPQpHV56SKDcDHf4Gsfwf7jQX0nIzMXUYY4aCKgYluO935R
vLUxv2+pO9xsHapTYaHndJGZ7Z2FPKr5IMLpt1WKGRZNaHdeGdhsyDySi/KoSpI2
C2bHaiaylEsCPXifPHuOCvFR1oNU0j2g8fCHjV9/I/2sxUVAWt/xAlEsQM/HL0mx
ln7p2adIojzGDqG4XlSInurvvrY9A8OwNqKdcGscmzM3LpFS+2STIBdIR/OqhT6A
eRpnYISPpiEbalY7I2HZFE1GxUWjiSObnsNyde7CggVCU5R8Tn+PodhAmeWI39Gj
v5fXyewc4Zke/Zvj8i1Hdt0d1rxNUy8PKL4/vmMFdtcmgrthry+5/i0R75//oTZ3
GzslpFNijy1VIkvLhC86JWAt1KX3aI0QVkEw49Lvd5EOoaMW5Gz4DI0RNuwbhEWr
4SEJhVmEU9BrEt6PoyCrPHmob+cMsBJSWdr4F/8+SLMQbj9gYvsadmoZdG1zA+Vo
4BTg21lh1BkXJ84R2nbNgQInbNi9DOYnPOwuEM+fRlAkozEBThE=
=CRoi
-----END PGP SIGNATURE-----


G
G
Greg Hogan wrote on 18 Jan 2023 16:03
CA+3U0ZmFvbkMZ088+4=CARH=jKhddqj8cFGKdGDUxfz_wER8oQ@mail.gmail.com
On Wed, Jan 18, 2023 at 4:40 AM Efraim Flashner <efraim@flashner.co.il> wrote:
Toggle quote (4 lines)
>
> I meant to come back to this one. I wasn't able to build version 19
> locally and I guess I forgot to say anything :/

I see that this was committed and built successfully on ci. Since
TasksMax only appears to be affecting my foreign distro build
environment (with thousands of zombie bash processes) this ticket is
complete and I am closing. Thanks Maxim and Efraim!

Greg
Closed
M
M
Maxim Cournoyer wrote on 18 Jan 2023 16:45
(name . Greg Hogan)(address . code@greghogan.com)
87y1pz7sni.fsf@gmail.com
Hi,

Greg Hogan <code@greghogan.com> writes:

Toggle quote (10 lines)
> On Wed, Jan 18, 2023 at 4:40 AM Efraim Flashner <efraim@flashner.co.il> wrote:
>>
>> I meant to come back to this one. I wasn't able to build version 19
>> locally and I guess I forgot to say anything :/
>
> I see that this was committed and built successfully on ci. Since
> TasksMax only appears to be affecting my foreign distro build
> environment (with thousands of zombie bash processes) this ticket is
> complete and I am closing. Thanks Maxim and Efraim!

The zombie processes could be resolved by fixing #30948.

--
Thanks,
Maxim
Closed
?