[PATCH] gnu: Add raylib.

  • Done
  • quality assurance status badge
Details
3 participants
  • dan
  • Ludovic Courtès
  • (
Owner
unassigned
Submitted by
dan
Severity
normal
D
(address . guix-patches@gnu.org)
20221212141100.27626-1-i@dan.games
* gnu/packages/game-development.scm (raylib): New variable.
---
gnu/packages/game-development.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 4a0435045b..ca7808c0a1 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -27,6 +27,7 @@
;;; Copyright © 2021 Andy Tai <atai@atai.org>
;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 dan <i@dan.games>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2866,3 +2867,33 @@ (define-public recastnavigation
progresses the level, or you may regenerate tiles as the world changes.")
(home-page "https://github.com/recastnavigation/recastnavigation")
(license license:zlib))))
+
+(define-public raylib
+ (package
+ (name "raylib")
+ (version "4.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/raysan5/raylib/")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14v5iwxh8grywiyw9agpd2sfpyriq1rwwkd9f2s4iihh0z5j7hk8"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f)) ;no test
+ (inputs (list alsa-lib
+ libx11
+ libxrandr
+ libxi
+ libxinerama
+ libxcursor
+ mesa))
+ (native-inputs (list pkg-config))
+ (synopsis "C library for videogame programming")
+ (description
+ "raylib is a simple and easy-to-use library to enjoy videogames programming.")
+ (home-page "https://www.raylib.com/")
+ (license license:zlib)))
--
2.38.1
(
CP01PFEY4VF9.3W4C9T3BFIVGA@guix-framework
Heya,

* gnu/packages/game-development.scm (raylib): New variable.

Nice! :D

--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm

@@ -2866,3 +2867,33 @@ (define-public recastnavigation

+ (arguments
+ '(#:tests? #f)) ;no test

``(list ...)'' is preferred to ``'()'' for arguments now:

(arguments
(list #:tests? #f))

+ (description
+ "raylib is a simple and easy-to-use library to enjoy videogames programming.")

A bit markety, imo. How about this?

(description
"raylib is a high-level library for video game programming. It aims to
abstract away platform and graphics details, allowing you to focus on
writing your game.")

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmOXcOYACgkQ7ImHg/nq
I21wbQv/QZ5iq4X5TiKfOk3XD9uofzOFFjwkeMQ4+rIpyaMp/4Kc6DZYe1xPUNDG
Pq1uXArbhfBUN/RbWlBgucihiZCRAk2gAU9D53Jb++sgAtSWIwa07r/AvDUzJJCF
oE9fsGhcSE8rRPAQxCBq2Gwf2rUsxcTmPMc6L6DPjZKZxxbkwXANswFIfkPvFWkw
tmLW2fH7/Aa1WFqMs5Ncekp6945GpdvTxt0SND6vJrCGzt5jteJRxBlQseoi3UTV
z8BSslNWaqhoSet8zfhdl3U2m82XbXp2o0xONHgi9ElRPBCG9em8h06A6QTpw+WW
abBm1dawgDhM1FIUs1qbPg4NFRK6nIsNkM86RhJzqF52HKz4ovsTp12S8q1DEpX1
aN2qVGCEl9xxoZDT+lA/8eMMjR+BizrIHjBldNGCYA/L4ctYSVrA2E5owoD3A0Fb
uggklWS5Unj1l21klq+8hFxHTqg7Ycio1CVDTZLtvqD37LTnVB/+TQsDNXtlLRz3
XJoPv31Q
=8EAH
-----END PGP SIGNATURE-----


D
[PATCH] gnu: Add raylib.
(address . 60008@debbugs.gnu.org)
20221212235911.30300-1-i@dan.games
* gnu/packages/game-development.scm (raylib): New variable.
---
gnu/packages/game-development.scm | 33 +++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 4a0435045b..7bdc6a8818 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -27,6 +27,7 @@
;;; Copyright © 2021 Andy Tai <atai@atai.org>
;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 dan <i@dan.games>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2866,3 +2867,35 @@ (define-public recastnavigation
progresses the level, or you may regenerate tiles as the world changes.")
(home-page "https://github.com/recastnavigation/recastnavigation")
(license license:zlib))))
+
+(define-public raylib
+ (package
+ (name "raylib")
+ (version "4.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/raysan5/raylib/")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14v5iwxh8grywiyw9agpd2sfpyriq1rwwkd9f2s4iihh0z5j7hk8"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f)) ;no test
+ (inputs (list alsa-lib
+ libx11
+ libxrandr
+ libxi
+ libxinerama
+ libxcursor
+ mesa))
+ (native-inputs (list pkg-config))
+ (synopsis "C library for videogame programming")
+ (description
+ "raylib is a high-level library for video game programming. It aims to
+ abstract away platform and graphics details, allowing you to focus on
+ writing your game.")
+ (home-page "https://www.raylib.com/")
+ (license license:zlib)))
--
2.38.1
L
L
Ludovic Courtès wrote on 17 Jan 2023 15:50
(name . dan)(address . i@dan.games)(address . 60008-done@debbugs.gnu.org)
87sfg9gqpo.fsf_-_@gnu.org
Hi,

dan <i@dan.games> skribis:

Toggle quote (2 lines)
> * gnu/packages/game-development.scm (raylib): New variable.

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60008@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60008
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch