[PATCH] gnu: Add swaynotificationcenter

  • Done
  • quality assurance status badge
Details
2 participants
  • florhizome
  • Ludovic Courtès
Owner
unassigned
Submitted by
florhizome
Severity
normal
F
F
florhizome wrote on 12 Dec 2022 13:56
(address . guix-patches@gnu.org)(name . florhizome)(address . florhizome@posteo.net)
8212c708047fca6676c6072d807794c4b2b49f9f.1670849754.git.florhizome@posteo.net
From: florhizome <florhizome@posteo.net>

* gnu/packages/wm.scm (swaynotificationcenter): New variable.
---
gnu/packages/wm.scm | 50 +++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (80 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 042a878257..86573658f4 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1724,6 +1724,56 @@ (define-public swaybg
(description "Swaybg is a wallpaper utility for Wayland compositors.")
(license license:expat))) ; MIT license
+
+(define-public swaynotificationcenter
+ (package
+ (name "swaynotificationcenter")
+ (version "0.7.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/ErikReider/SwayNotificationCenter")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "1xvr5m5sqznr3dd512i5pk0d56v7n0ywdcy6rnz85vbf2k7b6kj5"))))
+ (build-system meson-build-system)
+ (arguments (list #:configure-flags #~(list "-Dsystemd-service=false")))
+ (native-inputs
+ (list `(,glib "bin")
+ gobject-introspection
+ pkg-config
+ python-minimal
+ scdoc
+ vala-next))
+ (inputs
+ (list json-glib
+ glib
+ gtk+
+ gtk-layer-shell
+ libhandy
+ wayland-protocols))
+ (synopsis "A simple notification daemon with a GTK gui built for
+ Notifications and the control center")
+ (description "Features
+@itemize
+@item Keyboard shortcuts
+@item Notification body markup with image support
+@item A panel to view previous notifications
+@item Show album art for notifications like Spotify
+@item Do not disturb
+@item Click notification to execute default action
+@item Show alternative notification actions
+@item Customization through a CSS file
+@item Trackpad/mouse gesture to close notification
+@item The same features as any other basic notification daemon
+@item Basic configuration through a JSON config file
+@item Hot-reload config through swaync-client
+@end itemize")
+ (home-page "https://github.com/ErikReider/SwayNotificationCenter")
+ (license license:expat)))
+
(define-public waybar
(package
(name "waybar")

base-commit: 0ce1f82e5aaac951b21d579eb46bf75cfe6713c0
prerequisite-patch-id: 36ae907c0ae2cbc001f774c0514ab217855270c2
prerequisite-patch-id: f85768858f3a8b1ef44b6e355dcd7f9254c07d24
prerequisite-patch-id: 2c99b804c1a929fc9d74b4c3d92263cbd296f785
prerequisite-patch-id: 2525aea715c2eb5be5f61e2e14296a36898413ca
prerequisite-patch-id: f7afbf36e2776eced1e69090ec127a40456efca4
prerequisite-patch-id: ba73cf06ab2610e36d03df1f6b6a1c4b8f271cda
prerequisite-patch-id: 9ac4b32603488e776af63831ff13406c649a8686
prerequisite-patch-id: 1cec3e6ed7a13938c53c24f816056d98b2b005c7
prerequisite-patch-id: 011ca6e0eaf4ea7077787d7030f193836c30aa82
prerequisite-patch-id: 4243cf3f6370445e6d583f03231e87921f541cc2
prerequisite-patch-id: 6c88bfec7b2fa53face9523329de4a9102149772
prerequisite-patch-id: d1bed6e8da46c3d6f4017546f7a00c001e814fe1
prerequisite-patch-id: 1ff1bcd9503a2b38ca7cc59ebdcebb45f970cf1a
prerequisite-patch-id: 4aa5ec94c128f5b6b6b6709c25baa49fffa571f6
prerequisite-patch-id: cb8f4f83e84db03ffa3c6be6c6b0df2ef0b59422
--
2.38.1
L
L
Ludovic Courtès wrote on 17 Jan 2023 15:53
(address . florhizome@posteo.net)(address . 60005-done@debbugs.gnu.org)
87o7qxgqkg.fsf@gnu.org
Hi,

florhizome@posteo.net skribis:

Toggle quote (4 lines)
> From: florhizome <florhizome@posteo.net>
>
> * gnu/packages/wm.scm (swaynotificationcenter): New variable.

Applied with the changes below, as per our guidelines.

Thanks,
Ludo’.
Toggle diff (43 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index bfe4fe15ed..9a18580753 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1727,15 +1727,14 @@ (define-public swaynotificationcenter
(package
(name "swaynotificationcenter")
(version "0.7.3")
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/ErikReider/SwayNotificationCenter")
- (commit (string-append "v" version))))
- (sha256
- (base32 "1xvr5m5sqznr3dd512i5pk0d56v7n0ywdcy6rnz85vbf2k7b6kj5"))))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ErikReider/SwayNotificationCenter")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xvr5m5sqznr3dd512i5pk0d56v7n0ywdcy6rnz85vbf2k7b6kj5"))))
(build-system meson-build-system)
(arguments (list #:configure-flags #~(list "-Dsystemd-service=false")))
(native-inputs
@@ -1752,9 +1751,11 @@ (define-public swaynotificationcenter
gtk-layer-shell
libhandy
wayland-protocols))
- (synopsis "A simple notification daemon with a GTK gui built for
- Notifications and the control center")
- (description "Features
+ (synopsis "Notification daemon with a graphical interface")
+ (description
+ "This package provides a notification daemon for the Sway Wayland
+compository, supporting the following featuers:
+
@itemize
@item Keyboard shortcuts
@item Notification body markup with image support
Closed
?