Jeremiah wrote 2 years ago
(address . bug-guix@gnu.org)
If one adds the following to their guix configuration:
(file-system
(mount-point "/srv/share")
(device "username@server:/mountpoint/")
(type "fuse.sshfs")
;; sshfs can't be set to #t or you'll get a weird error and no explaination
;; So that is a lovely bug in guix
(mount? #f)
(options "noauto,users,allow_other,IdentityFile=/root/.ssh/credential"))
and changes mount? to #t guix reconfigure will fail with a hard to
understand debug trace.
So either guix needs to make a meaningful error message or fix why it
currently doesn't allow sshfs filesystems to automount on boot
-Jeremiah