[PATCH] gnu: Add minetest-mobs-monster

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal

Debbugs page

Vivien Kraus wrote 2 years ago
(address . guix-patches@gnu.org)
ea5c53bd0c79f7689a453175036ea1a3cee73b19.camel@planete-kraus.eu
* gnu/packages/minetest.scm (minetest-mobs-monster): New variable.
---
gnu/packages/minetest.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/minetest.scm b/gnu/packages/minetest.scm
index 0f017217de..c898e76180 100644
--- a/gnu/packages/minetest.scm
+++ b/gnu/packages/minetest.scm
@@ -472,6 +472,31 @@ (define-public minetest-mobs-animal
(license (list license:cc0 license:expat))
(properties `((upstream-name . "TenPlus1/mobs_animal")))))
+(define-public minetest-mobs-monster
+ (package
+ (name "minetest-mobs-monster")
+ ;; Upstream does not use version numbers, so use the release title
+ ;; from ContentDB instead;
+ (version "2022-12-10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://notabug.org/TenPlus1/mobs_monster")
+ (commit "1b197f9ae136179a764ef45824464b667ade52e6")))
+ (sha256
+ (base32 "15g8acrzvsiccxchfmgjhyf2lmkbrpdjqv3v7hmqz7xqypi8wm3h"))
+ (file-name (git-file-name name version))))
+ (build-system minetest-mod-build-system)
+ (propagated-inputs (list minetest-mobs))
+ (home-page "https://notabug.org/TenPlus1/mobs_monster")
+ (synopsis "Add monsters with Mobs Redo on minetest")
+ (description
+ "This Minetest mod adds many types of monsters to Minetest, that live on the
+surface or deep underground.")
+ (license license:expat)
+ (properties `((upstream-name . "TenPlus1/mobs_monster")))))
+
(define-public minetest-pipeworks
(package
(name "minetest-pipeworks")

base-commit: 0ce1f82e5aaac951b21d579eb46bf75cfe6713c0
--
2.38.1
Ludovic Courtès wrote 2 years ago
(name . Vivien Kraus)(address . vivien@planete-kraus.eu)(address . 59965-done@debbugs.gnu.org)
87v8lfr7o4.fsf@gnu.org
Vivien Kraus <vivien@planete-kraus.eu> skribis:

Toggle quote (2 lines)
> * gnu/packages/minetest.scm (minetest-mobs-monster): New variable.

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59965@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59965
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help