[PATCH] gnu: Add minetest-wielded-light

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal
V
V
Vivien Kraus wrote on 11 Dec 2022 14:23
(address . guix-patches@gnu.org)
dc3c64dcebff9e9f3fde0eb8466c019e7cba3c6b.camel@planete-kraus.eu
* gnu/packages/minetest.scm (minetest-wielded-light): New variable.
---
gnu/packages/minetest.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/minetest.scm b/gnu/packages/minetest.scm
index 0f017217de..4e473c9d2b 100644
--- a/gnu/packages/minetest.scm
+++ b/gnu/packages/minetest.scm
@@ -769,3 +769,23 @@ (define-public minetest-oneblock
block or item from the oneblock to expand the island!")
(license license:gpl3+)
(properties `((upstream-name . "NO11/oneblock")))))
+
+(define-public minetest-wielded-light
+ (package
+ (name "minetest-wielded-light")
+ (version "2022-06-24")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/minetest-mods/wielded_light")
+ (commit "b5236562af9772dff8522fe2bda5b5f738e81b88")))
+ (sha256
+ (base32
+ "0m5rf8wkc9iq04xppjfva9d83qmhlnx8fibdbi2d3pkwwl6p2y5c"))
+ (file-name (git-file-name name version))))
+ (build-system minetest-mod-build-system)
+ (home-page (minetest-topic 19378))
+ (synopsis "Adds shining for wielded and dropped items")
+ (description "All bright nodes lighten the player environment if wielded.")
+ (license license:gpl3)
+ (properties `((upstream-name . "bell07/wielded_light")))))

base-commit: 0ce1f82e5aaac951b21d579eb46bf75cfe6713c0
--
2.38.1
L
L
Ludovic Courtès wrote on 9 Jan 2023 17:30
(name . Vivien Kraus)(address . vivien@planete-kraus.eu)(address . 59964-done@debbugs.gnu.org)
87zgarr7qa.fsf@gnu.org
Vivien Kraus <vivien@planete-kraus.eu> skribis:

Toggle quote (2 lines)
> * gnu/packages/minetest.scm (minetest-wielded-light): New variable.

Hi! Applied with the changes below, thanks!

Ludo’.
Toggle diff (15 lines)
diff --git a/gnu/packages/minetest.scm b/gnu/packages/minetest.scm
index 4e473c9d2b..0ee6690826 100644
--- a/gnu/packages/minetest.scm
+++ b/gnu/packages/minetest.scm
@@ -786,6 +786,8 @@ (define-public minetest-wielded-light
(build-system minetest-mod-build-system)
(home-page (minetest-topic 19378))
(synopsis "Adds shining for wielded and dropped items")
- (description "All bright nodes lighten the player environment if wielded.")
- (license license:gpl3)
+ (description
+ "With this Minetest extension, all bright nodes lighten the player
+environment if wielded.")
+ (license license:gpl3+)
(properties `((upstream-name . "bell07/wielded_light")))))
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59964@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59964
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch